aboutsummaryrefslogtreecommitdiff
path: root/games/warsow
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-23 10:08:05 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-23 10:08:05 +0000
commite2d204295352a2573d613016860581b233e3d6e2 (patch)
tree686fb319d0e9ac9ff2f072bc0e34e59c650ba573 /games/warsow
parent0aee5348b846fb3a56c7706bfb1a860e26c7a758 (diff)
downloadports-e2d204295352a2573d613016860581b233e3d6e2.tar.gz
ports-e2d204295352a2573d613016860581b233e3d6e2.zip
- Update to version 0.6.2
- Remove stale master sites - Adjust COMMENT slightly; avoid full stop in a comment in post-patch - Build angelwrap library (cf. PR ports/155268) Feature safe: yes
Notes
Notes: svn path=/head/; revision=286299
Diffstat (limited to 'games/warsow')
-rw-r--r--games/warsow/Makefile31
-rw-r--r--games/warsow/distinfo4
-rw-r--r--games/warsow/pkg-plist3
3 files changed, 19 insertions, 19 deletions
diff --git a/games/warsow/Makefile b/games/warsow/Makefile
index 8972e8ffc32f..6a8dd68a2c4e 100644
--- a/games/warsow/Makefile
+++ b/games/warsow/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= warsow
-PORTVERSION= 0.6
+PORTVERSION= 0.6.2
CATEGORIES= games
-MASTER_SITES= http://www.zcdn.org/dl/ \
- http://www.derchris.eu/warsow/
-DISTNAME= ${PORTNAME}_${PORTVERSION}_sdk
+MASTER_SITES= http://www.zcdn.org/dl/
+DISTNAME= ${PORTNAME}_${PORTVERSION:R}${PORTVERSION:E}_sdk
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= A fast paced first person shooter game
+COMMENT= A futuristic, fast-paced first person shooter
LICENSE= GPLv2
@@ -26,9 +25,10 @@ USE_GMAKE= yes
USE_ZIP= yes
WRKSRC= ${WRKDIR}/source
-ALL_TARGET= game
+ALL_TARGET= game angelwrap
RELEASEDIR= ${WRKSRC}/release
-WSWSUBDIR= basewsw
+AS_SDK_DIR= ${WRKSRC}/../libsrcs/angelscript/angelSVN/sdk
+WSWSUBDIR= basewsw libs
OPTIONS= CLIENT "Build client executable" on \
SERVER "Build dedicated server executable" on \
@@ -67,10 +67,6 @@ PLIST_SUB+= SERVER="@comment "
LIB_DEPENDS+= vorbisfile.6:${PORTSDIR}/audio/libvorbis
.endif
-.if !(defined(WITHOUT_QF) && defined(WITHOUT_OPENAL) && defined(WITHOUT_IRC))
-WSWSUBDIR+= libs
-.endif
-
.if !defined(WITHOUT_QF)
USE_SDL= yes
ALL_TARGET+= qf
@@ -105,12 +101,12 @@ PLIST_SUB+= TVSERVER="@comment "
PLIST_SUB+= ARCH=${ARCH}
post-patch: .SILENT
-# Unmute build and link commands, respect CFLAGS
+# Unmute build and link commands, respect CFLAGS, fix hardcoded make(1)
${REINPLACE_CMD} -e 's|@$$(DO_CC|$$(DO_CC| ; /> Linking $$@/d ; \
- s|-O2 -fno-strict-aliasing -ffast-math -funroll-loops ||' \
- ${WRKSRC}/Makefile
-# Search directory provided by warsow-data port instead of current. Doing
-# so allows us not to install any wrapper scripts.
+ s|-O2 -fno-strict-aliasing -ffast-math -funroll-loops || ; \
+ s|make -C|$$(MAKE) -C|' ${WRKSRC}/Makefile
+# Search directory provided by warsow-data port instead of current (doing
+# so allows us not to install any wrapper scripts)
${REINPLACE_CMD} -e 's|path", "\.|path", "${DATADIR}|' \
${WRKSRC}/qcommon/files.c
# Adjust architecture names, get rid of ``freebsd_'' prefix
@@ -124,6 +120,9 @@ post-patch: .SILENT
${WRKSRC}/qcommon/net.c
${REINPLACE_CMD} -e '19s|^|#include <stdint.h>|' \
${WRKSRC}/unix/unix_xpm.c
+# Fix AngelScript build on 64-bit arches
+ ${REINPLACE_CMD} -e '/GetCurrentThreadId/!s|asDWORD|pthread_t| ; \
+ s|(asDWORD)||' ${AS_SDK_DIR}/angelscript/source/as_thread.*
do-install:
.for b in ${WSWBIN}
diff --git a/games/warsow/distinfo b/games/warsow/distinfo
index 542ddf178b1d..c12e411e6529 100644
--- a/games/warsow/distinfo
+++ b/games/warsow/distinfo
@@ -1,2 +1,2 @@
-SHA256 (warsow/warsow_0.6_sdk.zip) = d88e5ee2dc1b2bd81fd1f5787b6f09aae76348cec638c1a8262072e214c93ad7
-SIZE (warsow/warsow_0.6_sdk.zip) = 36597211
+SHA256 (warsow/warsow_0.62_sdk.zip) = e1a86c355307539b8f427a76fc54e7279f39567a9eb570accd8ad74f4bf96159
+SIZE (warsow/warsow_0.62_sdk.zip) = 36600605
diff --git a/games/warsow/pkg-plist b/games/warsow/pkg-plist
index be9196df3edc..c73427d1b44a 100644
--- a/games/warsow/pkg-plist
+++ b/games/warsow/pkg-plist
@@ -4,7 +4,8 @@
%%CLIENT%%%%DATADIR%%/basewsw/cgame_%%ARCH%%.so
%%DATADIR%%/basewsw/game_%%ARCH%%.so
%%CLIENT%%%%DATADIR%%/basewsw/ui_%%ARCH%%.so
+%%DATADIR%%/libs/angelwrap_%%ARCH%%.so
%%IRC%%%%DATADIR%%/libs/irc_%%ARCH%%.so
%%OPENAL%%%%DATADIR%%/libs/snd_openal_%%ARCH%%.so
%%QF%%%%DATADIR%%/libs/snd_qf_%%ARCH%%.so
-%%IRC%%%%OPENAL%%%%QF%%@dirrm %%DATADIR%%/libs
+@dirrm %%DATADIR%%/libs