aboutsummaryrefslogtreecommitdiff
path: root/games/warzone/Makefile
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-09-16 11:07:08 +0000
committerSimon Barner <barner@FreeBSD.org>2005-09-16 11:07:08 +0000
commit4eac9f1b182ef9e0273b2857517bcb96a1a9000d (patch)
tree3f3631191bf07c9022190f3c40f4b80b2ab53d8b /games/warzone/Makefile
parent30915f5be3d81839c31ecf00c611342c99d0dcd3 (diff)
downloadports-4eac9f1b182ef9e0273b2857517bcb96a1a9000d.tar.gz
ports-4eac9f1b182ef9e0273b2857517bcb96a1a9000d.zip
Notes
Diffstat (limited to 'games/warzone/Makefile')
-rw-r--r--games/warzone/Makefile79
1 files changed, 79 insertions, 0 deletions
diff --git a/games/warzone/Makefile b/games/warzone/Makefile
new file mode 100644
index 000000000000..4103f01a9c1f
--- /dev/null
+++ b/games/warzone/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: warzone2100
+# Date created: 21 Aug 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= warzone2100
+PORTVERSION= 0.2.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Innovative 3D real-time strategy game
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ mad.2:${PORTSDIR}/audio/libmad \
+ ogg.5:${PORTSDIR}/audio/libogg \
+ openal.0:${PORTSDIR}/audio/openal \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GL= yes
+USE_SDL= net sdl
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-transform-name=""
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib"
+
+SUB_FILES= warzone
+
+post-patch:
+# Remove "-m32" flag
+ @${REINPLACE_CMD} -e 's|-m32||' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT} \
+ ${WRKSRC}/makerules/common.mk
+
+# Fix SDL include statement
+.for f in configure *.c *.h
+ @${FIND} ${WRKSRC} -type f -name "${f}" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e \
+ 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|'
+.endfor
+
+do-install:
+# Script
+ @${INSTALL_SCRIPT} ${WRKDIR}/warzone ${PREFIX}/bin
+
+# Program
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/warzone ${PREFIX}/libexec
+
+# Data
+ @${MKDIR} ${DATADIR}
+ @${CP} -R ${WRKSRC}/data/* ${DATADIR}
+
+# Documentation
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+post-install:
+# Fix permissions
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
+ @${FIND} ${DATADIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} ${SHAREMODE}
+ @${FIND} ${DATADIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} ${BINMODE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not compile (missing stdint.h)
+.endif
+
+.include <bsd.port.post.mk>