aboutsummaryrefslogtreecommitdiff
path: root/games/warzone2100/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-04 21:59:05 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-04 21:59:05 +0000
commit875961060879771a0b7af0e60908c4f6e9878108 (patch)
treef3bbd628769e64052731ac77de66e02a49554867 /games/warzone2100/Makefile
parent1fb2567105045cc39e7732952d740458b39e4ebd (diff)
downloadports-875961060879771a0b7af0e60908c4f6e9878108.tar.gz
ports-875961060879771a0b7af0e60908c4f6e9878108.zip
Notes
Diffstat (limited to 'games/warzone2100/Makefile')
-rw-r--r--games/warzone2100/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index 1ce3c89216c2..9e22c8dfa5c2 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= warzone2100
-PORTVERSION= 3.1.5
+PORTVERSION= 3.2.1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/releases/${PORTVERSION}/
@@ -15,23 +15,23 @@ BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libphysfs.so:devel/physfs \
libpng.so:graphics/png \
libvorbis.so:audio/libvorbis \
+ libogg.so:audio/libogg \
libtheora.so:multimedia/libtheora \
libfribidi.so:converters/fribidi \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
-USES= bison compiler:c++11-lang gmake localbase openal:al pkgconfig tar:xz # actually, old gcc fails on unknown -W flag
+USES= bison compiler:c++11-lib gmake localbase openal:al pkgconfig ssl tar:xz
GNU_CONFIGURE= yes
-USE_GL= glew glu
-USE_SDL= sdl
-USE_QT4= corelib network script gui moc_build
+USE_GL= gl glu glew
+USE_SDL= sdl2
+USE_XORG= x11 xrandr
+USE_QT5= core gui widgets script buildtools_build
QT_NONSTANDARD= yes
CONFIGURE_ARGS= --program-transform-name="" --with-distributor="FreeBSD ports"
-CONFIGURE_ENV= PATH="${LOCALBASE}/bin:$$PATH" \
- CCOMPILER="${CC}" \
- CXXCOMPILER="${CXX}"
-REINPLACE_ARGS= -i ''
+CONFIGURE_ENV= LIBCRYPTO_CFLAGS="-I${OPENSSLINC}" \
+ LIBCRYPTO_LIBS="-L${OPENSSLLIB} -lcrypto"
PORTDOCS= *
PORTDATA= *
@@ -48,5 +48,9 @@ MANPAGES_BUILD_DEPENDS= a2x:textproc/asciidoc
post-patch:
@${REINPLACE_CMD} -e 's|-Werror||g; s|-R$$found_dir||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|./build_tools/autorevision|& -f|g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e '/INSTALL_DATA.*warzone2100.appdata.xml/d' ${WRKSRC}/icons/Makefile.*
+
+post-install:
+ @${RMDIR} ${STAGEDIR}${PREFIX}/share/appdata
.include <bsd.port.mk>