aboutsummaryrefslogtreecommitdiff
path: root/games/warzone2100/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
commit4e1b79a0a61f4973df8b4b0864d22086c769e219 (patch)
tree78ceaf1b099c56a40c240ab46278cdf4ae9e7c01 /games/warzone2100/Makefile
parent7f4572eae4327c4403d9ef714cb6de917650662a (diff)
downloadports-4e1b79a0a61f4973df8b4b0864d22086c769e219.tar.gz
ports-4e1b79a0a61f4973df8b4b0864d22086c769e219.zip
Notes
Diffstat (limited to 'games/warzone2100/Makefile')
-rw-r--r--games/warzone2100/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index ad03b32d0d16..12e83babe41a 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -11,16 +11,16 @@ COMMENT= Innovative 3D real-time strategy game
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- unzip:${PORTSDIR}/archivers/unzip
-LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs \
- libpng.so:${PORTSDIR}/graphics/png \
- libvorbis.so:${PORTSDIR}/audio/libvorbis \
- libtheora.so:${PORTSDIR}/multimedia/libtheora \
- libfribidi.so:${PORTSDIR}/converters/fribidi \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
-RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
+BUILD_DEPENDS= zip:archivers/zip \
+ unzip:archivers/unzip
+LIB_DEPENDS= libphysfs.so:devel/physfs \
+ libpng.so:graphics/png \
+ libvorbis.so:audio/libvorbis \
+ libtheora.so:multimedia/libtheora \
+ libfribidi.so:converters/fribidi \
+ libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
+RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
USES= bison compiler:c++11-lang gmake localbase openal:al pkgconfig tar:xz # actually, old gcc fails on unknown -W flag
GNU_CONFIGURE= yes
@@ -44,7 +44,7 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-MANPAGES_BUILD_DEPENDS= a2x:${PORTSDIR}/textproc/asciidoc
+MANPAGES_BUILD_DEPENDS= a2x:textproc/asciidoc
post-patch:
@${REINPLACE_CMD} -e 's|-Werror||g; s|-R$$found_dir||g' ${WRKSRC}/configure