aboutsummaryrefslogtreecommitdiff
path: root/games/warzone2100
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-09-12 23:51:54 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-09-12 23:51:54 +0000
commit736e980d963f056ac739992d2250db2a6894a370 (patch)
treea92cf8e2bae6f4bb0e705cc94ac8ef6d9d8fe672 /games/warzone2100
parent431622844fcecf9286bca43cbdd9e3ae5ff5e273 (diff)
downloadports-736e980d963f056ac739992d2250db2a6894a370.tar.gz
ports-736e980d963f056ac739992d2250db2a6894a370.zip
Notes
Diffstat (limited to 'games/warzone2100')
-rw-r--r--games/warzone2100/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index cf318404488e..de7297afe148 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -35,8 +35,13 @@ CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include \
`${SDL_CONFIG} --cflags`
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+.include <bsd.port.pre.mk>
+
post-patch:
- @${REINPLACE_CMD} -e '/stdint.h/d' ${WRKSRC}/lib/ivis_opengl/screen.c
+.if ${OSVERSION} < 5000000
+ @${REINPLACE_CMD} -e 's|<stdint\.h>|<inttypes.h>|' \
+ ${WRKSRC}/lib/framework/types.h
+.endif
@${REINPLACE_CMD} -e \
's|-m32||; \
s|/usr/local|${LOCALBASE}|; \
@@ -53,4 +58,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>