aboutsummaryrefslogtreecommitdiff
path: root/games/warzone2100
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-08-31 22:39:04 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-08-31 22:39:04 +0000
commit8a15aa5afe7965a112b85f167d176a2c0c4c9768 (patch)
tree0e5809b1c1c260655b49f5e2973b6c33c19559d2 /games/warzone2100
parent0cb600852cb92340eba2bab87573ad5cde2915cc (diff)
downloadports-8a15aa5afe7965a112b85f167d176a2c0c4c9768.tar.gz
ports-8a15aa5afe7965a112b85f167d176a2c0c4c9768.zip
Notes
Diffstat (limited to 'games/warzone2100')
-rw-r--r--games/warzone2100/Makefile56
-rw-r--r--games/warzone2100/distinfo3
-rw-r--r--games/warzone2100/files/patch-src__loop.c13
-rw-r--r--games/warzone2100/files/patch-src__seqdisp.c22
-rw-r--r--games/warzone2100/pkg-descr13
-rw-r--r--games/warzone2100/pkg-message22
-rw-r--r--games/warzone2100/pkg-plist6
7 files changed, 135 insertions, 0 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
new file mode 100644
index 000000000000..cf318404488e
--- /dev/null
+++ b/games/warzone2100/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: warzone2100
+# Date created: 21 Aug 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= warzone2100
+PORTVERSION= 2.0.4
+CATEGORIES= games
+MASTER_SITES= http://download.gna.org/warzone/releases/2.0/
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Innovative 3D real-time strategy game
+
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ mad.2:${PORTSDIR}/audio/libmad \
+ ogg.5:${PORTSDIR}/audio/libogg \
+ openal.0:${PORTSDIR}/audio/openal \
+ physfs-1.0.1:${PORTSDIR}/devel/physfs \
+ png.5:${PORTSDIR}/graphics/png \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+USE_BZIP2= yes
+USE_BISON= yes
+USE_GL= yes
+USE_SDL= net sdl
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-transform-name=""
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ LIBS="${PTHREAD_LIBS}"
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include \
+ `${SDL_CONFIG} --cflags`
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e '/stdint.h/d' ${WRKSRC}/lib/ivis_opengl/screen.c
+ @${REINPLACE_CMD} -e \
+ 's|-m32||; \
+ s|/usr/local|${LOCALBASE}|; \
+ s|/usr/X11R6|${X11BASE}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+.for f in configure *.c *.h
+ @${FIND} ${WRKSRC} -type f -name "${f}" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e 's|SDL/||'
+.endfor
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/warzone2100/distinfo b/games/warzone2100/distinfo
new file mode 100644
index 000000000000..995003794ad3
--- /dev/null
+++ b/games/warzone2100/distinfo
@@ -0,0 +1,3 @@
+MD5 (warzone2100-2.0.4.tar.bz2) = 84e92061d9a00405994ab7496d03a610
+SHA256 (warzone2100-2.0.4.tar.bz2) = 06ce1d72ec1c3ffceed8f5aae77b96442469abe3096caebc5ce43b1178aee9b5
+SIZE (warzone2100-2.0.4.tar.bz2) = 19883711
diff --git a/games/warzone2100/files/patch-src__loop.c b/games/warzone2100/files/patch-src__loop.c
new file mode 100644
index 000000000000..7deef6c8f62f
--- /dev/null
+++ b/games/warzone2100/files/patch-src__loop.c
@@ -0,0 +1,13 @@
+--- src/loop.c 2006/08/26 15:50:47 289
++++ src/loop.c 2006/08/29 19:57:34 304
+@@ -1085,7 +1085,7 @@
+ paused = FALSE;
+ video = FALSE;
+ gameTimeStart();
+-// pie_SetFogStatus(TRUE);
++ pie_SetFogStatus(TRUE);
+ cdAudio_Resume();
+ ASSERT( videoMode == 0,"loop_ClearVideoPlaybackMode: out of sync." );
+ }
+
+
diff --git a/games/warzone2100/files/patch-src__seqdisp.c b/games/warzone2100/files/patch-src__seqdisp.c
new file mode 100644
index 000000000000..8687b9d2ebbf
--- /dev/null
+++ b/games/warzone2100/files/patch-src__seqdisp.c
@@ -0,0 +1,22 @@
+--- src/seqdisp.c 2006/08/27 19:09:35 298
++++ src/seqdisp.c 2006/08/29 19:57:34 304
+@@ -384,13 +384,14 @@
+ //full screenvideo functions
+ BOOL seq_StartFullScreenVideo(char* videoName, char* audioName)
+ {
+- bHoldSeqForAudio = FALSE;
+-
+ #ifdef DUMMY_VIDEO
+ debug( LOG_VIDEO, "seq_StartFullScreenVideo: Refusing to play video! (Not a bug)" );
+- return FALSE;
++ // FIXME We probably should call something like eventFireCallbackTrigger((TRIGGER_TYPE)CALL_VIDEO_QUIT); here!
++ return TRUE;
+ #endif
+
++ bHoldSeqForAudio = FALSE;
++
+ frameSkip = 1;
+ switch(war_GetSeqMode())
+ {
+
+
diff --git a/games/warzone2100/pkg-descr b/games/warzone2100/pkg-descr
new file mode 100644
index 000000000000..c22cf0226aa2
--- /dev/null
+++ b/games/warzone2100/pkg-descr
@@ -0,0 +1,13 @@
+Warzone 2100 was an innovative 3D real-time strategy game back in 1999, and
+most will agree it didn't enjoy the commercial success it should have had. The
+game's source code was liberated on December 6th, 2004, under a GPL license
+(see COPYING in this directory for details). Soon after that, the Warzone 2100
+ReDev project was formed to take care of its future.
+
+Our goal is to make warzone run on all possible platforms. Therefore, we
+stripped the original code of all proprietary technologies and replaced them
+with cross-platform and free equivalents, like OpenGL, OpenAL, etc... Right
+now, Warzone 2100 works very well on Windows and GNU/Linux, and we have even
+heard of it running on BSD with no particular issue.
+
+WWW: http://wz.rootzilla.de/site/
diff --git a/games/warzone2100/pkg-message b/games/warzone2100/pkg-message
new file mode 100644
index 000000000000..155d7920e78c
--- /dev/null
+++ b/games/warzone2100/pkg-message
@@ -0,0 +1,22 @@
+==============================================================================
+
+Warzone2100 has been installed.
+
+If the game locks up in heavy fight (e.g. many units firing at each other) try
+to set OPENAL_BUFFER_SIZE to 8192 before running it.
+
+$ env OPENAL_BUFFER_SIZE=8192 warzone
+
+Or set the environment variable in your shell's configuration file (you can
+also run these commands directly from the command-line).
+
+For sh/bash add in your /etc/profile or ~/.profile:
+OPENAL_BUFFER_SIZE=8192
+export OPENAL_BUFFER_SIZE
+
+For csh/tcsh add in your /etc/csh.cshrc or ~/.cshrc:
+setenv OPENAL_BUFFER_SIZE=8192
+
+Enjoy!
+
+==============================================================================
diff --git a/games/warzone2100/pkg-plist b/games/warzone2100/pkg-plist
new file mode 100644
index 000000000000..e26ee908b1c7
--- /dev/null
+++ b/games/warzone2100/pkg-plist
@@ -0,0 +1,6 @@
+bin/warzone2100
+%%DATADIR%%/mp.wz
+%%DATADIR%%/warzone.wz
+%%PORTDOCS%%%%DOCSDIR%%/README
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%