aboutsummaryrefslogtreecommitdiff
path: root/games/warzone2100
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-14 14:22:08 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-14 14:22:08 +0000
commit8a1a39031b79e8e3915825211f6c004338232aa9 (patch)
treedb5db4581d5c2c90f8fd8941b42b0788f2482dc6 /games/warzone2100
parentc1c123d63ad9910b589d0fb2938ef3f129ce2ca1 (diff)
downloadports-8a1a39031b79e8e3915825211f6c004338232aa9.tar.gz
ports-8a1a39031b79e8e3915825211f6c004338232aa9.zip
Notes
Diffstat (limited to 'games/warzone2100')
-rw-r--r--games/warzone2100/Makefile6
-rw-r--r--games/warzone2100/files/patch-lib__ivis_opengl__screen.cpp6
-rw-r--r--games/warzone2100/files/patch-lib__netplay__netsocket.cpp6
3 files changed, 8 insertions, 10 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index ae08cf59ded6..c48d73e07c44 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -8,7 +8,7 @@ MASTER_SITES= SF/${PORTNAME}/releases/${PORTVERSION}/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Innovative 3D real-time strategy game
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
@@ -22,7 +22,7 @@ LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
-USES= tar:xz bison gmake openal:al pkgconfig compiler:c++11-lang # actually, old gcc fails on unknown -W flag
+USES= bison compiler:c++11-lang gmake localbase openal:al pkgconfig tar:xz # actually, old gcc fails on unknown -W flag
GNU_CONFIGURE= yes
USE_GL= glew glu
USE_SDL= sdl
@@ -32,8 +32,6 @@ CONFIGURE_ARGS= --program-transform-name="" --with-distributor="FreeBSD ports"
CONFIGURE_ENV= PATH="${LOCALBASE}/bin:$$PATH" \
CCOMPILER="${CC}" \
CXXCOMPILER="${CXX}"
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
REINPLACE_ARGS= -i ''
PORTDOCS= *
diff --git a/games/warzone2100/files/patch-lib__ivis_opengl__screen.cpp b/games/warzone2100/files/patch-lib__ivis_opengl__screen.cpp
index 56125eb0e6cf..5775c330f1e8 100644
--- a/games/warzone2100/files/patch-lib__ivis_opengl__screen.cpp
+++ b/games/warzone2100/files/patch-lib__ivis_opengl__screen.cpp
@@ -1,6 +1,6 @@
---- lib/ivis_opengl/screen.cpp.orig 2013-12-12 06:20:34.000000000 +0400
-+++ lib/ivis_opengl/screen.cpp 2014-08-18 16:11:06.000000000 +0400
-@@ -261,7 +261,7 @@
+--- lib/ivis_opengl/screen.cpp.orig 2013-12-12 02:20:34 UTC
++++ lib/ivis_opengl/screen.cpp
+@@ -261,7 +261,7 @@ void screen_EnableMissingFunctions()
__glewUseProgram = __glewUseProgramObjectARB;
__glewGetShaderiv = __glewGetObjectParameterivARB;
__glewLinkProgram = __glewLinkProgramARB;
diff --git a/games/warzone2100/files/patch-lib__netplay__netsocket.cpp b/games/warzone2100/files/patch-lib__netplay__netsocket.cpp
index 19659e55fc55..04d2f54d6dea 100644
--- a/games/warzone2100/files/patch-lib__netplay__netsocket.cpp
+++ b/games/warzone2100/files/patch-lib__netplay__netsocket.cpp
@@ -1,6 +1,6 @@
---- lib/netplay/netsocket.cpp.orig 2013-01-15 03:54:07.000000000 +0400
-+++ lib/netplay/netsocket.cpp 2013-01-18 19:32:35.110932805 +0400
-@@ -1399,9 +1399,6 @@
+--- lib/netplay/netsocket.cpp.orig 2013-11-24 01:25:10 UTC
++++ lib/netplay/netsocket.cpp
+@@ -1399,9 +1399,6 @@ SocketAddress *resolveHost(const char *h
hint.ai_family = AF_UNSPEC;
hint.ai_socktype = SOCK_STREAM;
hint.ai_protocol = 0;