aboutsummaryrefslogtreecommitdiff
path: root/games/warzone2100
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-01-30 19:10:42 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-01-30 19:10:42 +0000
commitcc7e777f8138d07de0b29457ff46dbe847c3682e (patch)
tree950248826f5e62914cadd6594296fb70b57f9b54 /games/warzone2100
parent90c7b4e4afe7fd38c5b441344054471742eff827 (diff)
downloadports-cc7e777f8138d07de0b29457ff46dbe847c3682e.tar.gz
ports-cc7e777f8138d07de0b29457ff46dbe847c3682e.zip
Notes
Diffstat (limited to 'games/warzone2100')
-rw-r--r--games/warzone2100/Makefile63
-rw-r--r--games/warzone2100/distinfo4
-rw-r--r--games/warzone2100/files/patch-configure11
-rw-r--r--games/warzone2100/files/patch-lib-netplay-netsocket.cpp (renamed from games/warzone2100/files/patch-lib-netplay-netplay.c)6
-rw-r--r--games/warzone2100/pkg-plist6
5 files changed, 32 insertions, 58 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index ba6c4c8fd3b1..6d4de6481c7b 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -1,39 +1,39 @@
-# New ports collection makefile for: warzone2100
-# Date created: 21 Aug 2005
-# Whom: Alejandro Pulver <alejandro@varnet.biz>
-#
+# Create by: Alejandro Pulver <alejandro@varnet.biz>
# $FreeBSD$
-#
PORTNAME= warzone2100
-PORTVERSION= 2.3.9
-PORTREVISION= 3
+PORTVERSION= 3.1.0
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/releases/${PORTVERSION}/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Innovative 3D real-time strategy game
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- mad.2:${PORTSDIR}/audio/libmad \
- ogg:${PORTSDIR}/audio/libogg \
- physfs.1:${PORTSDIR}/devel/physfs \
+LIB_DEPENDS= physfs:${PORTSDIR}/devel/physfs \
png15:${PORTSDIR}/graphics/png \
- vorbis.4:${PORTSDIR}/audio/libvorbis \
- GLC.0:${PORTSDIR}/graphics/quesoglc \
- theora.0:${PORTSDIR}/multimedia/libtheora \
- popt.0:${PORTSDIR}/devel/popt
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ theora:${PORTSDIR}/multimedia/libtheora \
+ GLEW:${PORTSDIR}/graphics/glew \
+ fribidi:${PORTSDIR}/converters/fribidi \
+ freetype:${PORTSDIR}/print/freetype2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
+USE_XZ= yes
USE_BISON= build
GNU_CONFIGURE= yes
USE_OPENAL= al
USE_GL= yes
USE_GMAKE= yes
-USE_SDL= net sdl
+USE_SDL= sdl
+USE_QT4= corelib network script gui moc_build
+QT_NONSTANDARD= yes
CONFIGURE_ARGS= --program-transform-name="" --with-distributor="FreeBSD ports"
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}" \
PATH="${LOCALBASE}/bin:$$PATH"
@@ -42,8 +42,15 @@ LDFLAGS+= -L${LOCALBASE}/lib
REINPLACE_ARGS= -i ''
MAKE_JOBS_SAFE= yes
PORTDOCS= *
+USE_GCC= 4.6+
+
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 800000
+IGNORE= does not build on < 8.x
+.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -52,30 +59,12 @@ PLIST_SUB+= NLS="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e '/_XOPEN_SOURCE/ d' ${WRKSRC}/config.h.in
- @${REINPLACE_CMD} -e 's|NSIG|32|g; s|SIGPOLL|SIGIO|g' \
- ${WRKSRC}/lib/exceptionhandler/exceptionhandler.c
- @${REINPLACE_CMD} -e '/include.*alloca/ d' \
- ${WRKSRC}/lib/framework/config-macosx.h \
- ${WRKSRC}/lib/framework/resource_parser.tab.c \
- ${WRKSRC}/lib/framework/strres_parser.tab.c \
- ${WRKSRC}/lib/framework/wzglobal.h \
- ${WRKSRC}/lib/gamelib/audp_parser.tab.c \
- ${WRKSRC}/lib/script/chat_parser.tab.c \
- ${WRKSRC}/lib/script/script_parser.tab.c \
- ${WRKSRC}/src/message_parser.tab.c \
- ${WRKSRC}/src/scriptvals_parser.tab.c
- @${REINPLACE_CMD} -e 's|-m32||; s|-Werror||g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|AUTHORS||; s|COPYING COPYING\.README||' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e '/typedef void (\*__GLXextFuncPtr)(void);/d' \
- ${WRKSRC}/lib/ivis_opengl/GLee.h
-.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|-Werror||g' ${WRKSRC}/configure
+.if ! ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -Ee 's|install-dist_docDATA$$||' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|^install: install-am|install:|' \
${WRKSRC}/doc/Makefile.in
-.else
.endif
.include <bsd.port.mk>
diff --git a/games/warzone2100/distinfo b/games/warzone2100/distinfo
index 31013d53f7fd..c776dfb6b766 100644
--- a/games/warzone2100/distinfo
+++ b/games/warzone2100/distinfo
@@ -1,2 +1,2 @@
-SHA256 (warzone2100-2.3.9.tar.gz) = 9e843bb752c9c4798b8e6ea0edfb625f9aa2f2ba8cbfe42e31ab1c6aa9267adb
-SIZE (warzone2100-2.3.9.tar.gz) = 62509972
+SHA256 (warzone2100-3.1.0.tar.xz) = c3e24b0a2703ffe5b171401e0eb9decbe9b130d6478e64300ccfb73a60f61c03
+SIZE (warzone2100-3.1.0.tar.xz) = 67316000
diff --git a/games/warzone2100/files/patch-configure b/games/warzone2100/files/patch-configure
deleted file mode 100644
index 4b0311cc7327..000000000000
--- a/games/warzone2100/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./configure.orig 2012-07-25 12:01:59.220711135 +0200
-+++ ./configure 2012-07-25 12:02:30.934712586 +0200
-@@ -8603,7 +8603,7 @@
-
-
- for ac_prog in pkg-config; do
-- ac_prog_version_check=`$ac_prog --version | head -n 1 | sed 's/([^)]*)//g;s/^[a-zA-Z\.\ \-\/]*//;s/ .*$//'`
-+ ac_prog_version_check=`$ac_prog --modversion pkg-config | head -n 1 | sed 's/([^)]*)//g;s/^[a-zA-Z\.\ \-\/]*//;s/ .*$//'`
- ac_prog_major_check=`echo $ac_prog_version_check | cut -d. -f1`
- ac_prog_minor_check=`echo $ac_prog_version_check | sed s/[-,a-z,A-Z].*// | cut -d. -f2`
- ac_prog_micro_check=`echo $ac_prog_version_check | sed s/[-,a-z,A-Z].*// | cut -d. -f3`
diff --git a/games/warzone2100/files/patch-lib-netplay-netplay.c b/games/warzone2100/files/patch-lib-netplay-netsocket.cpp
index fd58cf6058b2..19659e55fc55 100644
--- a/games/warzone2100/files/patch-lib-netplay-netplay.c
+++ b/games/warzone2100/files/patch-lib-netplay-netsocket.cpp
@@ -1,6 +1,6 @@
---- lib/netplay/netplay.c.orig 2010-08-12 01:53:49.000000000 +0400
-+++ lib/netplay/netplay.c 2010-11-09 03:37:53.000000000 +0300
-@@ -1231,9 +1231,6 @@
+--- lib/netplay/netsocket.cpp.orig 2013-01-15 03:54:07.000000000 +0400
++++ lib/netplay/netsocket.cpp 2013-01-18 19:32:35.110932805 +0400
+@@ -1399,9 +1399,6 @@
hint.ai_family = AF_UNSPEC;
hint.ai_socktype = SOCK_STREAM;
hint.ai_protocol = 0;
diff --git a/games/warzone2100/pkg-plist b/games/warzone2100/pkg-plist
index a5e0af43817e..728bf7c7e5b0 100644
--- a/games/warzone2100/pkg-plist
+++ b/games/warzone2100/pkg-plist
@@ -5,6 +5,7 @@ share/icons/warzone2100.png
%%NLS%%share/locale/cs/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/da/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/de/LC_MESSAGES/warzone2100.mo
+%%NLS%%share/locale/el/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/es/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/et_EE/LC_MESSAGES/warzone2100.mo
@@ -32,9 +33,6 @@ share/icons/warzone2100.png
%%NLS%%share/locale/zh_CN/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/warzone2100.mo
%%DATADIR%%/base.wz
-%%DATADIR%%/mods/multiplay/dydo-ai.wz
-%%DATADIR%%/mods/multiplay/ntw.wz
-%%DATADIR%%/mods/multiplay/old-1.10-balance.wz
%%DATADIR%%/mp.wz
%%DATADIR%%/music/menu.ogg
%%DATADIR%%/music/music.wpl
@@ -42,8 +40,6 @@ share/icons/warzone2100.png
%%DATADIR%%/music/track2.ogg
%%DATADIR%%/music/track3.ogg
@dirrm %%DATADIR%%/music
-@dirrm %%DATADIR%%/mods/multiplay
-@dirrm %%DATADIR%%/mods
@dirrm %%DATADIR%%
%%NLS%%@dirrmtry share/locale/uk_UA/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/uk_UA