aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth-devel/Makefile
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2008-06-10 21:38:42 +0000
committerPhilip Paeps <philip@FreeBSD.org>2008-06-10 21:38:42 +0000
commit2fa970cca6ddb906064af196591522a0559627a3 (patch)
tree9a39b0446891bff6a1d7e1bb5d7d84160ae4e314 /games/wesnoth-devel/Makefile
parent8d79bfc6004db64a80cb8b2ed16312073b554492 (diff)
downloadports-2fa970cca6ddb906064af196591522a0559627a3.tar.gz
ports-2fa970cca6ddb906064af196591522a0559627a3.zip
Notes
Diffstat (limited to 'games/wesnoth-devel/Makefile')
-rw-r--r--games/wesnoth-devel/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/games/wesnoth-devel/Makefile b/games/wesnoth-devel/Makefile
index f4e5f7c0e02b..1326844b7621 100644
--- a/games/wesnoth-devel/Makefile
+++ b/games/wesnoth-devel/Makefile
@@ -6,24 +6,22 @@
#
PORTNAME= wesnoth
-PORTVERSION= 1.4.2
-PORTREVISION= 1
+PORTVERSION= 1.4.3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.wesnoth.org/files/
MASTER_SITE_SUBDIR= wesnoth
-LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
- freetype.9:${PORTSDIR}/print/freetype2
-
MAINTAINER= philip@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
+ freetype.9:${PORTSDIR}/print/freetype2
+
USE_SDL= image mixer net
USE_GNOME= gnometarget
USE_GMAKE= yes
WANT_GNOME= yes
-USE_GETTEXT= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var \
@@ -36,13 +34,17 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
MAN6= wesnoth.6
-MANLANG= "" ca_ES@valencia cs de fr gl_ES it ja nl sk sr@latin sv zh_CN
+MANLANG= "" ca_ES@valencia cs da de es fr gl_ES hu it ja
+MANLANG+= lt nl pl sk sr sr@latin sv tr zh_CN
OPTIONS= CAMPAIGN "Enable campaign server" On \
EDITOR "Enable map editor" On \
+ NLS "Enable localization" On \
SERVER "Enable server" On \
TOOLS "Enable extra tools for artists and translators" On
+.include <bsd.port.pre.mk>
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
@@ -62,6 +64,14 @@ MAN6+= wesnoth_editor.6
PLIST_SUB+= EDITOR=""
.endif
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
.if defined(WITHOUT_SERVER)
PLIST_SUB+= SERVER="@comment "
.else
@@ -77,8 +87,6 @@ CONFIGURE_ARGS+= --enable-tools
PLIST_SUB+= TOOLS=""
.endif
-.include <bsd.port.pre.mk>
-
post-configure:
@${REINPLACE_CMD} -e 's|[$$][{]datarootdir[}]/icons|${LOCALBASE}/share/pixmaps|' \
${WRKSRC}/icons/Makefile