aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-07-03 05:31:42 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-07-03 05:31:42 +0000
commit699110ab5e4f199f58f9efdee4a3256f8e3db964 (patch)
tree6253abb11ed59ac2291158283522174f13363fd7 /games/wesnoth/Makefile
parent27378fff5d7e53114350801a67b992a3826fbccb (diff)
downloadports-699110ab5e4f199f58f9efdee4a3256f8e3db964.tar.gz
ports-699110ab5e4f199f58f9efdee4a3256f8e3db964.zip
Notes
Diffstat (limited to 'games/wesnoth/Makefile')
-rw-r--r--games/wesnoth/Makefile20
1 files changed, 3 insertions, 17 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 3067b11e042f..e311f1833ebb 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -6,15 +6,11 @@
#
PORTNAME= wesnoth
-PORTVERSION= 0.9.2
+PORTVERSION= 0.9.3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.wesnoth.org/files/
MASTER_SITE_SUBDIR= wesnoth
-.if defined(LITE)
-PKGNAMESUFFIX= -lite
-DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
-.endif
MAINTAINER= mezz@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
@@ -42,13 +38,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN6= wesnoth.6
MANLANG= "" de
-.if defined(LITE)
-CONFIGURE_ARGS+= --enable-lite
-PLIST_SUB+= LITE:="@comment "
-.else
-PLIST_SUB+= LITE:=""
-.endif
-
.if defined(WITH_CAMPAIGN) || defined(PACKAGE_BUILDING)
CONFIGURE_ARGS+= --enable-campaign-server
PLIST_SUB+= CAMPAIGN:=""
@@ -104,13 +93,10 @@ PLIST_SUB+= KDE:="@comment "
.endif
pre-everything::
-.if !defined(LITE) || !defined(WITH_CAMPAIGN) || !defined(WITH_DEBUG) || !defined(WITH_EDITOR) || !defined(WITH_SERVER) || !defined(WITH_TOOLS)
+.if !defined(WITH_CAMPAIGN) || !defined(WITH_DEBUG) || !defined(WITH_EDITOR) || !defined(WITH_SERVER) || !defined(WITH_TOOLS)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} " "
.endif
-.if !defined(LITE)
- @${ECHO_MSG} "LITE=yes for lite version of Wesnoth (without music and story images)."
-.endif
.if !defined(WITH_CAMPAIGN)
@${ECHO_MSG} "WITH_CAMPAIGN=yes to enable compilation of campaign server."
.endif
@@ -131,6 +117,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${X11BASE}/share/gnome/applications|g ; \
s|[$$][(]datadir[)]/icons|${X11BASE}/share/gnome/pixmaps|g' \
${WRKSRC}/icons/Makefile.in
- @${FIND} ${WRKSRC} -name stamp-po -delete
+# @${FIND} ${WRKSRC} -name stamp-po -delete
.include <bsd.port.post.mk>