aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth/files
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-10-11 22:42:04 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-10-11 22:42:04 +0000
commit6f7b0b41245cee3ed8bf10b191055307eb987afc (patch)
treecb42820cf7ff1b46e5e47d875c1eb09f0b31661a /games/wesnoth/files
parente31c15dd63c85bcfe2f0a2f687596372c2e205c5 (diff)
downloadports-6f7b0b41245cee3ed8bf10b191055307eb987afc.tar.gz
ports-6f7b0b41245cee3ed8bf10b191055307eb987afc.zip
Notes
Diffstat (limited to 'games/wesnoth/files')
-rw-r--r--games/wesnoth/files/patch-configure74
-rw-r--r--games/wesnoth/files/patch-src::Makefile.in12
-rw-r--r--games/wesnoth/files/patch-src::help.cpp7
-rw-r--r--games/wesnoth/files/patch-src::scoped_resource.hpp11
4 files changed, 90 insertions, 14 deletions
diff --git a/games/wesnoth/files/patch-configure b/games/wesnoth/files/patch-configure
new file mode 100644
index 000000000000..2461bb21a243
--- /dev/null
+++ b/games/wesnoth/files/patch-configure
@@ -0,0 +1,74 @@
+--- configure.orig Tue Oct 5 23:42:20 2004
++++ configure Tue Oct 5 23:43:44 2004
+@@ -10043,36 +10043,6 @@
+
+
+
+-if test x$kde = xyes && test x$kdefound = xyes; then
+- KDE_TRUE=
+- KDE_FALSE='#'
+-else
+- KDE_TRUE='#'
+- KDE_FALSE=
+-fi
+-
+-
+-
+-if test x$gnome = xyes && test x$gnome1found = xyes; then
+- GNOME1_TRUE=
+- GNOME1_FALSE='#'
+-else
+- GNOME1_TRUE='#'
+- GNOME1_FALSE=
+-fi
+-
+-
+-
+-if test x$gnome = xyes && test x$gnome1found = xno; then
+- GNOME2_TRUE=
+- GNOME2_FALSE='#'
+-else
+- GNOME2_TRUE='#'
+- GNOME2_FALSE=
+-fi
+-
+-
+-
+ if test x$GXX = xyes; then
+ GCC_TRUE=
+ GCC_FALSE='#'
+@@ -13259,6 +13229,34 @@
+ fi
+
+
++
++if test x$kde = xyes && test x$kdefound = xyes; then
++ KDE_TRUE=
++ KDE_FALSE='#'
++else
++ KDE_TRUE='#'
++ KDE_FALSE=
++fi
++
++
++
++if test x$gnome = xyes && test x$gnome1found = xyes; then
++ GNOME1_TRUE=
++ GNOME1_FALSE='#'
++else
++ GNOME1_TRUE='#'
++ GNOME1_FALSE=
++fi
++
++
++
++if test x$gnome = xyes && test x$gnome1found = xno; then
++ GNOME2_TRUE=
++ GNOME2_FALSE='#'
++else
++ GNOME2_TRUE='#'
++ GNOME2_FALSE=
++fi
+
+
+
diff --git a/games/wesnoth/files/patch-src::Makefile.in b/games/wesnoth/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..8da0562ab287
--- /dev/null
+++ b/games/wesnoth/files/patch-src::Makefile.in
@@ -0,0 +1,12 @@
+--- src/Makefile.in.orig Tue Oct 5 23:45:33 2004
++++ src/Makefile.in Tue Oct 5 23:45:59 2004
+@@ -660,8 +660,7 @@
+ wesconfig.h
+
+ AM_CXXFLAGS = @SDL_CFLAGS@ -DWESNOTH_PATH=\"$(pkgdatadir)\" \
+- -DLOCALEDIR=\"$(LOCALEDIR)\" -DHAS_RELATIVE_LOCALEDIR=$(HAS_RELATIVE_LOCALEDIR) \
+- -I../intl -I$(top_srcdir)/intl
++ -DLOCALEDIR=\"$(LOCALEDIR)\" -DHAS_RELATIVE_LOCALEDIR=$(HAS_RELATIVE_LOCALEDIR)
+
+ CXXLD = $(LDPREFIX) $(CXX)
+ all: all-recursive
diff --git a/games/wesnoth/files/patch-src::help.cpp b/games/wesnoth/files/patch-src::help.cpp
index a383d415a4e9..836c0540340d 100644
--- a/games/wesnoth/files/patch-src::help.cpp
+++ b/games/wesnoth/files/patch-src::help.cpp
@@ -1,10 +1,11 @@
---- src/help.cpp.orig Sat Jul 3 20:44:17 2004
-+++ src/help.cpp Sat Jul 3 20:44:25 2004
-@@ -27,7 +27,6 @@
+--- src/help.cpp.orig Tue Oct 5 23:47:06 2004
++++ src/help.cpp Tue Oct 5 23:47:19 2004
+@@ -29,7 +29,7 @@
#include <cassert>
#include <algorithm>
#include <iostream>
-#include <locale>
++#include <locale.h>
#include <queue>
#include <set>
#include <stack>
diff --git a/games/wesnoth/files/patch-src::scoped_resource.hpp b/games/wesnoth/files/patch-src::scoped_resource.hpp
deleted file mode 100644
index 38256248cdab..000000000000
--- a/games/wesnoth/files/patch-src::scoped_resource.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/scoped_resource.hpp.orig Sat Jul 3 16:23:45 2004
-+++ src/scoped_resource.hpp Sat Jul 3 16:24:35 2004
-@@ -13,6 +13,8 @@
- #ifndef SCOPED_RESOURCE_H_INCLUDED
- #define SCOPED_RESOURCE_H_INCLUDED
-
-+#include <cstdio>
-+
- /**
- * The util namespace should take all classes which are of a generic type,
- * used to perform common tasks which are not BibleTime-specific. See