aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-01-31 20:23:38 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-01-31 20:23:38 +0000
commit1b90228615f87283fee69ef48021d57e009c7c71 (patch)
treed74bec9f464df305af9ebd8f57288b48e67f6624 /games/wesnoth
parentf02c7229d52d7886cd170bb6f39f794556cb8b5d (diff)
downloadports-1b90228615f87283fee69ef48021d57e009c7c71.tar.gz
ports-1b90228615f87283fee69ef48021d57e009c7c71.zip
Notes
Diffstat (limited to 'games/wesnoth')
-rw-r--r--games/wesnoth/Makefile13
-rw-r--r--games/wesnoth/distinfo8
-rw-r--r--games/wesnoth/files/patch-src::Makefile.in6
-rw-r--r--games/wesnoth/pkg-plist284
4 files changed, 288 insertions, 23 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 3a486b0a1ba0..08c85c6fda65 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wesnoth
-PORTVERSION= 0.8.8
+PORTVERSION= 0.8.9
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.wesnoth.org/files/
@@ -19,6 +19,8 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
+LIB_DEPENDS= zipios.0:${PORTSDIR}/archivers/zipios++
+
USE_GCC= 3.4
USE_SDL= image mixer net
USE_GNOME= gnometarget
@@ -28,15 +30,16 @@ USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-sdltest \
- --with-libiconv-prefix=${LOCALBASE} \
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE} \
--with-freetype-prefix=${LOCALBASE} \
--with-localedir=${PREFIX}/share/locale
-CONFIGURE_ENV= CPPFLAGS="-ftemplate-depth-45" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ CXXFLAGS="-I${LOCALBASE}/include ${CXXFLAGS} -ftemplate-depth-45" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
MAN6= wesnoth.6 wesnoth_editor.6 wesnothd.6
+MANLANG= "" de
.if defined(LITE)
CONFIGURE_ARGS+= --enable-lite
@@ -121,5 +124,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${X11BASE}/share/gnome/apps/Games|g ; \
s|[$$][(]datadir[)]/icons|${X11BASE}/share/gnome/pixmaps|g' \
${WRKSRC}/icons/Makefile.in
+ @${REINPLACE_CMD} -e 's|@SDL_CFLAGS@|@SDL_CFLAGS@ -I../sdl_ttf|g' \
+ ${WRKSRC}/src/tools/Makefile.in
.include <bsd.port.post.mk>
diff --git a/games/wesnoth/distinfo b/games/wesnoth/distinfo
index f67174e13b1c..6f2a7baf899d 100644
--- a/games/wesnoth/distinfo
+++ b/games/wesnoth/distinfo
@@ -1,4 +1,4 @@
-MD5 (wesnoth-0.8.8.tar.gz) = 54a580a721ea19b8006cedb2766fe6ba
-SIZE (wesnoth-0.8.8.tar.gz) = 34172227
-MD5 (wesnoth-lite-0.8.8.tar.gz) = 07487f897470665180b342e45e438e8b
-SIZE (wesnoth-lite-0.8.8.tar.gz) = 18375319
+MD5 (wesnoth-0.8.9.tar.gz) = 4a4a0b68d3895dae86337c04812e4952
+SIZE (wesnoth-0.8.9.tar.gz) = 36499929
+MD5 (wesnoth-lite-0.8.9.tar.gz) = 4d46efe6c5c74527c7d6b89fa1411b41
+SIZE (wesnoth-lite-0.8.9.tar.gz) = 20702849
diff --git a/games/wesnoth/files/patch-src::Makefile.in b/games/wesnoth/files/patch-src::Makefile.in
index 4a8e0f1e57b3..85a18ef922be 100644
--- a/games/wesnoth/files/patch-src::Makefile.in
+++ b/games/wesnoth/files/patch-src::Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig Mon Dec 6 01:07:40 2004
-+++ src/Makefile.in Mon Dec 6 01:08:16 2004
-@@ -693,10 +693,10 @@
+--- src/Makefile.in.orig Wed Jan 26 18:36:37 2005
++++ src/Makefile.in Wed Jan 26 18:37:47 2005
+@@ -661,10 +661,10 @@
sdl_ttf/SDL_ttf.h \
wesconfig.h
diff --git a/games/wesnoth/pkg-plist b/games/wesnoth/pkg-plist
index 7e60f9659bdc..7853135a04d7 100644
--- a/games/wesnoth/pkg-plist
+++ b/games/wesnoth/pkg-plist
@@ -1,10 +1,18 @@
%%CAMPAIGN:%%bin/campaignd
-%%TOOLS:%%bin/make_translation
-%%TOOLS:%%bin/merge_translations
+%%TOOLS:%%bin/cutter
+%%TOOLS:%%bin/exploder
bin/wesnoth
%%EDITOR:%%bin/wesnoth_editor
%%SERVER:%%bin/wesnothd
bin/wmlxgettext
+share/locale/bg/LC_MESSAGES/wesnoth-editor.mo
+share/locale/bg/LC_MESSAGES/wesnoth-ei.mo
+share/locale/bg/LC_MESSAGES/wesnoth-httt.mo
+share/locale/bg/LC_MESSAGES/wesnoth-lib.mo
+share/locale/bg/LC_MESSAGES/wesnoth-sotbe.mo
+share/locale/bg/LC_MESSAGES/wesnoth-tdh.mo
+share/locale/bg/LC_MESSAGES/wesnoth-trow.mo
+share/locale/bg/LC_MESSAGES/wesnoth.mo
share/locale/ca/LC_MESSAGES/wesnoth-editor.mo
share/locale/ca/LC_MESSAGES/wesnoth-ei.mo
share/locale/ca/LC_MESSAGES/wesnoth-httt.mo
@@ -93,6 +101,14 @@ share/locale/it/LC_MESSAGES/wesnoth-sotbe.mo
share/locale/it/LC_MESSAGES/wesnoth-tdh.mo
share/locale/it/LC_MESSAGES/wesnoth-trow.mo
share/locale/it/LC_MESSAGES/wesnoth.mo
+share/locale/la/LC_MESSAGES/wesnoth-editor.mo
+share/locale/la/LC_MESSAGES/wesnoth-ei.mo
+share/locale/la/LC_MESSAGES/wesnoth-httt.mo
+share/locale/la/LC_MESSAGES/wesnoth-lib.mo
+share/locale/la/LC_MESSAGES/wesnoth-sotbe.mo
+share/locale/la/LC_MESSAGES/wesnoth-tdh.mo
+share/locale/la/LC_MESSAGES/wesnoth-trow.mo
+share/locale/la/LC_MESSAGES/wesnoth.mo
share/locale/nl/LC_MESSAGES/wesnoth-editor.mo
share/locale/nl/LC_MESSAGES/wesnoth-ei.mo
share/locale/nl/LC_MESSAGES/wesnoth-httt.mo
@@ -543,6 +559,7 @@ share/wesnoth/data/units/Horse_Lord.cfg
share/wesnoth/data/units/Horseman.cfg
share/wesnoth/data/units/Initiate.cfg
share/wesnoth/data/units/Iron_Mauler.cfg
+share/wesnoth/data/units/Javelineer.cfg
share/wesnoth/data/units/Knight.cfg
share/wesnoth/data/units/Lancer.cfg
share/wesnoth/data/units/Lich.cfg
@@ -569,6 +586,8 @@ share/wesnoth/data/units/Merman_Triton.cfg
share/wesnoth/data/units/Merman_Warrior.cfg
share/wesnoth/data/units/Mounted_Captain.cfg
share/wesnoth/data/units/Mounted_Commander.cfg
+share/wesnoth/data/units/Mounted_Fighter.cfg
+share/wesnoth/data/units/Mounted_Warrior.cfg
share/wesnoth/data/units/Mudcrawler.cfg
share/wesnoth/data/units/Naga-Fighter.cfg
share/wesnoth/data/units/Naga-Myrmidon.cfg
@@ -668,6 +687,12 @@ share/wesnoth/images/arch-mage-attack1.png
share/wesnoth/images/arch-mage-attack2.png
share/wesnoth/images/arch-mage-defend.png
share/wesnoth/images/arch-mage.png
+share/wesnoth/images/assassin+female-attack.png
+share/wesnoth/images/assassin+female-attack2.png
+share/wesnoth/images/assassin+female-defend.png
+share/wesnoth/images/assassin+female-throwknife1.png
+share/wesnoth/images/assassin+female-throwknife2.png
+share/wesnoth/images/assassin+female.png
share/wesnoth/images/assassin-attack.png
share/wesnoth/images/assassin-attack2.png
share/wesnoth/images/assassin-defend.png
@@ -803,6 +828,11 @@ share/wesnoth/images/cursors/move.png
share/wesnoth/images/cursors/normal.png
share/wesnoth/images/cursors/select.png
share/wesnoth/images/cursors/wait.png
+share/wesnoth/images/cuttlefish-attack-2.png
+share/wesnoth/images/cuttlefish-attack-3.png
+share/wesnoth/images/cuttlefish-attack-4.png
+share/wesnoth/images/cuttlefish-attack-ink.png
+share/wesnoth/images/cuttlefish-attack.png
share/wesnoth/images/cuttlefish-defend.png
share/wesnoth/images/cuttlefish.png
share/wesnoth/images/deep-tentacle-attack.png
@@ -1048,14 +1078,18 @@ share/wesnoth/images/elvish-hero-bow-defend.png
share/wesnoth/images/elvish-hero-bow.png
share/wesnoth/images/elvish-hero-defend.png
share/wesnoth/images/elvish-hero.png
+share/wesnoth/images/elvish-high-lord-attack-sword-1.png
+share/wesnoth/images/elvish-high-lord-attack-sword-2.png
share/wesnoth/images/elvish-high-lord-defend.png
-share/wesnoth/images/elvish-high-lord-melee.png
+share/wesnoth/images/elvish-high-lord-ranged-defend.png
share/wesnoth/images/elvish-high-lord-ranged1.png
share/wesnoth/images/elvish-high-lord-ranged2.png
share/wesnoth/images/elvish-high-lord-ranged3.png
share/wesnoth/images/elvish-high-lord.png
share/wesnoth/images/elvish-lord-defend.png
share/wesnoth/images/elvish-lord-melee.png
+share/wesnoth/images/elvish-lord-ranged-defend.png
+share/wesnoth/images/elvish-lord-ranged.png
share/wesnoth/images/elvish-lord-ranged1.png
share/wesnoth/images/elvish-lord-ranged2.png
share/wesnoth/images/elvish-lord.png
@@ -1201,6 +1235,7 @@ share/wesnoth/images/giant-mudcrawler-attack2.png
share/wesnoth/images/giant-mudcrawler-defend.png
share/wesnoth/images/giant-mudcrawler.png
share/wesnoth/images/goblin-direwolver-attack.png
+share/wesnoth/images/goblin-direwolver-defend.png
share/wesnoth/images/goblin-direwolver.png
share/wesnoth/images/goblin-impaler-attack-ranged1.png
share/wesnoth/images/goblin-impaler-attack-ranged2.png
@@ -1209,16 +1244,18 @@ share/wesnoth/images/goblin-impaler-attack2.png
share/wesnoth/images/goblin-impaler-defend.png
share/wesnoth/images/goblin-impaler.png
share/wesnoth/images/goblin-knight-attack.png
+share/wesnoth/images/goblin-knight-defend.png
share/wesnoth/images/goblin-knight.png
share/wesnoth/images/goblin-pillager-attack.png
share/wesnoth/images/goblin-pillager-attack2.png
share/wesnoth/images/goblin-pillager-defend.png
share/wesnoth/images/goblin-pillager.png
-share/wesnoth/images/goblin-spearman-attack.png
share/wesnoth/images/goblin-spearman-defend.png
share/wesnoth/images/goblin-spearman-melee.png
share/wesnoth/images/goblin-spearman-ranged.png
share/wesnoth/images/goblin-spearman.png
+share/wesnoth/images/grand-knight-attack-sword.png
+share/wesnoth/images/grand-knight-defend.png
share/wesnoth/images/grand-knight-moving.png
share/wesnoth/images/grand-knight.png
share/wesnoth/images/great-mage+female-attack.png
@@ -1234,6 +1271,9 @@ share/wesnoth/images/great-mage.png
share/wesnoth/images/great-troll-attack.png
share/wesnoth/images/great-troll-defend.png
share/wesnoth/images/great-troll.png
+share/wesnoth/images/gryphon-attack1.png
+share/wesnoth/images/gryphon-attack2.png
+share/wesnoth/images/gryphon-defend.png
share/wesnoth/images/gryphon-master-attack1.png
share/wesnoth/images/gryphon-master-attack2.png
share/wesnoth/images/gryphon-master-defend.png
@@ -1291,6 +1331,7 @@ share/wesnoth/images/halo/mage-halo6.png
share/wesnoth/images/halo/mage-halo7.png
share/wesnoth/images/halo/mage-halo8.png
share/wesnoth/images/halo/mage-halo9.png
+share/wesnoth/images/halo/mermaid-siren-naia-touch-halo.png
share/wesnoth/images/halo/silver-mage-halo1.png
share/wesnoth/images/halo/silver-mage-halo10.png
share/wesnoth/images/halo/silver-mage-halo11.png
@@ -1354,6 +1395,15 @@ share/wesnoth/images/human-halberdier-pierce-2.png
share/wesnoth/images/human-heavyinfantry-attack.png
share/wesnoth/images/human-heavyinfantry-defend.png
share/wesnoth/images/human-heavyinfantry.png
+share/wesnoth/images/human-javelineer-attack-melee-1.png
+share/wesnoth/images/human-javelineer-attack-melee-2.png
+share/wesnoth/images/human-javelineer-attack-melee-3.png
+share/wesnoth/images/human-javelineer-attack-ranged-1.png
+share/wesnoth/images/human-javelineer-attack-ranged-2.png
+share/wesnoth/images/human-javelineer-attack-ranged-3.png
+share/wesnoth/images/human-javelineer-attack-ranged-4.png
+share/wesnoth/images/human-javelineer-defend.png
+share/wesnoth/images/human-javelineer.png
share/wesnoth/images/human-lieutenant-attack-crossbow.png
share/wesnoth/images/human-lieutenant-attack-sword.png
share/wesnoth/images/human-lieutenant-defend.png
@@ -1371,6 +1421,10 @@ share/wesnoth/images/human-marshal-attack-sword2.png
share/wesnoth/images/human-marshal-defense.png
share/wesnoth/images/human-marshal-leading.png
share/wesnoth/images/human-marshal.png
+share/wesnoth/images/human-masterbowman-attack-ranged1.png
+share/wesnoth/images/human-masterbowman-attack-ranged2.png
+share/wesnoth/images/human-masterbowman-attack-ranged3.png
+share/wesnoth/images/human-masterbowman-attack-ranged4.png
share/wesnoth/images/human-masterbowman-defend.png
share/wesnoth/images/human-masterbowman.png
share/wesnoth/images/human-pikeman-attack-1.png
@@ -1474,6 +1528,8 @@ share/wesnoth/images/konrad-fighter-attack.png
share/wesnoth/images/konrad-fighter-defend.png
share/wesnoth/images/konrad-fighter.png
share/wesnoth/images/konrad-lord-attack.png
+share/wesnoth/images/konrad-lord-bow1.png
+share/wesnoth/images/konrad-lord-bow2.png
share/wesnoth/images/konrad-lord-defend.png
share/wesnoth/images/konrad-lord-leading.png
share/wesnoth/images/konrad-lord.png
@@ -1497,9 +1553,39 @@ share/wesnoth/images/mage-defend.png
share/wesnoth/images/mage.png
share/wesnoth/images/maps/wesnoth.png
share/wesnoth/images/mermaid-diviner.png
+share/wesnoth/images/mermaid-enchantress-defend.png
+share/wesnoth/images/mermaid-enchantress-staff-attack.png
+share/wesnoth/images/mermaid-enchantress-water-attack1.png
+share/wesnoth/images/mermaid-enchantress-water-attack2.png
+share/wesnoth/images/mermaid-enchantress-water-attack3.png
+share/wesnoth/images/mermaid-enchantress-water-attack4.png
+share/wesnoth/images/mermaid-enchantress-water-attack5.png
+share/wesnoth/images/mermaid-enchantress-water-attack6.png
+share/wesnoth/images/mermaid-enchantress-water-attack7.png
share/wesnoth/images/mermaid-enchantress.png
+share/wesnoth/images/mermaid-initiate-defend.png
+share/wesnoth/images/mermaid-initiate-staff-attack.png
+share/wesnoth/images/mermaid-initiate-water-attack1.png
+share/wesnoth/images/mermaid-initiate-water-attack2.png
+share/wesnoth/images/mermaid-initiate-water-attack3.png
+share/wesnoth/images/mermaid-initiate-water-attack4.png
+share/wesnoth/images/mermaid-initiate-water-attack5.png
+share/wesnoth/images/mermaid-initiate-water-attack6.png
+share/wesnoth/images/mermaid-initiate-water-attack7.png
share/wesnoth/images/mermaid-initiate.png
share/wesnoth/images/mermaid-priestess.png
+share/wesnoth/images/mermaid-siren-defend.png
+share/wesnoth/images/mermaid-siren-naia-touch-attack1.png
+share/wesnoth/images/mermaid-siren-naia-touch-attack2.png
+share/wesnoth/images/mermaid-siren-naia-touch-attack3.png
+share/wesnoth/images/mermaid-siren-naia-touch-attack4.png
+share/wesnoth/images/mermaid-siren-water-attack1.png
+share/wesnoth/images/mermaid-siren-water-attack2.png
+share/wesnoth/images/mermaid-siren-water-attack3.png
+share/wesnoth/images/mermaid-siren-water-attack4.png
+share/wesnoth/images/mermaid-siren-water-attack5.png
+share/wesnoth/images/mermaid-siren-water-attack6.png
+share/wesnoth/images/mermaid-siren-water-attack7.png
share/wesnoth/images/mermaid-siren.png
share/wesnoth/images/merman-attack.png
share/wesnoth/images/merman-defend.png
@@ -1626,11 +1712,9 @@ share/wesnoth/images/misc/rightside-editor.png
share/wesnoth/images/misc/rightside.png
share/wesnoth/images/misc/schedule-afternoon.png
share/wesnoth/images/misc/schedule-dawn.png
-share/wesnoth/images/misc/schedule-day.png
share/wesnoth/images/misc/schedule-dusk.png
share/wesnoth/images/misc/schedule-firstwatch.png
share/wesnoth/images/misc/schedule-morning.png
-share/wesnoth/images/misc/schedule-night.png
share/wesnoth/images/misc/schedule-secondwatch.png
share/wesnoth/images/misc/schedule-underground-illum.png
share/wesnoth/images/misc/schedule-underground.png
@@ -1656,6 +1740,7 @@ share/wesnoth/images/misc/selected-ellipse-9-bottom.png
share/wesnoth/images/misc/selected-ellipse-9-top.png
share/wesnoth/images/misc/slowed.png
share/wesnoth/images/misc/status-bg.png
+share/wesnoth/images/misc/stone.png
share/wesnoth/images/misc/title.png
share/wesnoth/images/misc/top-bg.png
share/wesnoth/images/misc/topleft-corner.png
@@ -1699,6 +1784,11 @@ share/wesnoth/images/naga.png
share/wesnoth/images/neutral-bandit-attack.png
share/wesnoth/images/neutral-bandit-defend.png
share/wesnoth/images/neutral-bandit.png
+share/wesnoth/images/neutral-footpad+female-attack.png
+share/wesnoth/images/neutral-footpad+female-attack1.png
+share/wesnoth/images/neutral-footpad+female-attack2.png
+share/wesnoth/images/neutral-footpad+female-defend.png
+share/wesnoth/images/neutral-footpad+female.png
share/wesnoth/images/neutral-footpad-attack.png
share/wesnoth/images/neutral-footpad-attack1.png
share/wesnoth/images/neutral-footpad-attack2.png
@@ -1785,18 +1875,35 @@ share/wesnoth/images/orcish-grunt-defend.png
share/wesnoth/images/orcish-grunt.png
share/wesnoth/images/orcish-leader-attack.png
share/wesnoth/images/orcish-leader-defend.png
+share/wesnoth/images/orcish-leader-ranged-1.png
+share/wesnoth/images/orcish-leader-ranged-2.png
share/wesnoth/images/orcish-leader.png
share/wesnoth/images/orcish-ruler-attack.png
share/wesnoth/images/orcish-ruler-defend.png
+share/wesnoth/images/orcish-ruler-ranged-1.png
+share/wesnoth/images/orcish-ruler-ranged-2.png
share/wesnoth/images/orcish-ruler.png
-share/wesnoth/images/orcish-shaman.png
-share/wesnoth/images/orcish-shaman1.png
-share/wesnoth/images/orcish-shaman2.png
+share/wesnoth/images/orcish-shaman-black-attack-curse.png
+share/wesnoth/images/orcish-shaman-black-attack-staff.png
+share/wesnoth/images/orcish-shaman-black-defend.png
+share/wesnoth/images/orcish-shaman-black.png
+share/wesnoth/images/orcish-shaman-red-attack-curse.png
+share/wesnoth/images/orcish-shaman-red-attack-staff.png
+share/wesnoth/images/orcish-shaman-red-defend.png
+share/wesnoth/images/orcish-shaman-red.png
+share/wesnoth/images/orcish-shaman-tan-attack-curse.png
+share/wesnoth/images/orcish-shaman-tan-attack-staff.png
+share/wesnoth/images/orcish-shaman-tan-defend.png
+share/wesnoth/images/orcish-shaman-tan.png
share/wesnoth/images/orcish-sovereign-attack1.png
share/wesnoth/images/orcish-sovereign-attack2.png
share/wesnoth/images/orcish-sovereign-defend.png
+share/wesnoth/images/orcish-sovereign-ranged-1.png
+share/wesnoth/images/orcish-sovereign-ranged-2.png
share/wesnoth/images/orcish-sovereign.png
share/wesnoth/images/orcish-warlord-defend.png
+share/wesnoth/images/orcish-warlord-ranged-1.png
+share/wesnoth/images/orcish-warlord-ranged-2.png
share/wesnoth/images/orcish-warlord.png
share/wesnoth/images/orcish-warrior-defend.png
share/wesnoth/images/orcish-warrior-melee1.png
@@ -1823,12 +1930,13 @@ share/wesnoth/images/paladin.png
share/wesnoth/images/parandra.png
share/wesnoth/images/pirate-galleon.png
share/wesnoth/images/portraits/Eastern_Invasion/dacyn.png
+share/wesnoth/images/portraits/Eastern_Invasion/gweddry.png
+share/wesnoth/images/portraits/Eastern_Invasion/mal-ravanal.png
share/wesnoth/images/portraits/Heir_To_The_Throne/asheviere.png
share/wesnoth/images/portraits/Heir_To_The_Throne/delfador.png
share/wesnoth/images/portraits/Heir_To_The_Throne/kalenz.png
share/wesnoth/images/portraits/Heir_To_The_Throne/konrad.png
share/wesnoth/images/portraits/Heir_To_The_Throne/lisar.png
-share/wesnoth/images/portraits/Heir_To_The_Throne/lisar_angry.png
share/wesnoth/images/portraits/The_Rise_of_Wesnoth/addroran.png
share/wesnoth/images/portraits/The_Rise_of_Wesnoth/aethyr.png
share/wesnoth/images/portraits/The_Rise_of_Wesnoth/aryad.png
@@ -1855,7 +1963,8 @@ share/wesnoth/images/projectiles/darkmissile-ne.png
share/wesnoth/images/projectiles/entangle.png
share/wesnoth/images/projectiles/fireball.png
share/wesnoth/images/projectiles/gaze.png
-share/wesnoth/images/projectiles/hatchet.png
+share/wesnoth/images/projectiles/hatchet-n.png
+share/wesnoth/images/projectiles/hatchet-ne.png
share/wesnoth/images/projectiles/icemissile-n.png
share/wesnoth/images/projectiles/icemissile-ne.png
share/wesnoth/images/projectiles/ink.png
@@ -1879,7 +1988,6 @@ share/wesnoth/images/projectiles/stone.png
share/wesnoth/images/projectiles/thorns-ne.png
share/wesnoth/images/projectiles/thorns.png
share/wesnoth/images/projectiles/water-spray.png
-share/wesnoth/images/projectiles/water_spay.png
share/wesnoth/images/projectiles/web.png
share/wesnoth/images/projectiles/whitemissile-n.png
share/wesnoth/images/projectiles/whitemissile-ne.png
@@ -1892,6 +2000,10 @@ share/wesnoth/images/red-mage-attack-melee.png
share/wesnoth/images/red-mage-attack-ranged.png
share/wesnoth/images/red-mage-defend.png
share/wesnoth/images/red-mage.png
+share/wesnoth/images/rogue+female-attack.png
+share/wesnoth/images/rogue+female-defend.png
+share/wesnoth/images/rogue+female-ranged.png
+share/wesnoth/images/rogue+female.png
share/wesnoth/images/rogue-attack.png
share/wesnoth/images/rogue-defend.png
share/wesnoth/images/rogue-ranged.png
@@ -2107,14 +2219,73 @@ share/wesnoth/images/terrain/coast2.png
share/wesnoth/images/terrain/coast3.png
share/wesnoth/images/terrain/dark_grass.png
share/wesnoth/images/terrain/dawn.png
+share/wesnoth/images/terrain/desert-hills-n.png
+share/wesnoth/images/terrain/desert-hills-ne.png
+share/wesnoth/images/terrain/desert-hills-nw.png
+share/wesnoth/images/terrain/desert-hills-s.png
+share/wesnoth/images/terrain/desert-hills-se.png
+share/wesnoth/images/terrain/desert-hills-sw.png
+share/wesnoth/images/terrain/desert-hills.png
+share/wesnoth/images/terrain/desert-hills2.png
+share/wesnoth/images/terrain/desert-hills3.png
+share/wesnoth/images/terrain/desert-mountain-peak1.png
+share/wesnoth/images/terrain/desert-mountain-peak2.png
+share/wesnoth/images/terrain/desert-mountain-peak3.png
+share/wesnoth/images/terrain/desert-mountains-n.png
+share/wesnoth/images/terrain/desert-mountains-ne.png
+share/wesnoth/images/terrain/desert-mountains-nw.png
+share/wesnoth/images/terrain/desert-mountains-s.png
+share/wesnoth/images/terrain/desert-mountains-se.png
+share/wesnoth/images/terrain/desert-mountains-sw.png
+share/wesnoth/images/terrain/desert-mountains.png
+share/wesnoth/images/terrain/desert-n-ne-se.png
+share/wesnoth/images/terrain/desert-n-ne.png
share/wesnoth/images/terrain/desert-n.png
+share/wesnoth/images/terrain/desert-ne-se-s.png
+share/wesnoth/images/terrain/desert-ne-se.png
share/wesnoth/images/terrain/desert-ne.png
+share/wesnoth/images/terrain/desert-nw-n-ne.png
+share/wesnoth/images/terrain/desert-nw-n.png
share/wesnoth/images/terrain/desert-nw.png
+share/wesnoth/images/terrain/desert-oasis.png
share/wesnoth/images/terrain/desert-plant.png
+share/wesnoth/images/terrain/desert-plant2.png
+share/wesnoth/images/terrain/desert-plant3.png
+share/wesnoth/images/terrain/desert-road-n-ne-se.png
+share/wesnoth/images/terrain/desert-road-n-ne.png
+share/wesnoth/images/terrain/desert-road-n.png
+share/wesnoth/images/terrain/desert-road-ne-se-s.png
+share/wesnoth/images/terrain/desert-road-ne-se.png
+share/wesnoth/images/terrain/desert-road-ne.png
+share/wesnoth/images/terrain/desert-road-nw-n-ne.png
+share/wesnoth/images/terrain/desert-road-nw-n.png
+share/wesnoth/images/terrain/desert-road-nw.png
+share/wesnoth/images/terrain/desert-road-s-sw-nw.png
+share/wesnoth/images/terrain/desert-road-s-sw.png
+share/wesnoth/images/terrain/desert-road-s.png
+share/wesnoth/images/terrain/desert-road-se-s-sw.png
+share/wesnoth/images/terrain/desert-road-se-s.png
+share/wesnoth/images/terrain/desert-road-se.png
+share/wesnoth/images/terrain/desert-road-sw-nw-n.png
+share/wesnoth/images/terrain/desert-road-sw-nw.png
+share/wesnoth/images/terrain/desert-road-sw.png
+share/wesnoth/images/terrain/desert-road.png
+share/wesnoth/images/terrain/desert-s-sw-nw.png
+share/wesnoth/images/terrain/desert-s-sw.png
share/wesnoth/images/terrain/desert-s.png
+share/wesnoth/images/terrain/desert-se-s-sw.png
+share/wesnoth/images/terrain/desert-se-s.png
share/wesnoth/images/terrain/desert-se.png
+share/wesnoth/images/terrain/desert-sw-nw-n.png
+share/wesnoth/images/terrain/desert-sw-nw.png
share/wesnoth/images/terrain/desert-sw.png
share/wesnoth/images/terrain/desert.png
+share/wesnoth/images/terrain/desert2.png
+share/wesnoth/images/terrain/desert3.png
+share/wesnoth/images/terrain/desert4.png
+share/wesnoth/images/terrain/desert5.png
+share/wesnoth/images/terrain/desert6.png
+share/wesnoth/images/terrain/desert7.png
share/wesnoth/images/terrain/dirt-n.png
share/wesnoth/images/terrain/dirt-ne.png
share/wesnoth/images/terrain/dirt-nw.png
@@ -2424,6 +2595,58 @@ share/wesnoth/images/terrain/road-se.png
share/wesnoth/images/terrain/road-sw.png
share/wesnoth/images/terrain/road.png
share/wesnoth/images/terrain/rocks.png
+share/wesnoth/images/terrain/sand-n.png
+share/wesnoth/images/terrain/sand-ne.png
+share/wesnoth/images/terrain/sand-nw.png
+share/wesnoth/images/terrain/sand-plant.png
+share/wesnoth/images/terrain/sand-s.png
+share/wesnoth/images/terrain/sand-se.png
+share/wesnoth/images/terrain/sand-sw.png
+share/wesnoth/images/terrain/sand.png
+share/wesnoth/images/terrain/savanna-n-ne-se.png
+share/wesnoth/images/terrain/savanna-n-ne.png
+share/wesnoth/images/terrain/savanna-n.png
+share/wesnoth/images/terrain/savanna-ne-se-s.png
+share/wesnoth/images/terrain/savanna-ne-se.png
+share/wesnoth/images/terrain/savanna-ne.png
+share/wesnoth/images/terrain/savanna-nw-n-ne.png
+share/wesnoth/images/terrain/savanna-nw-n.png
+share/wesnoth/images/terrain/savanna-nw.png
+share/wesnoth/images/terrain/savanna-s-sw-nw.png
+share/wesnoth/images/terrain/savanna-s-sw.png
+share/wesnoth/images/terrain/savanna-s.png
+share/wesnoth/images/terrain/savanna-se-s-sw.png
+share/wesnoth/images/terrain/savanna-se-s.png
+share/wesnoth/images/terrain/savanna-se.png
+share/wesnoth/images/terrain/savanna-sw-nw-n.png
+share/wesnoth/images/terrain/savanna-sw-nw.png
+share/wesnoth/images/terrain/savanna-sw.png
+share/wesnoth/images/terrain/savanna-to-water-n-ne-se.png
+share/wesnoth/images/terrain/savanna-to-water-n-ne.png
+share/wesnoth/images/terrain/savanna-to-water-n.png
+share/wesnoth/images/terrain/savanna-to-water-ne-se-s.png
+share/wesnoth/images/terrain/savanna-to-water-ne-se.png
+share/wesnoth/images/terrain/savanna-to-water-ne.png
+share/wesnoth/images/terrain/savanna-to-water-nw-n-ne.png
+share/wesnoth/images/terrain/savanna-to-water-nw-n.png
+share/wesnoth/images/terrain/savanna-to-water-nw.png
+share/wesnoth/images/terrain/savanna-to-water-s-sw-nw.png
+share/wesnoth/images/terrain/savanna-to-water-s-sw.png
+share/wesnoth/images/terrain/savanna-to-water-s.png
+share/wesnoth/images/terrain/savanna-to-water-se-s-sw.png
+share/wesnoth/images/terrain/savanna-to-water-se-s.png
+share/wesnoth/images/terrain/savanna-to-water-se.png
+share/wesnoth/images/terrain/savanna-to-water-sw-nw-n.png
+share/wesnoth/images/terrain/savanna-to-water-sw-nw.png
+share/wesnoth/images/terrain/savanna-to-water-sw.png
+share/wesnoth/images/terrain/savanna.png
+share/wesnoth/images/terrain/snow-forest-ctrans-n-ne.png
+share/wesnoth/images/terrain/snow-forest-ctrans-n.png
+share/wesnoth/images/terrain/snow-forest-ctrans-ne.png
+share/wesnoth/images/terrain/snow-forest-ctrans-nw-n-ne.png
+share/wesnoth/images/terrain/snow-forest-ctrans-nw-n.png
+share/wesnoth/images/terrain/snow-forest-ctrans-nw-ne.png
+share/wesnoth/images/terrain/snow-forest-ctrans-nw.png
share/wesnoth/images/terrain/snow-forest-n-ne.png
share/wesnoth/images/terrain/snow-forest-n.png
share/wesnoth/images/terrain/snow-forest-ne.png
@@ -2490,8 +2713,28 @@ share/wesnoth/images/terrain/temple.png
share/wesnoth/images/terrain/tent.png
share/wesnoth/images/terrain/test.png
share/wesnoth/images/terrain/trash.png
+share/wesnoth/images/terrain/tropical-forest-ctrans-n-ne.png
+share/wesnoth/images/terrain/tropical-forest-ctrans-n.png
+share/wesnoth/images/terrain/tropical-forest-ctrans-ne.png
+share/wesnoth/images/terrain/tropical-forest-ctrans-nw-n-ne.png
+share/wesnoth/images/terrain/tropical-forest-ctrans-nw-n.png
+share/wesnoth/images/terrain/tropical-forest-ctrans-nw-ne.png
+share/wesnoth/images/terrain/tropical-forest-ctrans-nw.png
+share/wesnoth/images/terrain/tropical-forest-n.png
+share/wesnoth/images/terrain/tropical-forest-ne.png
+share/wesnoth/images/terrain/tropical-forest-nw.png
+share/wesnoth/images/terrain/tropical-forest-s.png
+share/wesnoth/images/terrain/tropical-forest-se.png
+share/wesnoth/images/terrain/tropical-forest-sw.png
+share/wesnoth/images/terrain/tropical-forest.png
+share/wesnoth/images/terrain/tropical-forest2.png
+share/wesnoth/images/terrain/tropical-forest3.png
+share/wesnoth/images/terrain/tropical-forest4.png
share/wesnoth/images/terrain/village-cave.png
share/wesnoth/images/terrain/village-coast.png
+share/wesnoth/images/terrain/village-desert-shadow.png
+share/wesnoth/images/terrain/village-desert.png
+share/wesnoth/images/terrain/village-desert2.png
share/wesnoth/images/terrain/village-dusk.png
share/wesnoth/images/terrain/village-dusk2.png
share/wesnoth/images/terrain/village-dusk3.png
@@ -2507,6 +2750,7 @@ share/wesnoth/images/terrain/village-second_watch.png
share/wesnoth/images/terrain/village-snow.png
share/wesnoth/images/terrain/village-sw.png
share/wesnoth/images/terrain/village-swampwater.png
+share/wesnoth/images/terrain/village-tropical-forest.png
share/wesnoth/images/terrain/village.png
share/wesnoth/images/terrain/void-n-ne-se-s.png
share/wesnoth/images/terrain/void-n-ne-se.png
@@ -2529,6 +2773,9 @@ share/wesnoth/images/terrain/void-sw-nw-n.png
share/wesnoth/images/terrain/void-sw-nw.png
share/wesnoth/images/terrain/void-sw.png
share/wesnoth/images/terrain/void.png
+share/wesnoth/images/thief+female-attack.png
+share/wesnoth/images/thief+female-defend.png
+share/wesnoth/images/thief+female.png
share/wesnoth/images/thief-attack.png
share/wesnoth/images/thief-defend.png
share/wesnoth/images/thief.png
@@ -2551,6 +2798,7 @@ share/wesnoth/images/troll-lobber-attack-ranged2.png
share/wesnoth/images/troll-lobber-defend.png
share/wesnoth/images/troll-lobber.png
share/wesnoth/images/troll-warrior-attack.png
+share/wesnoth/images/troll-warrior-defend.png
share/wesnoth/images/troll-warrior.png
share/wesnoth/images/troll-whelp-attack.png
share/wesnoth/images/troll-whelp-defend.png
@@ -2564,6 +2812,7 @@ share/wesnoth/images/undead-ancient-lich.png
share/wesnoth/images/undead-archer-attack.png
share/wesnoth/images/undead-archer-attack1.png
share/wesnoth/images/undead-archer-attack2.png
+share/wesnoth/images/undead-archer-defend.png
share/wesnoth/images/undead-archer.png
share/wesnoth/images/undead-bat-attack.png
share/wesnoth/images/undead-bat-defend.png
@@ -2590,7 +2839,11 @@ share/wesnoth/images/undead-deathblade-attack2.png
share/wesnoth/images/undead-deathblade-attack3.png
share/wesnoth/images/undead-deathblade-defend.png
share/wesnoth/images/undead-deathblade.png
+share/wesnoth/images/undead-deathknight-attack-crossbow-1.png
+share/wesnoth/images/undead-deathknight-attack-crossbow-2.png
share/wesnoth/images/undead-deathknight-attack.png
+share/wesnoth/images/undead-deathknight-defend.png
+share/wesnoth/images/undead-deathknight-leading.png
share/wesnoth/images/undead-deathknight.png
share/wesnoth/images/undead-deathmaster-attack1.png
share/wesnoth/images/undead-deathmaster-attack2.png
@@ -2601,6 +2854,7 @@ share/wesnoth/images/undead-deathmaster-ranged3.png
share/wesnoth/images/undead-deathmaster-ranged4.png
share/wesnoth/images/undead-deathmaster.png
share/wesnoth/images/undead-demilich-attack.png
+share/wesnoth/images/undead-demilich-defend.png
share/wesnoth/images/undead-demilich-ranged1.png
share/wesnoth/images/undead-demilich-ranged2.png
share/wesnoth/images/undead-demilich.png
@@ -2636,6 +2890,7 @@ share/wesnoth/images/undead-nightgaunt-attack2.png
share/wesnoth/images/undead-nightgaunt-defend.png
share/wesnoth/images/undead-nightgaunt.png
share/wesnoth/images/undead-revenant-attack.png
+share/wesnoth/images/undead-revenant-defend.png
share/wesnoth/images/undead-revenant.png
share/wesnoth/images/undead-shadow-attack.png
share/wesnoth/images/undead-shadow-defend.png
@@ -2710,6 +2965,7 @@ share/wesnoth/images/yeti-attack2.png
share/wesnoth/images/yeti-defend.png
share/wesnoth/images/yeti.png
share/wesnoth/images/young-ogre-attack.png
+share/wesnoth/images/young-ogre-defend.png
share/wesnoth/images/young-ogre.png
%%LITE:%%share/wesnoth/music/elf-land.ogg
%%LITE:%%share/wesnoth/music/frantic.ogg
@@ -2773,6 +3029,8 @@ share/wesnoth/sounds/zombie-attack.wav
share/wesnoth/sounds/zombie-hit.wav
@unexec rmdir %D/share/locale/el_GR/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/el_GR 2> /dev/null || true
+@unexec rmdir %D/share/locale/la/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/la 2> /dev/null || true
@dirrm share/wesnoth/sounds
%%LITE:%%@dirrm share/wesnoth/music
@dirrm share/wesnoth/images/tools/exploder
@@ -2832,6 +3090,8 @@ share/wesnoth/sounds/zombie-hit.wav
@dirrm share/wesnoth/data/campaigns
@dirrm share/wesnoth/data
@dirrm share/wesnoth
+@unexec rmdir %D/man/de/man6 2> /dev/null || true
+@unexec rmdir %D/man/de/ 2> /dev/null || true
%%GNOME:%%share/gnome/apps/Games/wesnoth.desktop
%%GNOME:%%share/gnome/pixmaps/wesnoth-icon.png