aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-18 20:55:47 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-18 20:55:47 +0000
commit42f285a62328c649d9fdcc8586a346eeb52f99b5 (patch)
treeda69ac80bcf949729f801d16ac4f019b5ff31aff /games/wesnoth
parentf6ed5afa0cb492b722374476ef9e0372ec7f5ce5 (diff)
downloadports-42f285a62328c649d9fdcc8586a346eeb52f99b5.tar.gz
ports-42f285a62328c649d9fdcc8586a346eeb52f99b5.zip
Notes
Diffstat (limited to 'games/wesnoth')
-rw-r--r--games/wesnoth/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index b7e1242d6166..ff06ecb0d614 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wesnoth
PORTVERSION= 1.12.6
-PORTREVISION= 9
+PORTREVISION= 10
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTNAME}-${PORTVERSION} \
@@ -16,7 +16,8 @@ LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libvorbisfile.so:audio/libvorbis \
libboost_thread.so:devel/boost-libs \
libpng.so:graphics/png \
libfontconfig.so:x11-fonts/fontconfig
@@ -28,10 +29,11 @@ LDFLAGS+= -L${LOCALBASE}/lib -lboost_system
PORTSCOUT= limitw:1,even
+USES= cmake cpe pkgconfig python:run shebangfix tar:bzip2
USE_SDL= image mixer net ttf
USE_LDCONFIG= yes
-USE_GNOME= pango
-USES= cmake cpe pkgconfig python:run shebangfix tar:bzip2
+USE_GNOME= cairo pango
+USE_XORG= ice sm x11 xext
SHEBANG_FILES= data/tools/about_cfg_to_wiki \
data/tools/campaign2wiki.py \
data/tools/castle-cutter/mk-castle.sh \
@@ -49,7 +51,8 @@ SHEBANG_FILES= data/tools/about_cfg_to_wiki \
data/tools/wmlindent data/tools/wmllint \
data/tools/wmllint-1.4 data/tools/wmllint_gui \
data/tools/wmlmove data/tools/wmlscope data/tools/wmlunits \
- data/tools/wmlvalidator
+ data/tools/wmlvalidator \
+ data/tools/GUI.pyw
CPE_VENDOR= ${PORTNAME}
CPE_PRODUCT= battle_for_wesnoth
CMAKE_ARGS= -DMANDIR="man" -DENABLE_STRICT_COMPILATION=off