aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2010-09-27 09:13:10 +0000
committerPhilip Paeps <philip@FreeBSD.org>2010-09-27 09:13:10 +0000
commitb17feaaba00582a548bbf7377a13dfdfd1c153d7 (patch)
tree0f600ab4d2ea25d20053fc8fcf5b3bc9fc525187 /games/wesnoth
parent1a8ef37b1d0c4d7299c29871c379a77fa7e76ae9 (diff)
downloadports-b17feaaba00582a548bbf7377a13dfdfd1c153d7.tar.gz
ports-b17feaaba00582a548bbf7377a13dfdfd1c153d7.zip
Notes
Diffstat (limited to 'games/wesnoth')
-rw-r--r--games/wesnoth/Makefile10
-rw-r--r--games/wesnoth/distinfo6
-rw-r--r--games/wesnoth/files/patch-Makefile.am18
-rw-r--r--games/wesnoth/files/patch-configure.ac19
4 files changed, 36 insertions, 17 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index cbf429e1348a..a97b8aeff9d1 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= wesnoth
-PORTVERSION= 1.8.4
-PORTREVISION= 1
+PORTVERSION= 1.8.5
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTNAME}-${PORTVERSION} \
http://files.wesnoth.org/
@@ -27,10 +26,9 @@ USE_SDL= image mixer net ttf
USE_GNOME= gnometarget pango
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-WANT_GNOME= yes
USE_BZIP2= yes
USE_LUA= 5.1
-USE_AUTOTOOLS= aclocal:110 autoheader:267 automake:110 autoconf:267
+USE_AUTOTOOLS= aclocal:111 autoheader:267 automake:111 autoconf:267
ACLOCAL_ARGS= -Im4
AUTOMAKE_ARGS= --add-missing --copy
CONFIGURE_ENV= PKG_CONFIG="${PKG_CONFIG}" \
@@ -43,7 +41,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
--with-localedir=${PREFIX}/share/locale
PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
-MANLANG= "" cs de en_GB es et fi fr gl hu it ja lt pl pt_BR sk \
+MANLANG= "" cs de en_GB es et fi fr gl hu id it ja lt pl pt_BR sk \
sr sr@ijekavian sr@ijekavianlatin sr@latin tr zh_CN zh_TW
MAN6= wesnoth.6
@@ -192,7 +190,7 @@ PLIST_SUB+= TOOLS=""
.endif
.if defined(NOPORTDOCS)
-CONFIGURE_ARGS+= --docdir=${WRKDIR}/docs
+CONFIGURE_ARGS+= --without-docs
.endif
.if defined(NOPORTDATA)
diff --git a/games/wesnoth/distinfo b/games/wesnoth/distinfo
index 6008fb111537..bbe002ab1b04 100644
--- a/games/wesnoth/distinfo
+++ b/games/wesnoth/distinfo
@@ -1,3 +1,3 @@
-MD5 (wesnoth-1.8.4.tar.bz2) = 2dce83f835ecce1d505ea60e46b7356f
-SHA256 (wesnoth-1.8.4.tar.bz2) = af29ddf40f83ee016972d6edb8761d7323f8ed5d6bf15005659bff4fd7190eb9
-SIZE (wesnoth-1.8.4.tar.bz2) = 300557790
+MD5 (wesnoth-1.8.5.tar.bz2) = a800285d1406690755dd0ea22b98b6df
+SHA256 (wesnoth-1.8.5.tar.bz2) = eca3bdce505480a0cf045d0189df7260c16af9f543a427e7de8690fff9c655fa
+SIZE (wesnoth-1.8.5.tar.bz2) = 301024033
diff --git a/games/wesnoth/files/patch-Makefile.am b/games/wesnoth/files/patch-Makefile.am
new file mode 100644
index 000000000000..de5aa49d2456
--- /dev/null
+++ b/games/wesnoth/files/patch-Makefile.am
@@ -0,0 +1,18 @@
+--- Makefile.am~
++++ Makefile.am
+@@ -73,6 +73,7 @@ if INSTALLDATA
+ echo $(INSTALL_DATA) "$$d$$p" "$(DESTDIR)$(pkgdatadir)/$$f"; \
+ $(INSTALL_DATA) "$$d$$p" "$(DESTDIR)$(pkgdatadir)/$$f"; \
+ done
++if INSTALLDOCS
+ @echo "Replicate doc directory skeleton under target doc subdirectory"
+ @echo "Then copy all corresponding files."
+ test -z "$(docdir)" || $(mkdir_p) "$(DESTDIR)$(docdir)"
+@@ -84,6 +85,7 @@ if INSTALLDATA
+ echo $(INSTALL_DATA) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
+ $(INSTALL_DATA) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; cd ..; \
+ done
++endif
+ if TINYGUI
+ @echo "Shrink installed images by a factor of two."
+ (cd $(top_srcdir) && find data/core/images data/campaigns images \( $(findfilterflags) -a -name '*.png' -and -not -name 'bar-energy-tinygui.png' -print \) ) | while read p; do \
diff --git a/games/wesnoth/files/patch-configure.ac b/games/wesnoth/files/patch-configure.ac
index 0015eec85a64..25a98a8e1da7 100644
--- a/games/wesnoth/files/patch-configure.ac
+++ b/games/wesnoth/files/patch-configure.ac
@@ -1,11 +1,14 @@
--- configure.ac~
+++ configure.ac
-@@ -111,7 +111,7 @@ then
- fi
+@@ -213,6 +213,11 @@ esac
+ AC_SUBST([FULLLOCALEDIR])
+ AC_SUBST([HAS_RELATIVE_LOCALEDIR])
- # Make tests default in svn version
--svn_in_version=`expr match "$WESNOTH_VERSION" '.*svn'`
-+svn_in_version=`expr "$WESNOTH_VERSION" : '.*svn'`
- test_build=yes
- if test $svn_in_version = 0
- then
++AC_ARG_WITH([docs],
++ AS_HELP_STRING([--without-docs], [don't install wesnoth manual]),
++ [docs=$withval],
++ [docs=yes])
++AM_CONDITIONAL([INSTALLDOCS], [test x$docs = xyes])
+
+ AC_ARG_ENABLE([game],
+ AS_HELP_STRING([--disable-game], [disable compilation of game]),