aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-09 09:10:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-09 09:10:44 +0000
commit1fdb3fa31cd83a15af0e979d49a65af808ddb9ce (patch)
treece8c9b6c8cebe3fe4b9aa2fe4e4d8890be8020ac /games/wesnoth
parent7ead418e9b515590dda33e738e0f5e34b36a712b (diff)
downloadports-1fdb3fa31cd83a15af0e979d49a65af808ddb9ce.tar.gz
ports-1fdb3fa31cd83a15af0e979d49a65af808ddb9ce.zip
Notes
Diffstat (limited to 'games/wesnoth')
-rw-r--r--games/wesnoth/Makefile27
-rw-r--r--games/wesnoth/distinfo4
-rw-r--r--games/wesnoth/files/patch-src-mapgen.cpp13
-rw-r--r--games/wesnoth/pkg-plist197
4 files changed, 234 insertions, 7 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index ea1607aca36c..8bc1811b8f51 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wesnoth
-PORTVERSION= 0.7
+PORTVERSION= 0.7.2
CATEGORIES= games
MASTER_SITES= http://www.wesnoth.org/files/
@@ -15,7 +15,9 @@ COMMENT= A fantasy turn-based strategy game
USE_SDL= image mixer net ttf sdl
USE_GNOME= gnometarget
+WANT_GNOME= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
MAN6= wesnoth.6 wesnoth_editor.6 wesnothd.6
@@ -45,6 +47,22 @@ PLIST_SUB+= TOOLS:=""
PLIST_SUB+= TOOLS:="@comment "
.endif
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mlibgnome}!=""
+CONFIGURE_ARGS+= --enable-gnome
+PLIST_SUB+= GNOME:=""
+.else
+PLIST_SUB+= GNOME:="@comment "
+.endif
+
+.if exists(${LOCALBASE}/bin/kde-config)
+CONFIGURE_ARGS+= --enable-kde
+PLIST_SUB+= KDE:=""
+.else
+PLIST_SUB+= KDE:="@comment "
+.endif
+
pre-everything::
.if !defined(WITH_DEBUG) || !defined(WITH_EDITOR) || !defined(WITH_SERVER) || !defined(WITH_TOOLS)
@${ECHO_MSG} "You may specify the following on the command line:"
@@ -67,4 +85,9 @@ pre-everything::
@${ECHO_MSG} "WITH_TOOLS=yes for enable compilation of translation tools."
.endif
-.include <bsd.port.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${X11BASE}/share/gnome/apps/Games|g ; \
+ s|[$$][(]datadir[)]/icons|${X11BASE}/share/gnome/pixmaps|g' \
+ ${WRKSRC}/icons/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/games/wesnoth/distinfo b/games/wesnoth/distinfo
index 7f8d69def59a..4b97bb2bdd1b 100644
--- a/games/wesnoth/distinfo
+++ b/games/wesnoth/distinfo
@@ -1,2 +1,2 @@
-MD5 (wesnoth-0.7.tar.gz) = 8c38f71db9c689148c300474992eb260
-SIZE (wesnoth-0.7.tar.gz) = 17497561
+MD5 (wesnoth-0.7.2.tar.gz) = efd950457569426ef6292156c741938f
+SIZE (wesnoth-0.7.2.tar.gz) = 20157909
diff --git a/games/wesnoth/files/patch-src-mapgen.cpp b/games/wesnoth/files/patch-src-mapgen.cpp
new file mode 100644
index 000000000000..e1170b3a20b3
--- /dev/null
+++ b/games/wesnoth/files/patch-src-mapgen.cpp
@@ -0,0 +1,13 @@
+--- src/mapgen.cpp.orig Thu Apr 8 06:25:14 2004
++++ src/mapgen.cpp Fri Apr 9 10:28:48 2004
+@@ -127,8 +127,8 @@
+
+ //we have to check whether this is actually a valley
+ if(island_size != 0) {
+- const size_t diffx = abs(x1 - center_x);
+- const size_t diffy = abs(y1 - center_y);
++ const size_t diffx = abs((int)(x1 - center_x));
++ const size_t diffy = abs((int)(y1 - center_y));
+ const size_t dist = size_t(sqrt(double(diffx*diffx + diffy*diffy)));
+ is_valley = dist > island_size;
+ }
diff --git a/games/wesnoth/pkg-plist b/games/wesnoth/pkg-plist
index d768e1fd835e..9cd1b37b8ed5 100644
--- a/games/wesnoth/pkg-plist
+++ b/games/wesnoth/pkg-plist
@@ -37,16 +37,23 @@ share/wesnoth/data/maps/map6
share/wesnoth/data/maps/map7
share/wesnoth/data/maps/map8
share/wesnoth/data/maps/map9
+share/wesnoth/data/maps/mapentrance
share/wesnoth/data/maps/north-elves
share/wesnoth/data/maps/north-winter
+share/wesnoth/data/maps/orc-map1
+share/wesnoth/data/maps/orc-map2
+share/wesnoth/data/maps/orc-map3
+share/wesnoth/data/maps/orc-map4
+share/wesnoth/data/maps/orc-map5
+share/wesnoth/data/maps/orc-map6
+share/wesnoth/data/maps/orc-map7
+share/wesnoth/data/maps/orc-map8
share/wesnoth/data/maps/sceptre
share/wesnoth/data/maps/snowplains
share/wesnoth/data/maps/swampland
share/wesnoth/data/maps/undeadbook
share/wesnoth/data/maps/undeadtower
-share/wesnoth/data/maps/undmap1
share/wesnoth/data/maps/undmap2
-share/wesnoth/data/maps/undmap3
share/wesnoth/data/maps/undmapbrother
share/wesnoth/data/maps/undmapmages
share/wesnoth/data/maps/undmapskull
@@ -78,16 +85,29 @@ share/wesnoth/data/scenarios/Northern_Winter.cfg
share/wesnoth/data/scenarios/Plunging_Into_the_Darkness.cfg
share/wesnoth/data/scenarios/Princess_of_Wesnoth.cfg
share/wesnoth/data/scenarios/Random_Scenario.cfg
+share/wesnoth/data/scenarios/Return_to_Wesnoth.cfg
share/wesnoth/data/scenarios/Sceptre.cfg
share/wesnoth/data/scenarios/Snow_Plains.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye/Black_Flag.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye/Desert_Of_Death.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye/End_Of_Peace.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye/Shan_Taum_The_Smug.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye/Silent_Forest.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye/The_Siege_Of_Barag_Gor.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye/To_The_Harbour_Of_Tirigaz.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye/Towards_Mountains_of_Haag.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye/deaths.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye/story.cfg
+share/wesnoth/data/scenarios/Son_Of_The_Black_Eye/utils.cfg
share/wesnoth/data/scenarios/Swamp_Of_Dread.cfg
share/wesnoth/data/scenarios/The_Lost_General.cfg
share/wesnoth/data/scenarios/The_Siege_of_Elensefar.cfg
share/wesnoth/data/scenarios/The_Skull_of_Agarash.cfg
share/wesnoth/data/scenarios/Valley_of_Death.cfg
+share/wesnoth/data/scenarios/Valley_of_Statues.cfg
share/wesnoth/data/schedules.cfg
share/wesnoth/data/terrain.cfg
-share/wesnoth/data/terrain_generator.cfg
share/wesnoth/data/themes/default.cfg
share/wesnoth/data/translations/brazilian.cfg
share/wesnoth/data/translations/danish.cfg
@@ -110,12 +130,14 @@ share/wesnoth/data/units/Ancient_Lich.cfg
share/wesnoth/data/units/Arch_Mage.cfg
share/wesnoth/data/units/Assassin.cfg
share/wesnoth/data/units/Bandit.cfg
+share/wesnoth/data/units/Battle_Princess.cfg
share/wesnoth/data/units/Blood_Bat.cfg
share/wesnoth/data/units/Bone_Shooter.cfg
share/wesnoth/data/units/Bowman.cfg
share/wesnoth/data/units/Cavalry.cfg
share/wesnoth/data/units/Cave_Spider.cfg
share/wesnoth/data/units/Chocobone.cfg
+share/wesnoth/data/units/Cockatrice.cfg
share/wesnoth/data/units/Commander.cfg
share/wesnoth/data/units/Cuttle_Fish.cfg
share/wesnoth/data/units/Dark_Adept.cfg
@@ -157,8 +179,11 @@ share/wesnoth/data/units/Galleon.cfg
share/wesnoth/data/units/General.cfg
share/wesnoth/data/units/Ghost.cfg
share/wesnoth/data/units/Ghoul.cfg
+share/wesnoth/data/units/Giant_Scorpion.cfg
+share/wesnoth/data/units/Goblin_Direwolver.cfg
share/wesnoth/data/units/Goblin_Knight.cfg
share/wesnoth/data/units/Goblin_Pillager.cfg
+share/wesnoth/data/units/Grand_Knight.cfg
share/wesnoth/data/units/Great_Mage.cfg
share/wesnoth/data/units/Gryphon.cfg
share/wesnoth/data/units/Gryphon_Rider.cfg
@@ -186,12 +211,15 @@ share/wesnoth/data/units/Orcish_Assassin.cfg
share/wesnoth/data/units/Orcish_Crossbow.cfg
share/wesnoth/data/units/Orcish_Crossbowman.cfg
share/wesnoth/data/units/Orcish_Grunt.cfg
+share/wesnoth/data/units/Orcish_Ruler.cfg
+share/wesnoth/data/units/Orcish_Shaman.cfg
share/wesnoth/data/units/Orcish_Slayer.cfg
share/wesnoth/data/units/Orcish_Warlord.cfg
share/wesnoth/data/units/Orcish_Warrior.cfg
share/wesnoth/data/units/Outlaw.cfg
share/wesnoth/data/units/Paladin.cfg
share/wesnoth/data/units/Pikeman.cfg
+share/wesnoth/data/units/Pirate_Galleon.cfg
share/wesnoth/data/units/Poacher.cfg
share/wesnoth/data/units/Princess.cfg
share/wesnoth/data/units/Red_Mage.cfg
@@ -211,6 +239,7 @@ share/wesnoth/data/units/Spectre.cfg
share/wesnoth/data/units/Swordsman.cfg
share/wesnoth/data/units/Thief.cfg
share/wesnoth/data/units/Thug.cfg
+share/wesnoth/data/units/Transport_Galleon.cfg
share/wesnoth/data/units/Trapper.cfg
share/wesnoth/data/units/Triton.cfg
share/wesnoth/data/units/Troll.cfg
@@ -218,11 +247,14 @@ share/wesnoth/data/units/Troll_Warrior.cfg
share/wesnoth/data/units/Troll_Whelp.cfg
share/wesnoth/data/units/Vampire_Bat.cfg
share/wesnoth/data/units/Walking_Corpse.cfg
+share/wesnoth/data/units/Watch_Tower.cfg
share/wesnoth/data/units/White_Mage.cfg
share/wesnoth/data/units/Wolf_Rider.cfg
share/wesnoth/data/units/Wraith.cfg
+share/wesnoth/data/units/Yeti.cfg
share/wesnoth/data/units/Youth.cfg
share/wesnoth/data/utils.cfg
+share/wesnoth/fonts/Bepa-Roman.ttf
share/wesnoth/fonts/Vera.ttf
share/wesnoth/images/Afternoon.png
share/wesnoth/images/Dawn.png
@@ -232,6 +264,8 @@ share/wesnoth/images/FirstWatch.png
share/wesnoth/images/Morning.png
share/wesnoth/images/Night.png
share/wesnoth/images/SecondWatch.png
+share/wesnoth/images/Underground.png
+share/wesnoth/images/UndergroundIllum.png
share/wesnoth/images/ally-energy.png
share/wesnoth/images/arch-mage-attack2.png
share/wesnoth/images/arch-mage-defend.png
@@ -270,7 +304,16 @@ share/wesnoth/images/buttons/uparrow-button.png
share/wesnoth/images/cavespider.png
share/wesnoth/images/cockatrice-attack1.png
share/wesnoth/images/cockatrice-attack2.png
+share/wesnoth/images/cockatrice-defend.png
share/wesnoth/images/cockatrice.png
+share/wesnoth/images/cursors-bw/attack.png
+share/wesnoth/images/cursors-bw/move.png
+share/wesnoth/images/cursors-bw/normal.png
+share/wesnoth/images/cursors-bw/wait.png
+share/wesnoth/images/cursors/attack.png
+share/wesnoth/images/cursors/move.png
+share/wesnoth/images/cursors/normal.png
+share/wesnoth/images/cursors/wait.png
share/wesnoth/images/cuttlefish.png
share/wesnoth/images/darkmissile-n.png
share/wesnoth/images/darkmissile-ne.png
@@ -297,6 +340,7 @@ share/wesnoth/images/elder-mage.png
share/wesnoth/images/elvish-archer-attack.png
share/wesnoth/images/elvish-archer-attack1.png
share/wesnoth/images/elvish-archer-attack2.png
+share/wesnoth/images/elvish-archer-attack3.png
share/wesnoth/images/elvish-archer-bow-defend.png
share/wesnoth/images/elvish-archer-defend.png
share/wesnoth/images/elvish-archer.png
@@ -310,6 +354,7 @@ share/wesnoth/images/elvish-avenger.png
share/wesnoth/images/elvish-captain-attack.png
share/wesnoth/images/elvish-captain-bow-attack1.png
share/wesnoth/images/elvish-captain-bow-attack2.png
+share/wesnoth/images/elvish-captain-bow-attack3.png
share/wesnoth/images/elvish-captain-bow-defend.png
share/wesnoth/images/elvish-captain-bow.png
share/wesnoth/images/elvish-captain-defend.png
@@ -322,32 +367,42 @@ share/wesnoth/images/elvish-druid.png
share/wesnoth/images/elvish-fighter-attack.png
share/wesnoth/images/elvish-fighter-bow-attack1.png
share/wesnoth/images/elvish-fighter-bow-attack2.png
+share/wesnoth/images/elvish-fighter-bow-attack3.png
share/wesnoth/images/elvish-fighter-bow-defend.png
share/wesnoth/images/elvish-fighter-bow.png
share/wesnoth/images/elvish-fighter-defend.png
share/wesnoth/images/elvish-fighter.png
share/wesnoth/images/elvish-hero-attack.png
share/wesnoth/images/elvish-hero.png
+share/wesnoth/images/elvish-lord-ranged1.png
+share/wesnoth/images/elvish-lord-ranged2.png
share/wesnoth/images/elvish-lord.png
share/wesnoth/images/elvish-marksman-attack.png
share/wesnoth/images/elvish-marksman-attack1.png
share/wesnoth/images/elvish-marksman-attack2.png
+share/wesnoth/images/elvish-marksman-attack3.png
share/wesnoth/images/elvish-marksman-bow-defend.png
share/wesnoth/images/elvish-marksman.png
share/wesnoth/images/elvish-marshal-attack.png
+share/wesnoth/images/elvish-marshal-attack3.png
share/wesnoth/images/elvish-marshal-bow.png
share/wesnoth/images/elvish-marshal-defend.png
share/wesnoth/images/elvish-marshal.png
share/wesnoth/images/elvish-outrider-attack.png
+share/wesnoth/images/elvish-outrider-attack1.png
+share/wesnoth/images/elvish-outrider-attack2.png
share/wesnoth/images/elvish-outrider-defend.png
share/wesnoth/images/elvish-outrider.png
share/wesnoth/images/elvish-ranger-attack.png
share/wesnoth/images/elvish-ranger-attack1.png
share/wesnoth/images/elvish-ranger-attack2.png
+share/wesnoth/images/elvish-ranger-attack3.png
share/wesnoth/images/elvish-ranger-bow-defend.png
share/wesnoth/images/elvish-ranger-defend.png
share/wesnoth/images/elvish-ranger.png
share/wesnoth/images/elvish-scout-attack.png
+share/wesnoth/images/elvish-scout-attack1.png
+share/wesnoth/images/elvish-scout-attack2.png
share/wesnoth/images/elvish-scout-defend.png
share/wesnoth/images/elvish-scout.png
share/wesnoth/images/elvish-shaman-attack.png
@@ -357,24 +412,29 @@ share/wesnoth/images/elvish-shaman.png
share/wesnoth/images/elvish-sharpshooter-attack.png
share/wesnoth/images/elvish-sharpshooter-attack1.png
share/wesnoth/images/elvish-sharpshooter-attack2.png
+share/wesnoth/images/elvish-sharpshooter-attack3.png
share/wesnoth/images/elvish-sharpshooter.png
share/wesnoth/images/elvish-shyde.png
share/wesnoth/images/enemy-energy.png
share/wesnoth/images/entangle.png
share/wesnoth/images/fireball.png
share/wesnoth/images/galleon.png
+share/wesnoth/images/goblin-direwolver.png
share/wesnoth/images/goblin-knight-attack.png
share/wesnoth/images/goblin-knight.png
share/wesnoth/images/goblin-pillager-attack.png
share/wesnoth/images/goblin-pillager-attack2.png
share/wesnoth/images/goblin-pillager-defend.png
share/wesnoth/images/goblin-pillager.png
+share/wesnoth/images/grand-knight.png
share/wesnoth/images/great-mage.png
share/wesnoth/images/gryphon-rider.png
share/wesnoth/images/gryphon-sleeping.png
share/wesnoth/images/gryphon.png
share/wesnoth/images/horseman-attack.png
share/wesnoth/images/horseman.png
+share/wesnoth/images/human-battleprincess-attack.png
+share/wesnoth/images/human-battleprincess-defend.png
share/wesnoth/images/human-battleprincess.png
share/wesnoth/images/human-bowman-attack-sword.png
share/wesnoth/images/human-bowman-attack1.png
@@ -399,6 +459,7 @@ share/wesnoth/images/human-longbowman-attack2.png
share/wesnoth/images/human-longbowman-defend-close.png
share/wesnoth/images/human-longbowman-defend.png
share/wesnoth/images/human-longbowman.png
+share/wesnoth/images/human-masterbowman-defend.png
share/wesnoth/images/human-masterbowman.png
share/wesnoth/images/human-pikeman.png
share/wesnoth/images/human-princess-attack.png
@@ -464,6 +525,7 @@ share/wesnoth/images/konrad-fighter.png
share/wesnoth/images/konrad-lord-attack.png
share/wesnoth/images/konrad-lord.png
share/wesnoth/images/konrad-young-attack.png
+share/wesnoth/images/konrad-young-defend.png
share/wesnoth/images/konrad-young.png
share/wesnoth/images/lightning-bolt.png
share/wesnoth/images/lightning-n.png
@@ -502,7 +564,38 @@ share/wesnoth/images/misc/delfador.png
share/wesnoth/images/misc/disk.png
share/wesnoth/images/misc/dot.png
share/wesnoth/images/misc/druidstaff.png
+share/wesnoth/images/misc/ellipse-1-bottom.png
+share/wesnoth/images/misc/ellipse-1-top.png
+share/wesnoth/images/misc/ellipse-1.png
+share/wesnoth/images/misc/ellipse-10-bottom.png
+share/wesnoth/images/misc/ellipse-10-top.png
+share/wesnoth/images/misc/ellipse-10.png
+share/wesnoth/images/misc/ellipse-2-bottom.png
+share/wesnoth/images/misc/ellipse-2-top.png
+share/wesnoth/images/misc/ellipse-2.png
+share/wesnoth/images/misc/ellipse-3-bottom.png
+share/wesnoth/images/misc/ellipse-3-top.png
+share/wesnoth/images/misc/ellipse-3.png
+share/wesnoth/images/misc/ellipse-4-bottom.png
+share/wesnoth/images/misc/ellipse-4-top.png
+share/wesnoth/images/misc/ellipse-4.png
+share/wesnoth/images/misc/ellipse-5-bottom.png
+share/wesnoth/images/misc/ellipse-5-top.png
+share/wesnoth/images/misc/ellipse-5.png
+share/wesnoth/images/misc/ellipse-6-bottom.png
+share/wesnoth/images/misc/ellipse-6-top.png
+share/wesnoth/images/misc/ellipse-6.png
+share/wesnoth/images/misc/ellipse-7-bottom.png
+share/wesnoth/images/misc/ellipse-7-top.png
+share/wesnoth/images/misc/ellipse-7.png
+share/wesnoth/images/misc/ellipse-8-bottom.png
+share/wesnoth/images/misc/ellipse-8-top.png
+share/wesnoth/images/misc/ellipse-8.png
+share/wesnoth/images/misc/ellipse-9-bottom.png
+share/wesnoth/images/misc/ellipse-9-top.png
+share/wesnoth/images/misc/ellipse-9.png
share/wesnoth/images/misc/entangle.png
+share/wesnoth/images/misc/eye.png
share/wesnoth/images/misc/fangs.png
share/wesnoth/images/misc/fireball.png
share/wesnoth/images/misc/fist.png
@@ -621,6 +714,7 @@ share/wesnoth/images/missile-sw.png
share/wesnoth/images/missile.png
share/wesnoth/images/missiledagger-n.png
share/wesnoth/images/missiledagger-ne.png
+share/wesnoth/images/missilehatchet.png
share/wesnoth/images/missilespear-n.png
share/wesnoth/images/missilespear-ne.png
share/wesnoth/images/missilestone.png
@@ -658,6 +752,7 @@ share/wesnoth/images/orc-archer-attack.png
share/wesnoth/images/orc-archer-attack2.png
share/wesnoth/images/orc-archer.png
share/wesnoth/images/orc-assassin-attack.png
+share/wesnoth/images/orc-assassin-defend.png
share/wesnoth/images/orc-assassin.png
share/wesnoth/images/orc-slayer.png
share/wesnoth/images/orc-xbowman-attack.png
@@ -665,19 +760,33 @@ share/wesnoth/images/orc-xbowman.png
share/wesnoth/images/orcish-grunt-attack.png
share/wesnoth/images/orcish-grunt-defend.png
share/wesnoth/images/orcish-grunt.png
+share/wesnoth/images/orcish-ruler.png
+share/wesnoth/images/orcish-shaman.png
+share/wesnoth/images/orcish-shaman1.png
+share/wesnoth/images/orcish-shaman2.png
share/wesnoth/images/orcish-warlord.png
share/wesnoth/images/orcish-warrior-defend.png
+share/wesnoth/images/orcish-warrior-melee1.png
share/wesnoth/images/orcish-warrior.png
share/wesnoth/images/paladin.png
share/wesnoth/images/partmoved-energy.png
+share/wesnoth/images/pirate-galleon.png
share/wesnoth/images/red-mage.png
share/wesnoth/images/rogue-attack.png
share/wesnoth/images/rogue-defend.png
share/wesnoth/images/rogue.png
+share/wesnoth/images/scorpion-pincers-attack.png
+share/wesnoth/images/scorpion.png
share/wesnoth/images/sea-hag-defend.png
share/wesnoth/images/sea-hag.png
share/wesnoth/images/sea-orc.png
share/wesnoth/images/seaserpent.png
+share/wesnoth/images/sotbe/bigmap.png
+share/wesnoth/images/sotbe/fire.png
+share/wesnoth/images/sotbe/flag.png
+share/wesnoth/images/sotbe/map1.png
+share/wesnoth/images/sotbe/map2.png
+share/wesnoth/images/sotbe/map3.png
share/wesnoth/images/terrain/alpha.png
share/wesnoth/images/terrain/bridge-n-s.png
share/wesnoth/images/terrain/bridge-ne-sw.png
@@ -703,6 +812,25 @@ share/wesnoth/images/terrain/castle-sw-nw-n.png
share/wesnoth/images/terrain/castle-sw-nw.png
share/wesnoth/images/terrain/castle-sw.png
share/wesnoth/images/terrain/castle.png
+share/wesnoth/images/terrain/cave-n-ne-se-s.png
+share/wesnoth/images/terrain/cave-n-ne-se.png
+share/wesnoth/images/terrain/cave-n-ne.png
+share/wesnoth/images/terrain/cave-n.png
+share/wesnoth/images/terrain/cave-ne-se-s.png
+share/wesnoth/images/terrain/cave-ne-se.png
+share/wesnoth/images/terrain/cave-ne.png
+share/wesnoth/images/terrain/cave-nw-n.png
+share/wesnoth/images/terrain/cave-nw.png
+share/wesnoth/images/terrain/cave-s-sw-nw-n.png
+share/wesnoth/images/terrain/cave-s-sw-nw.png
+share/wesnoth/images/terrain/cave-s-sw.png
+share/wesnoth/images/terrain/cave-s.png
+share/wesnoth/images/terrain/cave-se-s.png
+share/wesnoth/images/terrain/cave-se-sw-nw.png
+share/wesnoth/images/terrain/cave-se.png
+share/wesnoth/images/terrain/cave-sw-nw-n.png
+share/wesnoth/images/terrain/cave-sw-nw.png
+share/wesnoth/images/terrain/cave-sw.png
share/wesnoth/images/terrain/cave.png
share/wesnoth/images/terrain/cavewall.png
share/wesnoth/images/terrain/coast-n.png
@@ -720,9 +848,16 @@ share/wesnoth/images/terrain/desert-s.png
share/wesnoth/images/terrain/desert-se.png
share/wesnoth/images/terrain/desert-sw.png
share/wesnoth/images/terrain/desert.png
+share/wesnoth/images/terrain/dirt-n.png
+share/wesnoth/images/terrain/dirt-ne.png
+share/wesnoth/images/terrain/dirt-nw.png
+share/wesnoth/images/terrain/dirt-s.png
+share/wesnoth/images/terrain/dirt-se.png
+share/wesnoth/images/terrain/dirt-sw.png
share/wesnoth/images/terrain/dirt.png
share/wesnoth/images/terrain/dwarven-doors.png
share/wesnoth/images/terrain/flag-cave-neutral.png
+share/wesnoth/images/terrain/flag-coast-neutral.png
share/wesnoth/images/terrain/flag-neutral-dusk.png
share/wesnoth/images/terrain/flag-neutral-first_watch.png
share/wesnoth/images/terrain/flag-neutral-n.png
@@ -734,6 +869,7 @@ share/wesnoth/images/terrain/flag-neutral-second_watch.png
share/wesnoth/images/terrain/flag-neutral-sw.png
share/wesnoth/images/terrain/flag-neutral.png
share/wesnoth/images/terrain/flag-snow-neutral.png
+share/wesnoth/images/terrain/flag-swampwater-neutral.png
share/wesnoth/images/terrain/flag-team1.png
share/wesnoth/images/terrain/flag-team10.png
share/wesnoth/images/terrain/flag-team2.png
@@ -744,11 +880,25 @@ share/wesnoth/images/terrain/flag-team6.png
share/wesnoth/images/terrain/flag-team7.png
share/wesnoth/images/terrain/flag-team8.png
share/wesnoth/images/terrain/flag-team9.png
+share/wesnoth/images/terrain/fog-n-ne-se-s.png
+share/wesnoth/images/terrain/fog-n-ne-se.png
+share/wesnoth/images/terrain/fog-n-ne.png
share/wesnoth/images/terrain/fog-n.png
+share/wesnoth/images/terrain/fog-ne-se-s.png
+share/wesnoth/images/terrain/fog-ne-se.png
share/wesnoth/images/terrain/fog-ne.png
+share/wesnoth/images/terrain/fog-nw-n-ne.png
+share/wesnoth/images/terrain/fog-nw-n.png
share/wesnoth/images/terrain/fog-nw.png
+share/wesnoth/images/terrain/fog-s-sw-nw-n.png
+share/wesnoth/images/terrain/fog-s-sw-nw.png
+share/wesnoth/images/terrain/fog-s-sw.png
share/wesnoth/images/terrain/fog-s.png
+share/wesnoth/images/terrain/fog-se-s-sw.png
+share/wesnoth/images/terrain/fog-se-s.png
share/wesnoth/images/terrain/fog-se.png
+share/wesnoth/images/terrain/fog-sw-nw-n.png
+share/wesnoth/images/terrain/fog-sw-nw.png
share/wesnoth/images/terrain/fog-sw.png
share/wesnoth/images/terrain/fog.png
share/wesnoth/images/terrain/forest-n.png
@@ -792,6 +942,16 @@ share/wesnoth/images/terrain/hills-sw.png
share/wesnoth/images/terrain/hills.png
share/wesnoth/images/terrain/human-village.gif
share/wesnoth/images/terrain/human-village.png
+share/wesnoth/images/terrain/ice-bridge-ne-sw.png
+share/wesnoth/images/terrain/ice-n.png
+share/wesnoth/images/terrain/ice-ne.png
+share/wesnoth/images/terrain/ice-nw.png
+share/wesnoth/images/terrain/ice-pier.png
+share/wesnoth/images/terrain/ice-s.png
+share/wesnoth/images/terrain/ice-se.png
+share/wesnoth/images/terrain/ice-sw.png
+share/wesnoth/images/terrain/ice.png
+share/wesnoth/images/terrain/icebridge-se-nw.png
share/wesnoth/images/terrain/keep.png
share/wesnoth/images/terrain/lava.png
share/wesnoth/images/terrain/mask.png
@@ -855,11 +1015,18 @@ share/wesnoth/images/terrain/snow-sw.png
share/wesnoth/images/terrain/snow.png
share/wesnoth/images/terrain/snow2.png
share/wesnoth/images/terrain/snowbits.png
+share/wesnoth/images/terrain/swampwater-n.png
+share/wesnoth/images/terrain/swampwater-ne.png
+share/wesnoth/images/terrain/swampwater-nw.png
+share/wesnoth/images/terrain/swampwater-s.png
+share/wesnoth/images/terrain/swampwater-se.png
+share/wesnoth/images/terrain/swampwater-sw.png
share/wesnoth/images/terrain/swampwater.png
share/wesnoth/images/terrain/swampwater2.png
share/wesnoth/images/terrain/swampwater3.png
share/wesnoth/images/terrain/temple.png
share/wesnoth/images/terrain/test.png
+share/wesnoth/images/terrain/trash.png
share/wesnoth/images/terrain/void-n.png
share/wesnoth/images/terrain/void-ne.png
share/wesnoth/images/terrain/void-nw.png
@@ -870,6 +1037,7 @@ share/wesnoth/images/terrain/void.png
share/wesnoth/images/thief-attack.png
share/wesnoth/images/thief-defend.png
share/wesnoth/images/thief.png
+share/wesnoth/images/tower.png
share/wesnoth/images/troll-grunt-attack.png
share/wesnoth/images/troll-grunt.png
share/wesnoth/images/troll-warrior-attack.png
@@ -883,6 +1051,8 @@ share/wesnoth/images/undead-adept.png
share/wesnoth/images/undead-ancient-lich-attack.png
share/wesnoth/images/undead-ancient-lich-defend.png
share/wesnoth/images/undead-ancient-lich.png
+share/wesnoth/images/undead-archer-attack1.png
+share/wesnoth/images/undead-archer-attack2.png
share/wesnoth/images/undead-archer.png
share/wesnoth/images/undead-bat-attack.png
share/wesnoth/images/undead-bat.png
@@ -898,6 +1068,10 @@ share/wesnoth/images/undead-ghost.png
share/wesnoth/images/undead-ghoul-attack.png
share/wesnoth/images/undead-ghoul-defend.png
share/wesnoth/images/undead-ghoul.png
+share/wesnoth/images/undead-lich-defend.png
+share/wesnoth/images/undead-lich-melee.png
+share/wesnoth/images/undead-lich-ranged1.png
+share/wesnoth/images/undead-lich-ranged2.png
share/wesnoth/images/undead-lich.png
share/wesnoth/images/undead-necromancer-attack.png
share/wesnoth/images/undead-necromancer-attack2.png
@@ -912,13 +1086,17 @@ share/wesnoth/images/undead-revenant.png
share/wesnoth/images/undead-shadow-attack.png
share/wesnoth/images/undead-shadow-defend.png
share/wesnoth/images/undead-shadow.png
+share/wesnoth/images/undead-skeleton-attack.png
+share/wesnoth/images/undead-skeleton-attackb.png
share/wesnoth/images/undead-skeleton-defend.png
share/wesnoth/images/undead-skeleton.png
share/wesnoth/images/undead-spectre-attack.png
share/wesnoth/images/undead-spectre-attack1.png
share/wesnoth/images/undead-spectre-defend.png
share/wesnoth/images/undead-spectre.png
+share/wesnoth/images/undead-wraith-attack.png
share/wesnoth/images/undead-wraith-attack1.png
+share/wesnoth/images/undead-wraith-defend.png
share/wesnoth/images/undead-wraith.png
share/wesnoth/images/undead-zombie-attack.png
share/wesnoth/images/undead-zombie.png
@@ -933,6 +1111,10 @@ share/wesnoth/images/whitemissile-ne.png
share/wesnoth/images/wolf-rider-attack.png
share/wesnoth/images/wolf-rider-defend.png
share/wesnoth/images/wolf-rider.png
+share/wesnoth/images/yeti-attack1.png
+share/wesnoth/images/yeti-attack2.png
+share/wesnoth/images/yeti-defend.png
+share/wesnoth/images/yeti.png
share/wesnoth/music/elf-land.ogg
share/wesnoth/music/frantic.ogg
share/wesnoth/music/underground.ogg
@@ -972,14 +1154,23 @@ share/wesnoth/sounds/wolf-cry.wav
@dirrm share/wesnoth/sounds
@dirrm share/wesnoth/music
@dirrm share/wesnoth/images/terrain
+@dirrm share/wesnoth/images/sotbe
@dirrm share/wesnoth/images/misc
+@dirrm share/wesnoth/images/cursors-bw
+@dirrm share/wesnoth/images/cursors
@dirrm share/wesnoth/images/buttons
@dirrm share/wesnoth/images
@dirrm share/wesnoth/fonts
@dirrm share/wesnoth/data/units
@dirrm share/wesnoth/data/translations
@dirrm share/wesnoth/data/themes
+@dirrm share/wesnoth/data/scenarios/Son_Of_The_Black_Eye
@dirrm share/wesnoth/data/scenarios
@dirrm share/wesnoth/data/maps
@dirrm share/wesnoth/data
@dirrm share/wesnoth
+%%GNOME:%%share/gnome/apps/Games/wesnoth.desktop
+%%GNOME:%%share/gnome/pixmaps/wesnoth-icon.png
+%%KDE:%%@cwd %%LOCALBASE%%
+%%KDE:%%share/applnk/Games/TacticStrategy/wesnoth.desktop
+%%KDE:%%share/icons/wesnoth-icon.png