aboutsummaryrefslogtreecommitdiff
path: root/games/whichwayisup/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-01 21:14:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-01 21:14:38 +0000
commit7e0e703b750cbb7a68aa37ee89879106a221215d (patch)
treed09d5ff072a06383d5d0fc353503c162f11c2400 /games/whichwayisup/Makefile
parent3a7e11c6eb421430864672cef75302d10913ee06 (diff)
downloadports-7e0e703b750cbb7a68aa37ee89879106a221215d.tar.gz
ports-7e0e703b750cbb7a68aa37ee89879106a221215d.zip
Notes
Diffstat (limited to 'games/whichwayisup/Makefile')
-rw-r--r--games/whichwayisup/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/whichwayisup/Makefile b/games/whichwayisup/Makefile
index dee3557be69f..f86790c8a8d6 100644
--- a/games/whichwayisup/Makefile
+++ b/games/whichwayisup/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= whichwayisup
-PORTVERSION= 0.7.0
+PORTVERSION= 0.7.9
DISTVERSION= ${PORTVERSION:S/.//g}
CATEGORIES= games
-MASTER_SITES= http://hectigo.net/puskutraktori/whichwayisup/ CENKES
+MASTER_SITES= http://hectigo.net/puskutraktori/whichwayisup/
DISTNAME= ${PORTNAME}_b${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -21,11 +21,14 @@ USE_PYTHON= yes
USE_ZIP= yes
PORTDOCS= README.txt changelog.txt
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
post-patch:
@${REINPLACE_CMD} -e '/libdir =/s|=.*|= "${PYTHON_SITELIBDIR}/${PORTNAME}"|'\
${WRKSRC}/run_game.py
@${REINPLACE_CMD} -e '/data_dir =/s|data_py.*data.|"${DATADIR}"|'\
${WRKSRC}/lib/data.py
+ @${RM} ${WRKSRC}/lib/data.py.bak
do-build:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/lib/