aboutsummaryrefslogtreecommitdiff
path: root/games/widelands
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2017-06-20 15:14:01 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2017-06-20 15:14:01 +0000
commit5298cf942ba7c363d2d48621fe0ec5d8162ec4d5 (patch)
treebc6021eaa74bb298a645fccaf46d647e040a74ca /games/widelands
parent447662f11355733b54257112f3153e6fcd844082 (diff)
downloadports-5298cf942ba7c363d2d48621fe0ec5d8162ec4d5.tar.gz
ports-5298cf942ba7c363d2d48621fe0ec5d8162ec4d5.zip
Notes
Diffstat (limited to 'games/widelands')
-rw-r--r--games/widelands/Makefile20
-rw-r--r--games/widelands/distinfo5
-rw-r--r--games/widelands/files/patch-CMakeLists.txt54
-rw-r--r--games/widelands/files/patch-cmake_WlFunctions.cmake9
-rw-r--r--games/widelands/files/patch-src-i18n.cc10
-rw-r--r--games/widelands/pkg-plist51
6 files changed, 117 insertions, 32 deletions
diff --git a/games/widelands/Makefile b/games/widelands/Makefile
index 15a1a2f09e53..ace8b09f8089 100644
--- a/games/widelands/Makefile
+++ b/games/widelands/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= widelands
-DISTVERSION= build18
-PORTREVISION= 11
+DISTVERSION= build19
CATEGORIES= games
-MASTER_SITES= https://launchpadlibrarian.net/167260749/ \
+MASTER_SITES= https://launchpad.net/widelands/${DISTVERSION}/${DISTVERSION}/+download/ \
http://mirror.amdmi3.ru/distfiles/
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
@@ -19,19 +18,18 @@ LIB_DEPENDS= libpng.so:graphics/png
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
USES= cmake:outsource compiler:c++11-lib execinfo gettext \
- lua:51 tar:bzip2 python:build
-CMAKE_ARGS= -DWL_INSTALL_PREFIX="${PREFIX}" \
- -DWL_INSTALL_DATADIR="share/widelands" \
+ lua:52 tar:bzip2 python:build
+CMAKE_ARGS= -DWL_INSTALL_BASEDIR="${PREFIX}" \
+ -DWL_INSTALL_DATADIR="${DATADIR}" \
+ -DWL_INSTALL_DOCDIR="${DOCSDIR}" \
-DWL_INSTALL_BINDIR="bin" \
-DWL_VERSION="${DISTVERSION}" \
- -DWL_COMPILERFLAG_OPTIMIZATIONS=""
+ -DWL_OPTIMIZE_FLAGS=""
USE_GL= glew
-USE_SDL= sdl mixer image net ttf gfx
+USE_SDL= sdl2 mixer2 image2 net2 ttf2
-PLIST_FILES= bin/widelands
PORTDATA= *
-PLIST_DIRS= %%DATADIR%%/maps/Desert\ Tournament.wmf/scripting \
- %%DATADIR%%/maps/Swamp\ Monks.wmf/scripting
+PORTDOCS= *
DESKTOP_ENTRIES="Widelands" \
"" \
diff --git a/games/widelands/distinfo b/games/widelands/distinfo
index 380a4633f051..a47d39e52d41 100644
--- a/games/widelands/distinfo
+++ b/games/widelands/distinfo
@@ -1,2 +1,3 @@
-SHA256 (widelands-build18-src.tar.bz2) = 6dffd9178f93ff7a9c3c0c9b31b7d3b8eb060c79fbd98901e6311837390b7de3
-SIZE (widelands-build18-src.tar.bz2) = 183443325
+TIMESTAMP = 1494019260
+SHA256 (widelands-build19-src.tar.bz2) = e511f9d26828a2b71b64cdfc6674e6e847543b2da73961ab882acca36c7c01a6
+SIZE (widelands-build19-src.tar.bz2) = 181609391
diff --git a/games/widelands/files/patch-CMakeLists.txt b/games/widelands/files/patch-CMakeLists.txt
index 054d4b01c06c..6465deda7e62 100644
--- a/games/widelands/files/patch-CMakeLists.txt
+++ b/games/widelands/files/patch-CMakeLists.txt
@@ -1,11 +1,47 @@
---- CMakeLists.txt.orig 2014-02-22 13:06:51.000000000 +0400
-+++ CMakeLists.txt 2014-02-26 18:16:19.484090644 +0400
-@@ -254,7 +254,7 @@
- # CMAKE only defines "-g", but we need -DDEBUG also, and we need -DNOPARACHUTE (for SDL) in Debug
- set (CMAKE_CXX_FLAGS_DEBUG "${WL_COMPILERFLAG_CXXSTD} -g -DDEBUG -DNOPARACHUTE${WL_COMPILERFLAG_OLDSTYLECAST}${WL_COMPILERFLAG_GENERICWARNINGS}${WL_COMPILERFLAG_EXTRAWARNINGS}${WL_COMPILERFLAG_GCCWARNINGS}${WL_COMPILERFLAG_STRICT}" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
+--- CMakeLists.txt.orig 2016-11-10 07:28:01 UTC
++++ CMakeLists.txt
+@@ -93,7 +93,7 @@ endif (NOT CMAKE_BUILD_TYPE OR CMAKE_BUILD_TYPE STREQU
+ if(CMAKE_BUILD_TYPE STREQUAL "Debug")
+ set(WL_DEBUG_FLAGS "-g -DDEBUG")
+ elseif(CMAKE_BUILD_TYPE STREQUAL "Release")
+- set(WL_OPTIMIZE_FLAGS "-O3")
++ set(WL_OPTIMIZE_FLAGS "-O3" CACHE STRING "")
+ set(WL_DEBUG_FLAGS "-DNDEBUG -DNOPARACHUTE")
+ elseif(CMAKE_BUILD_TYPE STREQUAL "RelWithDebInfo")
+ set(WL_OPTIMIZE_FLAGS "-O3")
+@@ -225,7 +225,7 @@ if (NOT DEFINED WL_VERSION)
+ else (NOT DEFINED WL_VERSION)
+ add_custom_target (
+ InputRevision ALL
+- COMMAND ${CMAKE_COMMAND -DWL_INSTALL_BASEDIR=${WL_INSTALL_BASEDIR} -DWL_VERSION=${WL_VERSION} -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE} -DSOURCE_DIR=${CMAKE_CURRENT_SOURCE_DIR} -DBINARY_DIR=${CMAKE_CURRENT_BINARY_DIR} -P ${CMAKE_CURRENT_SOURCE_DIR}/cmake/InputRevision.cmake
++ COMMAND ${CMAKE_COMMAND} -DWL_INSTALL_BASEDIR=${WL_INSTALL_BASEDIR} -DWL_VERSION=${WL_VERSION} -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE} -DSOURCE_DIR=${CMAKE_CURRENT_SOURCE_DIR} -DBINARY_DIR=${CMAKE_CURRENT_BINARY_DIR} -P ${CMAKE_CURRENT_SOURCE_DIR}/cmake/InputRevision.cmake
+ )
+ endif (NOT DEFINED WL_VERSION)
--set (WL_COMPILERFLAG_OPTIMIZATIONS "-O3")
-+set (WL_COMPILERFLAG_OPTIMIZATIONS "-O3" CACHE STRING "")
+@@ -244,7 +244,7 @@ add_custom_target(_run_all_tests ALL
- #This can be removed if no one uses gcc 4.5.1 or 4.5.2 any more
- IF (CMAKE_COMPILER_IS_GNUCXX)
+ install (
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/VERSION
+- DESTINATION ${WL_INSTALL_BASEDIR}
++ DESTINATION ${WL_INSTALL_DOCDIR}
+ CONFIGURATIONS Debug;Release
+ COMPONENT CoreVersionFile
+ )
+@@ -294,7 +294,7 @@ install(
+ COPYING
+ CREDITS
+ ChangeLog
+- DESTINATION ${WL_INSTALL_BASEDIR}
++ DESTINATION ${WL_INSTALL_DOCDIR}
+ CONFIGURATIONS Debug;Release
+ COMPONENT CoreLicenseFiles
+ )
+@@ -302,7 +302,7 @@ install(
+ install(
+ DIRECTORY
+ doc
+- DESTINATION ${WL_INSTALL_BASEDIR}
++ DESTINATION ${WL_INSTALL_DOCDIR}
+ CONFIGURATIONS Debug
+ COMPONENT DocFiles
+ PATTERN "CMakeLists.txt" EXCLUDE
diff --git a/games/widelands/files/patch-cmake_WlFunctions.cmake b/games/widelands/files/patch-cmake_WlFunctions.cmake
new file mode 100644
index 000000000000..44d2c6505f48
--- /dev/null
+++ b/games/widelands/files/patch-cmake_WlFunctions.cmake
@@ -0,0 +1,9 @@
+--- cmake/WlFunctions.cmake.orig 2016-11-10 07:28:01 UTC
++++ cmake/WlFunctions.cmake
+@@ -276,5 +276,5 @@ function(wl_binary NAME)
+
+ #Quoting the CMake documentation on DESTINATION:
+ #"If a relative path is given it is interpreted relative to the value of CMAKE_INSTALL_PREFIX"
+- install(TARGETS ${NAME} DESTINATION "." COMPONENT ExecutableFiles)
++ install(TARGETS ${NAME} DESTINATION "bin" COMPONENT ExecutableFiles)
+ endfunction()
diff --git a/games/widelands/files/patch-src-i18n.cc b/games/widelands/files/patch-src-i18n.cc
deleted file mode 100644
index 4aac45aaab04..000000000000
--- a/games/widelands/files/patch-src-i18n.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/i18n.cc.orig 2012-04-23 13:46:49.000000000 +0400
-+++ src/i18n.cc 2013-09-13 20:18:48.792226136 +0400
-@@ -27,6 +27,7 @@
-
- #include <cstdlib>
- #include <utility>
-+#include <clocale>
-
- #if __APPLE__ && LIBINTL_VERSION >= 0x001201
- // for older libintl versions, setlocale is just fine
diff --git a/games/widelands/pkg-plist b/games/widelands/pkg-plist
new file mode 100644
index 000000000000..47129ca23123
--- /dev/null
+++ b/games/widelands/pkg-plist
@@ -0,0 +1,51 @@
+bin/widelands
+bin/wl_map_info
+bin/wl_map_object_info
+bin/wl_render_richtext
+@dir %%DATADIR%%/maps/Archipelago_Sea.wmf/scripting
+@dir %%DATADIR%%/maps/Atoll.wmf/scripting
+@dir %%DATADIR%%/maps/Calvisson.wmf/scripting
+@dir %%DATADIR%%/maps/Checkmate.wmf/scripting
+@dir %%DATADIR%%/maps/Comet_Island_v2.wmf/scripting
+@dir %%DATADIR%%/maps/Crater.wmf/scripting
+@dir %%DATADIR%%/maps/Crossing_the_Horizon.wmf/scripting
+@dir %%DATADIR%%/maps/Desert_Tournament.wmf/scripting
+@dir %%DATADIR%%/maps/Dolomites_v2.wmf/scripting
+@dir %%DATADIR%%/maps/Elven_Forests.wmf/scripting
+@dir %%DATADIR%%/maps/Fellowships_v2.wmf/scripting
+@dir %%DATADIR%%/maps/Finnish_Lakes.wmf/scripting
+@dir %%DATADIR%%/maps/Firegames.wmf/scripting
+@dir %%DATADIR%%/maps/Four_Castles.wmf/scripting
+@dir %%DATADIR%%/maps/Four_Mountains.wmf/scripting
+@dir %%DATADIR%%/maps/Full_Moon_v2.wmf/scripting
+@dir %%DATADIR%%/maps/Glacier_Lake_v2.wmf/scripting
+@dir %%DATADIR%%/maps/Golden_Peninsula.wmf/scripting
+@dir %%DATADIR%%/maps/Ice_wars.wmf/scripting
+@dir %%DATADIR%%/maps/Impact.wmf/scripting
+@dir %%DATADIR%%/maps/Islands_at_War.wmf/scripting
+@dir %%DATADIR%%/maps/Kings_and_Queens_v2.wmf/scripting
+@dir %%DATADIR%%/maps/Lake_of_Tranquility.wmf/scripting
+@dir %%DATADIR%%/maps/Last_Bastion_v2.wmf/scripting
+@dir %%DATADIR%%/maps/Last_Survivors.wmf/scripting
+@dir %%DATADIR%%/maps/Mystical_Maze.wmf/scripting
+@dir %%DATADIR%%/maps/Rendez-Vous.wmf/scripting
+@dir %%DATADIR%%/maps/River_Explorers.wmf/scripting
+@dir %%DATADIR%%/maps/Riverlands.wmf/scripting
+@dir %%DATADIR%%/maps/Sun_of_Fire.wmf/scripting
+@dir %%DATADIR%%/maps/Swamp_Island.wmf/scripting
+@dir %%DATADIR%%/maps/Swamp_Monks.wmf/scripting
+@dir %%DATADIR%%/maps/The_Big_Lake.wmf/scripting
+@dir %%DATADIR%%/maps/The_Far_North.wmf/scripting
+@dir %%DATADIR%%/maps/The_Long_Way.wmf/scripting
+@dir %%DATADIR%%/maps/The_Nile_v2.wmf/scripting
+@dir %%DATADIR%%/maps/The_Oasis_Triangle.wmf/scripting
+@dir %%DATADIR%%/maps/The_Pass_Through_the_Mountains.wmf/scripting
+@dir %%DATADIR%%/maps/The_Thaw.wmf/scripting
+@dir %%DATADIR%%/maps/Three_Warriors.wmf/scripting
+@dir %%DATADIR%%/maps/Together_We're_Strong.wmf/scripting
+@dir %%DATADIR%%/maps/Twin_Lagoons_v2.wmf/scripting
+@dir %%DATADIR%%/maps/Twinkling_Waves.wmf/scripting
+@dir %%DATADIR%%/maps/Two_Frontiers.wmf/scripting
+@dir %%DATADIR%%/maps/Volcanic_Winter.wmf/scripting
+@dir %%DATADIR%%/maps/Wideworld.wmf/scripting
+@dir %%DATADIR%%/maps/Wisent_Valley.wmf/scripting