aboutsummaryrefslogtreecommitdiff
path: root/games/widelands
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2007-04-21 15:23:58 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2007-04-21 15:23:58 +0000
commitd12b503c469860be6f39a6e0e16ea99583921759 (patch)
tree3c5ff1a4d0f21753c12b3c4010b08ffb06cdae4e /games/widelands
parente04b24fbad9f0c8ef338bd4aa4ebc9ee21b66961 (diff)
downloadports-d12b503c469860be6f39a6e0e16ea99583921759.tar.gz
ports-d12b503c469860be6f39a6e0e16ea99583921759.zip
Notes
Diffstat (limited to 'games/widelands')
-rw-r--r--games/widelands/Makefile66
-rw-r--r--games/widelands/distinfo3
-rw-r--r--games/widelands/pkg-descr9
3 files changed, 78 insertions, 0 deletions
diff --git a/games/widelands/Makefile b/games/widelands/Makefile
new file mode 100644
index 000000000000..8324ec57af51
--- /dev/null
+++ b/games/widelands/Makefile
@@ -0,0 +1,66 @@
+# Ports collection makefile for: widelands
+# Date created: 8 April 2007
+# Whom: Bartosz Fabianowski <freebsd@chillt.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= widelands
+DISTVERSION= build10
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${DISTVERSION}-source
+
+MAINTAINER= freebsd@chillt.de
+COMMENT= Realtime strategy game inspired by Settlers II
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+WRKSRC= ${WRKDIR}/widelands
+PLIST= ${WRKDIR}/pkg-plist
+USE_BZIP2= yes
+USE_PYTHON_BUILD= 2.4+
+USE_GETTEXT= yes
+USE_SDL= mixer image net ttf
+
+SCONS_ARGS= CXXFLAGS="${CXXFLAGS}" LINKFLAGS="${LDFLAGS}" \
+ CPPPATH=${LOCALBASE}/include LIBPATH=${LOCALBASE}/lib \
+ CC="${CC}" CXX="${CXX}" \
+ install_prefix=${PREFIX} bindir=bin datadir=share/widelands
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|options=opts|options=opts, **dict((k, v.split()) for k, v in ARGUMENTS.iteritems())|' \
+ ${WRKSRC}/SConstruct
+ @${REINPLACE_CMD} -e 's|, True||' ${WRKSRC}/worlds/SConscript
+ @${RM} -f ${WRKSRC}/worlds/SConscript.bak
+
+do-build:
+ @cd ${WRKSRC} && \
+ (cd utils && ${TAR} xf scons-local-0.96.1.tar.gz) && \
+ ${PYTHON_CMD} utils/scons.py ${SCONS_ARGS}
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @${ECHO_CMD} bin/widelands > ${PLIST}
+ @for f in COPYING CREDITS ChangeLog README developers editor_readme ; do \
+ ${ECHO_CMD} %%DATADIR%%/doc/$$f >> ${PLIST} ; \
+ done
+ @cd ${WRKSRC} && for d in campaigns maps ; do \
+ ${LS} -1d $$d/*.wmf | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} ; \
+ done
+ @cd ${WRKSRC} && for d in fonts game_server music pics sound tribes worlds ; do \
+ ${FIND} $$d -type f \! -name SConscript | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} ; \
+ done
+ @for d in doc campaigns maps ; do \
+ ${ECHO_CMD} "@dirrm %%DATADIR%%/$$d" >> ${PLIST} ; \
+ done
+ @cd ${WRKSRC} && for d in fonts game_server music pics sound tribes worlds ; do \
+ ${FIND} $$d -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST} ; \
+ done
+ @${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${PYTHON_CMD} utils/scons.py ${SCONS_ARGS} install
+
+.include <bsd.port.mk>
diff --git a/games/widelands/distinfo b/games/widelands/distinfo
new file mode 100644
index 000000000000..13d387f66106
--- /dev/null
+++ b/games/widelands/distinfo
@@ -0,0 +1,3 @@
+MD5 (widelands-build10-source.tar.bz2) = 9e452baf7b8f22a27b4e371e2150e017
+SHA256 (widelands-build10-source.tar.bz2) = f67508066db1739839945f8c814a71a0e4a43904ff4a7f4e7cd3c269bcda18af
+SIZE (widelands-build10-source.tar.bz2) = 28526726
diff --git a/games/widelands/pkg-descr b/games/widelands/pkg-descr
new file mode 100644
index 000000000000..2b68336d842a
--- /dev/null
+++ b/games/widelands/pkg-descr
@@ -0,0 +1,9 @@
+Widelands is an open source real-time strategy game inspired by Bluebyte's
+Settlers II (TM). You are the chieftain of a small tribe. To grow your kingdom,
+you must secure resources, construct new buildings, train soldiers and wage
+war against your opponents.
+
+The game is playable and great fun already, but it is also still under heavy
+development, so do not be surprised if it crashes on you.
+
+WWW: http://www.widelands.org/