aboutsummaryrefslogtreecommitdiff
path: root/games/windstille/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-02 19:39:16 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-02 19:39:16 +0000
commit6afbd67bd963161d75b628146d17f2da3350f432 (patch)
tree3b05e3332f17aa2192e01909a9bf6351220f818f /games/windstille/Makefile
parent5e58e941e8602258375a3c26160f2d9b886af809 (diff)
downloadports-6afbd67bd963161d75b628146d17f2da3350f432.tar.gz
ports-6afbd67bd963161d75b628146d17f2da3350f432.zip
Notes
Diffstat (limited to 'games/windstille/Makefile')
-rw-r--r--games/windstille/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/games/windstille/Makefile b/games/windstille/Makefile
new file mode 100644
index 000000000000..934034448793
--- /dev/null
+++ b/games/windstille/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: windstille
+# Date created: 14 Jun 2007
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= windstille
+PORTVERSION= 0.3.0
+CATEGORIES= games
+MASTER_SITES= BERLIOS CENKES
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Classic 2D jump-n-shoot game
+
+LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
+ physfs-1.0.1:${PORTSDIR}/devel/physfs \
+ ogg.5:${PORTSDIR}/audio/libogg \
+ vorbis.4:${PORTSDIR}/audio/libvorbis \
+ png.5:${PORTSDIR}/graphics/png \
+ GLEW.1:${PORTSDIR}/graphics/glew \
+ squirrel.0:${PORTSDIR}/lang/squirrel
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
+
+USE_BZIP2= yes
+USE_SCONS= yes
+USE_GL= yes
+USE_SDL= sdl image
+USE_BISON= yes
+
+post-extract:
+ @${RM} -rf ${WRKSRC}/lib
+
+post-patch:
+ @cd ${WRKSRC}/src/ && ${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' \
+ particles/deform_drawer.cpp windstille_main.cpp objects/shockwave.cpp
+ @${REINPLACE_CMD} -e "s|glew|GLEW|;/LIBS/s|'squirrel'|'squirrel', 'sqstdlib'|"\
+ ${WRKSRC}/src/SConscript
+ @${REINPLACE_CMD} -e 's|PHYSFS_getBaseDir()|""|' ${WRKSRC}/src/windstille_main.cpp
+ @${REINPLACE_CMD} -e 's|bison|${LOCALBASE}/bin/&|' ${WRKSRC}/tools/SConscript
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/windstille ${PREFIX}/bin/
+ ${INSTALL} -d ${DATADIR}/
+ @cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR}/
+
+.include <bsd.port.mk>