aboutsummaryrefslogtreecommitdiff
path: root/games/wmqstat
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-03-30 10:56:11 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-03-30 10:56:11 +0000
commitc7461e5281c739c39a62c23358eb160d504f168a (patch)
treee39eafd8a2467444483e25981c1c982cfd26f44d /games/wmqstat
parent0203c8761c228ac40bfc7b9d49e04b34ccf3d2bd (diff)
downloadports-c7461e5281c739c39a62c23358eb160d504f168a.tar.gz
ports-c7461e5281c739c39a62c23358eb160d504f168a.zip
Notes
Diffstat (limited to 'games/wmqstat')
-rw-r--r--games/wmqstat/Makefile2
-rw-r--r--games/wmqstat/files/patch-Makefile25
2 files changed, 17 insertions, 10 deletions
diff --git a/games/wmqstat/Makefile b/games/wmqstat/Makefile
index 43f6673f0801..8214f2b36783 100644
--- a/games/wmqstat/Makefile
+++ b/games/wmqstat/Makefile
@@ -17,13 +17,13 @@ COMMENT= A dockapp for monitoring of various Internet game servers
RUN_DEPENDS= qstat:${PORTSDIR}/games/qstat
USE_XORG= xpm x11 xext
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/games/wmqstat/files/patch-Makefile b/games/wmqstat/files/patch-Makefile
index 28882d2830c9..21cbf9af64ea 100644
--- a/games/wmqstat/files/patch-Makefile
+++ b/games/wmqstat/files/patch-Makefile
@@ -1,13 +1,13 @@
---- ./Makefile.orig 2003-04-24 21:31:39.000000000 +0200
-+++ ./Makefile 2008-04-13 13:00:54.000000000 +0200
+--- Makefile.orig
++++ Makefile
@@ -1,14 +1,11 @@
-CC = cc
--
++CC ?= cc
+
-X11BASE = /usr/X11R6
-LDIR = -L${X11BASE}/lib
-IDIR = -I${X11BASE}/include
-+CC ?= cc
-
+-
-INSTALL = install
+LDIR = -L${LOCALBASE}/lib
+IDIR = -I${LOCALBASE}/include
@@ -19,12 +19,19 @@
OBJS = appcore/wmqstat.o\
appcore/srv_proc.o\
-@@ -23,8 +20,5 @@
- all: ${OBJS}
- ${CC} ${CFLAGS} -o wmqstat ${OBJS} ${LDIR} ${LIBS}
+@@ -18,13 +15,10 @@
+ wmgeneral/list.o
+
+ .c.o:
+- ${CC} ${CFLAGS} ${IDIR} -c $< -o $*.o
++ ${CC} ${CFLAGS} ${IDIR} -o $@ -c $<
+ all: ${OBJS}
+- ${CC} ${CFLAGS} -o wmqstat ${OBJS} ${LDIR} ${LIBS}
+-
-install:
- ${INSTALL} -o root -g wheel -m 755 wmqstat ${X11BASE}/bin
--
++ ${CC} ${CFLAGS} -o wmqstat $> ${LDIR} ${LIBS}
+
clean:
rm -f wmqstat appcore/*.o wmgeneral/*.o core