aboutsummaryrefslogtreecommitdiff
path: root/games/wmtictactoe
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-07 14:48:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-07 14:48:17 +0000
commitebc131d4cf022a55620fe003e2634f58852d052f (patch)
tree61e525f22ec74aeecc426728e7cdc14cef1a7371 /games/wmtictactoe
parent165adb350fabe9a4211c6d1531acb61f2fd6be32 (diff)
downloadports-ebc131d4cf022a55620fe003e2634f58852d052f.tar.gz
ports-ebc131d4cf022a55620fe003e2634f58852d052f.zip
- Fix build with clang
- Support PLIST_FILES - Trim header PR: 175035 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=311858
Diffstat (limited to 'games/wmtictactoe')
-rw-r--r--games/wmtictactoe/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/games/wmtictactoe/Makefile b/games/wmtictactoe/Makefile
index efc22bed7664..b8c33a958515 100644
--- a/games/wmtictactoe/Makefile
+++ b/games/wmtictactoe/Makefile
@@ -1,27 +1,28 @@
-# New ports collection makefile for: wmtictactoe
-# Date created: 28 Apr 1999
-# Whom: Jim Mock <jim@FreeBSD.org>
-#
+# Created by: Jim Mock <jim@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= wmtictactoe
PORTVERSION= 1.1
PORTREVISION= 3
CATEGORIES= games windowmaker afterstep
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= jim
-DISTNAME= wmtictactoe-1.1-1
+MASTER_SITES= LOCAL/jim
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= ports@FreeBSD.org
-COMMENT= A dockable TicTacToe game for WindowMaker and AfterStep
+COMMENT= Dockable TicTacToe game for WindowMaker and AfterStep
-PLIST_FILES= bin/wmtictactoe
-USE_GMAKE= yes
WRKSRC= ${WRKDIR}/wmtictactoe.app/wmtictactoe
+
USE_XORG= xpm
+USE_GMAKE= yes
+
+PLIST_FILES= bin/wmtictactoe
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^void .*main|int main|' ${WRKSRC}/wmtictactoe.c
post-install:
- @${ECHO} "===> Run 'wmtictactoe --help' for the available options"
+ @${ECHO_MSG} "===> Run 'wmtictactoe --help' for the available options"
.include <bsd.port.mk>