aboutsummaryrefslogtreecommitdiff
path: root/games/wolf3d/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-04-17 19:27:49 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-04-17 19:27:49 +0000
commita3b0bce535c7913ce03c25aa9f3bdf193e97f6c6 (patch)
treecee71590170022022d5f955b78f2102c8b037f10 /games/wolf3d/Makefile
parent8e84e20a52ef6f75962e2f4e6153c4aae1e6fe8d (diff)
downloadports-a3b0bce535c7913ce03c25aa9f3bdf193e97f6c6.tar.gz
ports-a3b0bce535c7913ce03c25aa9f3bdf193e97f6c6.zip
Notes
Diffstat (limited to 'games/wolf3d/Makefile')
-rw-r--r--games/wolf3d/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/games/wolf3d/Makefile b/games/wolf3d/Makefile
index 259d99a54a0b..8786e25d92e2 100644
--- a/games/wolf3d/Makefile
+++ b/games/wolf3d/Makefile
@@ -21,6 +21,7 @@ COMMENT= "Wolfenstein 3D Linux" by Steven Fuller (1992)
USE_SDL= sdl
OPTIONS= WOLF_SW "Install shareware data for Wolfenstein 3D" on \
+ OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
SPEAR_SW "Install shareware data for Spear of Destiny" off
SUB_FILES= pkg-message wolf3d
@@ -42,6 +43,10 @@ PLIST_SUB+= WOLF_SW=""
PLIST_SUB+= WOLF_SW="@comment "
.endif
+.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+MAKE_ENV+= OPT_CF="-O2 -fomit-frame-pointer -ffast-math -funroll-loops"
+.endif
+
.if defined(WITH_SPEAR_SW)
DISTFILES+= speardata${EXTRACT_SUFX}:sw
PLIST_SUB+= SPEAR_SW=""