aboutsummaryrefslogtreecommitdiff
path: root/games/wolf3d
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-04-17 19:27:49 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-04-17 19:27:49 +0000
commita3b0bce535c7913ce03c25aa9f3bdf193e97f6c6 (patch)
treecee71590170022022d5f955b78f2102c8b037f10 /games/wolf3d
parent8e84e20a52ef6f75962e2f4e6153c4aae1e6fe8d (diff)
downloadports-a3b0bce535c7913ce03c25aa9f3bdf193e97f6c6.tar.gz
ports-a3b0bce535c7913ce03c25aa9f3bdf193e97f6c6.zip
Notes
Diffstat (limited to 'games/wolf3d')
-rw-r--r--games/wolf3d/Makefile5
-rw-r--r--games/wolf3d/files/patch-Makefile4
-rw-r--r--games/wolf3d/pkg-plist2
3 files changed, 8 insertions, 3 deletions
diff --git a/games/wolf3d/Makefile b/games/wolf3d/Makefile
index 259d99a54a0b..8786e25d92e2 100644
--- a/games/wolf3d/Makefile
+++ b/games/wolf3d/Makefile
@@ -21,6 +21,7 @@ COMMENT= "Wolfenstein 3D Linux" by Steven Fuller (1992)
USE_SDL= sdl
OPTIONS= WOLF_SW "Install shareware data for Wolfenstein 3D" on \
+ OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
SPEAR_SW "Install shareware data for Spear of Destiny" off
SUB_FILES= pkg-message wolf3d
@@ -42,6 +43,10 @@ PLIST_SUB+= WOLF_SW=""
PLIST_SUB+= WOLF_SW="@comment "
.endif
+.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+MAKE_ENV+= OPT_CF="-O2 -fomit-frame-pointer -ffast-math -funroll-loops"
+.endif
+
.if defined(WITH_SPEAR_SW)
DISTFILES+= speardata${EXTRACT_SUFX}:sw
PLIST_SUB+= SPEAR_SW=""
diff --git a/games/wolf3d/files/patch-Makefile b/games/wolf3d/files/patch-Makefile
index e5448adb329c..ad46434f13a9 100644
--- a/games/wolf3d/files/patch-Makefile
+++ b/games/wolf3d/files/patch-Makefile
@@ -1,12 +1,12 @@
--- Makefile.orig Thu Sep 27 20:58:29 2001
-+++ Makefile Sun Apr 9 10:34:17 2006
++++ Makefile Thu Apr 13 15:49:57 2006
@@ -1,7 +1,8 @@
-CC = gcc
+#CC = gcc
#CC = gcc-3.0
-CFLAGS = -g -Wall -pedantic
-+CFLAGS += -O2 -fomit-frame-pointer -ffast-math -funroll-loops
++CFLAGS += $(OPT_CF) $(WF)
+#CFLAGS = -g -Wall -pedantic
#CFLAGS = -g -O2 -Wall -pedantic
#CFLAGS = -Wall -O6 -fomit-frame-pointer -ffast-math -funroll-loops -mpentiumpro -mcpu=pentiumpro -march=pentiumpro
diff --git a/games/wolf3d/pkg-plist b/games/wolf3d/pkg-plist
index f7ff2eba0260..a38b162c5905 100644
--- a/games/wolf3d/pkg-plist
+++ b/games/wolf3d/pkg-plist
@@ -23,7 +23,7 @@ libexec/wolf3d/sdlwolf3d-ws
%%SPEAR_SW%%%%DATADIR%%/vgagraph.sdm
%%SPEAR_SW%%%%DATADIR%%/vgahead.sdm
%%SPEAR_SW%%%%DATADIR%%/vswap.sdm
-@dirrm %%DATADIR%%
+@unexec rmdir %D/%%DATADIR%% 2>/dev/null || echo "If you are permanently removing this port, you should remove any Wolfenstein 3D and/or Spear Of Destiny data files left in %D/%%DATADIR%%." | fmt
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm libexec/wolf3d