aboutsummaryrefslogtreecommitdiff
path: root/games/wolfpack/files
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-26 19:16:46 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-26 19:16:46 +0000
commit2a7c46a12ffe92d2a8c458c9d42e074048bf534a (patch)
treedf64595a64c8036b29d19c33665e34e5d96953eb /games/wolfpack/files
parent446587fe3f458ebd79cd71700c62dec781f45b2c (diff)
downloadports-2a7c46a12ffe92d2a8c458c9d42e074048bf534a.tar.gz
ports-2a7c46a12ffe92d2a8c458c9d42e074048bf534a.zip
Notes
Diffstat (limited to 'games/wolfpack/files')
-rw-r--r--games/wolfpack/files/build.conf.tmpl63
-rw-r--r--games/wolfpack/files/patch-aa227
-rw-r--r--games/wolfpack/files/patch-ab12
-rw-r--r--games/wolfpack/files/patch-ac14
-rw-r--r--games/wolfpack/files/patch-ad45
-rw-r--r--games/wolfpack/files/post-install-info7
6 files changed, 368 insertions, 0 deletions
diff --git a/games/wolfpack/files/build.conf.tmpl b/games/wolfpack/files/build.conf.tmpl
new file mode 100644
index 000000000000..a18454a1916c
--- /dev/null
+++ b/games/wolfpack/files/build.conf.tmpl
@@ -0,0 +1,63 @@
+#
+# Below are a list of questions you may or may not need to answer. They
+# are all one-liner. Just change the default value if needed, and save
+# the file when done. Have fun!!!
+#
+
+# Please enter your name:
+MYNAME = %%NAME%%
+
+# Please enter your user name:
+# (For NT and the basic emp_client build, use "USERNAME = win-empcl2.8")
+USERNAME = %%USERNAME%%
+
+# Please enter your e-mail address:
+EMAIL = %%EMAIL%%
+
+# Please enter the host name you will be running on:
+# (For NT you can use "HOSTNAME = localhost" as this seems to be what it
+# resolves to if you use 127.0.0.1 below)
+HOSTNAME = %%HOSTNAME%%
+
+# Please enter the ip address of the host you will be running on:
+# (For NT you can use "IPADDR = 127.0.0.1")
+IPADDR = %%IPADDR%%
+
+# Please enter the port you will be running on:
+PORTNUM = 6665
+
+# Please enter the directory where you want the files for the game:
+# (For NT builds, use two \'s and make sure you include a drive letter)
+EMPDIR = %%EMPDIR%%
+
+# Please enter the C-compiler you are using (full path is allowed):
+# (For NT builds using MSVC 5.0, use "CC = CL")
+CC = gcc
+
+# Please enter the linker you are using (full path is allowed):
+LD = ld
+
+# Please enter the maximum number of countries you want:
+MAXNOC = 99
+
+# Please enter the world size you would like (WORLDX must be
+# divisible by 2):
+WORLDX = 64
+WORLDY = 32
+
+# Please enter if you are setting up a blitz (1 - yes, 0 - no)
+BLITZ = 1
+
+# Please enter the number of ETUs per update (must be divisible by 4):
+ETUS = 60
+
+# Please enter the frequency of the updates. For example:
+# Once per day - 1d
+# Once every 20 minutes - 20m
+# Once every 4 hours - 4h
+ETUFREQ = 10m
+
+# That's it... Save this file, and type "make <arch>" to build the
+# server. If you are not sure of what architectures are supported,
+# just type "make" and it will tell you. (If you are building the
+# NT port, use "nmake" instead of "make".)
diff --git a/games/wolfpack/files/patch-aa b/games/wolfpack/files/patch-aa
new file mode 100644
index 000000000000..4e8438c13e52
--- /dev/null
+++ b/games/wolfpack/files/patch-aa
@@ -0,0 +1,227 @@
+--- Makefile.orig Tue Feb 16 01:06:47 1999
++++ Makefile Tue Oct 26 14:56:09 1999
+@@ -80,7 +80,6 @@
+ ($(MAKE) genlibs $(ALPHAMASTER))
+ (cd src/lib/lwp; $(MAKE) $(ALPHAMASTER))
+ ($(MAKE) binaries $(ALPHAMASTER))
+- ($(MAKE) install)
+
+ alpha-pthreads:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -88,7 +87,6 @@
+ ($(MAKE) genlibs $(ALPHAPOSMASTER))
+ (cd src/lib/lwp; $(MAKE) $(ALPHAPOSMASTER))
+ ($(MAKE) binaries $(ALPHAPOSMASTER))
+- ($(MAKE) install)
+
+ apollo:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -96,7 +94,6 @@
+ ($(MAKE) genlibs $(APOLLOMASTER))
+ (cd src/lib/lwp; $(MAKE) $(APOLLOMASTER))
+ ($(MAKE) binaries $(APOLLOMASTER))
+- ($(MAKE) install)
+
+ freebsd:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -104,7 +101,6 @@
+ ($(MAKE) genlibs $(FREEBSDMASTER))
+ (cd src/lib/lwp; $(MAKE) $(FREEBSDMASTER))
+ ($(MAKE) binaries $(FREEBSDMASTER))
+- ($(MAKE) install)
+
+ hp:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -112,7 +108,6 @@
+ ($(MAKE) genlibs $(HPMASTER))
+ (cd src/lib/lwp; $(MAKE) $(HPMASTER))
+ ($(MAKE) binaries $(HPMASTER) CLIENTLIBS="")
+- ($(MAKE) install)
+
+ hpux:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -120,7 +115,6 @@
+ ($(MAKE) genlibs $(HPUXMASTER))
+ (cd src/lib/lwp; $(MAKE) $(HPUXMASTER))
+ ($(MAKE) binaries $(HPUXMASTER) CLIENTLIBS="")
+- ($(MAKE) install)
+
+ next:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -128,7 +122,6 @@
+ ($(MAKE) genlibs $(NEXTMASTER))
+ (cd src/lib/lwp; $(MAKE) $(NEXTMASTER))
+ ($(MAKE) binaries $(NEXTMASTER))
+- ($(MAKE) install)
+
+ irix:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -136,7 +129,6 @@
+ ($(MAKE) genlibs $(IRIXMASTER))
+ (cd src/lib/lwp; $(MAKE) $(IRIXMASTER))
+ ($(MAKE) binaries $(IRIXMASTER))
+- ($(MAKE) install)
+
+ irix5:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -144,7 +136,6 @@
+ ($(MAKE) genlibs $(IRIX5MASTER))
+ (cd src/lib/lwp; $(MAKE) $(IRIX5MASTER))
+ ($(MAKE) binaries $(IRIX5MASTER))
+- ($(MAKE) install)
+
+ isi:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -152,7 +143,6 @@
+ ($(MAKE) genlibs $(ISIMASTER))
+ (cd src/lib/lwp; $(MAKE) $(ISIMASTER))
+ ($(MAKE) binaries $(ISIMASTER))
+- ($(MAKE) install)
+
+ linux:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -162,7 +152,6 @@
+ ($(MAKE) genlibs $(LINUXMASTER))
+ (cd src/lib/lwp; $(MAKE) $(LINUXMASTER))
+ ($(MAKE) binaries $(LINUXMASTER))
+- ($(MAKE) install)
+
+ linux-pthreads:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -170,7 +159,6 @@
+ ($(MAKE) genlibs $(LINUXPTHMASTER))
+ (cd src/lib/lwp; $(MAKE) $(LINUXPTHMASTER))
+ ($(MAKE) binaries $(LINUXPTHMASTER))
+- ($(MAKE) install)
+
+ mipsbsd:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -178,7 +166,6 @@
+ ($(MAKE) genlibs $(MIPSBSDMASTER))
+ (cd src/lib/lwp; $(MAKE) mipsultrix $(MIPSBSDMASTER))
+ ($(MAKE) binaries $(MIPSBSDMASTER))
+- ($(MAKE) install)
+
+ mach2.5:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -186,7 +173,6 @@
+ ($(MAKE) genlibs $(MACH25MASTER))
+ (cd src/lib/lwp; $(MAKE) mipsultrix $(MACH25MASTER))
+ ($(MAKE) binaries $(MACH25MASTER))
+- ($(MAKE) install)
+
+ mipsultrix:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -194,7 +180,6 @@
+ ($(MAKE) genlibs $(MIPSULTMASTER))
+ (cd src/lib/lwp; $(MAKE) mipsultrix $(MIPSULTMASTER))
+ ($(MAKE) binaries $(MIPSULTMASTER))
+- ($(MAKE) install)
+
+ mipsultrix.gcc:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -202,7 +187,6 @@
+ ($(MAKE) genlibs $(MIPSULTGMASTER))
+ (cd src/lib/lwp; $(MAKE) mipsultrix $(MIPSULTGMASTER))
+ ($(MAKE) binaries $(MIPSULTGMASTER))
+- ($(MAKE) install)
+
+ nt:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -222,7 +206,6 @@
+ ($(MAKE) genlibs $(VAXULTMASTER))
+ (cd src/lib/lwp; $(MAKE) $(VAXULTMASTER))
+ ($(MAKE) binaries $(VAXULTMASTER))
+- ($(MAKE) install)
+
+ aix:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -230,7 +213,6 @@
+ ($(MAKE) genlibs $(AIXMASTER))
+ (cd src/lib/lwp; $(MAKE) aix $(AIXMASTER))
+ ($(MAKE) binaries $(AIXMASTER))
+- ($(MAKE) install)
+
+ rtpc:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -238,7 +220,6 @@
+ ($(MAKE) genlibs $(RTPCMASTER))
+ (cd src/lib/lwp; $(MAKE) aix $(RTPCMASTER))
+ ($(MAKE) binaries $(RTPCMASTER))
+- ($(MAKE) install)
+
+ sequent:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -246,7 +227,6 @@
+ ($(MAKE) genlibs $(SEQMASTER))
+ (cd src/lib/lwp; $(MAKE) $(SEQMASTER))
+ ($(MAKE) binaries $(SEQMASTER))
+- ($(MAKE) install)
+
+ sequent.fpa:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -254,7 +234,6 @@
+ ($(MAKE) genlibs $(SEQFPAMASTER))
+ (cd src/lib/lwp; $(MAKE) $(SEQFPAMASTER))
+ ($(MAKE) binaries $(SEQFPAMASTER))
+- ($(MAKE) install)
+
+ solaris:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -262,7 +241,6 @@
+ ($(MAKE) genlibs $(SOLMASTER))
+ (cd src/lib/lwp; $(MAKE) $(SOLMASTER))
+ ($(MAKE) binaries $(SOLMASTER))
+- ($(MAKE) install)
+
+ sun3:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -270,7 +248,6 @@
+ ($(MAKE) genlibs $(SUN3MASTER))
+ (cd src/lib/lwp; $(MAKE) $(SUN3MASTER))
+ ($(MAKE) binaries $(SUN3MASTER))
+- ($(MAKE) install)
+
+ sun4:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -278,7 +255,6 @@
+ ($(MAKE) genlibs $(SUN4MASTER))
+ (cd src/lib/lwp; $(MAKE) $(SUN4MASTER))
+ ($(MAKE) binaries $(SUN4MASTER))
+- ($(MAKE) install)
+
+ sun4.opt:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -286,7 +262,6 @@
+ ($(MAKE) genlibs $(SUN4OPTMASTER))
+ (cd src/lib/lwp; $(MAKE) $(SUN4OPTMASTER))
+ ($(MAKE) binaries $(SUN4OPTMASTER))
+- ($(MAKE) install)
+
+ sun4.debug:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -294,7 +269,6 @@
+ ($(MAKE) genlibs $(SUN4DBGMASTER))
+ (cd src/lib/lwp; $(MAKE) $(SUN4DBGMASTER))
+ ($(MAKE) binaries $(SUN4DBGMASTER))
+- ($(MAKE) install)
+
+ #
+ # Generic stuff that is called from the architecture specific stuff.
+@@ -527,9 +501,16 @@
+ # data directory if you didn't have one before.
+
+ install:
++ (cd src/doconfig; $(MAKE) install)
+ (cd src/client; $(MAKE) install)
+ (cd src/server; $(MAKE) install)
+ (cd src/util; $(MAKE) install)
++ cp README $(EMPDIR)
++ cp -r info.nr $(EMPDIR)
++ cp -r doc $(EMPDIR)
++ cp -r scripts $(EMPDIR)
++ cp man/*.1 $(PREFIX)/man/man1
++ cp man/*.6 $(PREFIX)/man/man6
+ -(mv $(EMPDIR)/data/econfig $(EMPDIR)/data/econfig.bak)
+ ($(EMPDIR)/bin/pconfig > $(EMPDIR)/data/econfig)
+ -(mv $(EMPDIR)/data/econfig.bak $(EMPDIR)/data/econfig)
diff --git a/games/wolfpack/files/patch-ab b/games/wolfpack/files/patch-ab
new file mode 100644
index 000000000000..66a2e7664ff1
--- /dev/null
+++ b/games/wolfpack/files/patch-ab
@@ -0,0 +1,12 @@
+diff -u -r ./include/misc.h ../emp4.patched/include/misc.h
+--- ./include/misc.h Wed Nov 18 10:12:29 1998
++++ ../emp4.patched/include/misc.h Tue Oct 26 10:55:54 1999
+@@ -181,7 +181,7 @@
+ extern char *calloc();
+ #endif
+ #else
+-#if !defined(ALPHA) && !defined(__osf__) && !defined(ultrix) && !defined(hpux)
++#if !defined(ALPHA) && !defined(__osf__) && !defined(ultrix) && !defined(hpux) && !defined(__FreeBSD__)
+ extern char *malloc();
+ extern char *calloc();
+ #endif
diff --git a/games/wolfpack/files/patch-ac b/games/wolfpack/files/patch-ac
new file mode 100644
index 000000000000..40083006bb6d
--- /dev/null
+++ b/games/wolfpack/files/patch-ac
@@ -0,0 +1,14 @@
+--- src/doconfig/Makefile Wed Nov 18 10:12:40 1998
++++ src/doconfig/Makefile.orig Tue Oct 26 15:13:55 1999
+@@ -53,7 +53,10 @@
+ @echo 'globalcflags = $(GLOBALCFLAGS)'
+ @echo 'globallflags = $(GLOBALLFLAGS)'
+ $(CC) $(GLOBALCFLAGS) $(DALL) doconfig.c -o doconfig $(GLOBALLFLAGS)
+- ./doconfig
++ ./doconfig config
++
++install: doconfig
++ ./doconfig install
+
+ nt: ntdoconfig
+
diff --git a/games/wolfpack/files/patch-ad b/games/wolfpack/files/patch-ad
new file mode 100644
index 000000000000..ccb8e8b513b6
--- /dev/null
+++ b/games/wolfpack/files/patch-ad
@@ -0,0 +1,45 @@
+--- src/doconfig/doconfig.c Sun Jan 17 03:14:13 1999
++++ src/doconfig/doconfig.c.orig Tue Oct 26 15:13:27 1999
+@@ -91,12 +91,17 @@
+ #endif
+
+ int
+-main()
++main(int argc, char **argv)
+ {
+ char buf[256];
+ char *cp;
+ char *pathname;
+
++ if (argc != 2) {
++ printf("Bad usage");
++ exit(-1);
++ }
++
+ if ((pathname = getcwd(NULL, 255)) == NULL) {
+ printf("Can't get current path!\n");
+ exit(-1);
+@@ -113,13 +118,14 @@
+ cp = (char *)rindex(pathname, '\\');
+ *cp = '\0';
+ #endif
++ if (!strcasecmp(argv[1], "config")) {
+ printf("Configuring...\n");
+ wrmakesrc(pathname);
+ sprintf(buf, "%s/include/gamesdef.h", pathname);
+ wrgamesdef(buf);
+ sprintf(buf, "%s/src/client/ipglob.c", pathname);
+ wripglob(buf);
+-
++ } else {
+ if (access(EP, 0)) {
+ printf("making directory %s\n", EP);
+ if (mkdir(EP, 493)) {
+@@ -139,6 +145,7 @@
+ wrauth(buf);
+ sprintf(buf, "%s/data/hours", EP);
+ wrhours(buf);
++ }
+ exit(0);
+ }
+
diff --git a/games/wolfpack/files/post-install-info b/games/wolfpack/files/post-install-info
new file mode 100644
index 000000000000..019a8d30665c
--- /dev/null
+++ b/games/wolfpack/files/post-install-info
@@ -0,0 +1,7 @@
+If you compile this on one machine and install it on another you will not be
+able to login as a deity from the installed machine. Check the
+$PREFIX/wolfpack/data/auth file.
+
+Please read the documentation in $PREFIX/wolfpack/README about configuring the
+server and creating a world.
+