aboutsummaryrefslogtreecommitdiff
path: root/games/wordplay
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-08 14:14:52 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-08 14:14:52 +0000
commit1db16f8e552aad4090cd266419bd4e66edb03c7e (patch)
tree52f1d2325fbb5c7666ccbac5c24ab92b489c267e /games/wordplay
parentad1bb388e254125ee59c69e886dc16e3d3a7d205 (diff)
downloadports-1db16f8e552aad4090cd266419bd4e66edb03c7e.tar.gz
ports-1db16f8e552aad4090cd266419bd4e66edb03c7e.zip
Notes
Diffstat (limited to 'games/wordplay')
-rw-r--r--games/wordplay/Makefile31
-rw-r--r--games/wordplay/files/patch-aa12
-rw-r--r--games/wordplay/pkg-descr2
-rw-r--r--games/wordplay/pkg-plist4
4 files changed, 20 insertions, 29 deletions
diff --git a/games/wordplay/Makefile b/games/wordplay/Makefile
index 02482804413d..f74ee4293147 100644
--- a/games/wordplay/Makefile
+++ b/games/wordplay/Makefile
@@ -6,30 +6,35 @@
PORTNAME= wordplay
PORTVERSION= 7.22
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= http://hsvmovies.com/static_subpages/personal/wordplay/
+MASTER_SITES= http://hsvmovies.com/static_subpages/personal_orig/wordplay/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple program to generate anagrams
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
-
NO_WRKSUBDIR= yes
-MAKEFILE= makefile
-ALL_TARGET= wordplay
+
+PORTDOCS= readme
+PLIST_FILES= bin/${PORTNAME} %%DATADIR%%/words721.txt
+PLIST_DIRS= %%DATADIR%%
post-patch:
- @${REINPLACE_CMD} -e \
- "s#words721.txt#${PREFIX}/share/wordplay/words721.txt#" \
- ${WRKSRC}/wordplay.c
+ @${REINPLACE_CMD} -e 's|"words721.txt"|"${DATADIR}/words721.txt"| ; \
+ s|<ctype.h>|<stdlib.h>|' ${WRKSRC}/wordplay.c
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${PORTNAME}.c -o ${PORTNAME}
do-install:
- @${MKDIR} ${PREFIX}/share/wordplay
- ${INSTALL_DATA} ${WRKSRC}/words721.txt ${WRKSRC}/readme \
- ${PREFIX}/share/wordplay
- ${INSTALL_PROGRAM} ${WRKSRC}/wordplay ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/words721.txt ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/games/wordplay/files/patch-aa b/games/wordplay/files/patch-aa
deleted file mode 100644
index a7d7647984a0..000000000000
--- a/games/wordplay/files/patch-aa
+++ /dev/null
@@ -1,12 +0,0 @@
---- makefile.orig Sat Jun 24 19:14:14 2000
-+++ makefile Sat Jun 24 19:14:30 2000
-@@ -1,8 +1,6 @@
-
- # If you don't have gcc, try cc instead, if it is an ANSI compiler.
-
--CC=gcc
--
- wordplay : wordplay.c
-- $(CC) -O -o wordplay wordplay.c
-+ $(CC) ${CFLAGS} -o wordplay wordplay.c
-
diff --git a/games/wordplay/pkg-descr b/games/wordplay/pkg-descr
index c06aa85e8e41..19d104b5c96f 100644
--- a/games/wordplay/pkg-descr
+++ b/games/wordplay/pkg-descr
@@ -1,2 +1,4 @@
This is a program written in ANSI C that anagrams a given string. It has
its own word file, but allows you to use a different one.
+
+WWW: http://hsvmovies.com/static_subpages/personal_orig/wordplay/
diff --git a/games/wordplay/pkg-plist b/games/wordplay/pkg-plist
deleted file mode 100644
index 512ad508a571..000000000000
--- a/games/wordplay/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/wordplay
-share/wordplay/readme
-share/wordplay/words721.txt
-@dirrm share/wordplay