aboutsummaryrefslogtreecommitdiff
path: root/games/xataxx/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-04 14:26:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-04 14:26:51 +0000
commit6e00b2437a5c3f01dcbbfa4a25e1a5c750c3fbf1 (patch)
treefb05702e81b0ea88c0d3803338b254a808634835 /games/xataxx/Makefile
parent9e2c91a9b42521d5e63ecd7cc46d40eef80488f1 (diff)
downloadports-6e00b2437a5c3f01dcbbfa4a25e1a5c750c3fbf1.tar.gz
ports-6e00b2437a5c3f01dcbbfa4a25e1a5c750c3fbf1.zip
Notes
Diffstat (limited to 'games/xataxx/Makefile')
-rw-r--r--games/xataxx/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/games/xataxx/Makefile b/games/xataxx/Makefile
index 8b38d7d11579..9a494ca662e2 100644
--- a/games/xataxx/Makefile
+++ b/games/xataxx/Makefile
@@ -1,30 +1,33 @@
-# New ports collection makefile for: xataxx
-# Date created: 4 July 1998
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= xataxx
PORTVERSION= 1.0
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= ftp://ftp.x.org/R5contrib/
+MASTER_SITES= XCONTRIB/../R5contrib
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Strategy game of position and movement for X Window System
-USE_IMAKE= yes
+OPTIONS_DEFINE= DOCS
+
USE_XORG= x11 xext
+USE_IMAKE= yes
+MAKE_JOBS_SAFE= yes
+
MAN6= xataxx.6
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/xataxx
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xataxx
- ${INSTALL_DATA} ${WRKSRC}/TODO ${PREFIX}/share/doc/xataxx
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for i in README TODO
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${DOCSDIR})
+.endfor
.endif
.include <bsd.port.mk>