aboutsummaryrefslogtreecommitdiff
path: root/games/xbill/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-24 06:47:09 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-24 06:47:09 +0000
commit6ab9d1ac6f602a1da9103716ab7d03db60711dd2 (patch)
tree26a5815280753fb4fa13c3ba3b60c26a172af88d /games/xbill/Makefile
parent67a93e97861f9ea443a740ddf194a641e8509eb6 (diff)
downloadports-6ab9d1ac6f602a1da9103716ab7d03db60711dd2.tar.gz
ports-6ab9d1ac6f602a1da9103716ab7d03db60711dd2.zip
Notes
Diffstat (limited to 'games/xbill/Makefile')
-rw-r--r--games/xbill/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/games/xbill/Makefile b/games/xbill/Makefile
index ce3023c9e5c6..a41528dce365 100644
--- a/games/xbill/Makefile
+++ b/games/xbill/Makefile
@@ -7,24 +7,22 @@
#
PORTNAME= xbill
-PORTVERSION= 2.0
+PORTVERSION= 2.1
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR= games
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.xbill.org/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Save your computers from the evil clutches of Bill
-USE_IMAKE= yes
+SCORES_DIR?= ${DATADIR}/scores
+
+USE_X_PREFIX= yes
+HAS_CONFIGURE= yes
USE_XPM= yes
-MAN1= xbill.1
+USE_GTK= yes
+CONFIGURE_ENV+= PREFIX=${PREFIX}
+CONFIGURE_ARGS+=--localstatedir=${SCORES_DIR}
-post-install:
- ${CP} ${WRKSRC}/README ${PREFIX}/share/xbill
- ${CHOWN} root:games ${PREFIX}/bin/xbill
- ${CHMOD} 2755 ${PREFIX}/bin/xbill
- ${CHOWN} root:games ${PREFIX}/share/xbill/scores
- ${CHMOD} 664 ${PREFIX}/share/xbill/scores
+MAN6= xbill.6
.include <bsd.port.mk>