aboutsummaryrefslogtreecommitdiff
path: root/games/xbl
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-20 23:01:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-20 23:01:05 +0000
commitd763e6001caecbd7884d5acfbd77b4d143b456fe (patch)
tree85f95986a132a17697521cbff73c089fde2b2adc /games/xbl
parentea29ec4b7b1e4a59e457a724ea86dee2259d1b51 (diff)
downloadports-d763e6001caecbd7884d5acfbd77b4d143b456fe.tar.gz
ports-d763e6001caecbd7884d5acfbd77b4d143b456fe.zip
Notes
Diffstat (limited to 'games/xbl')
-rw-r--r--games/xbl/Makefile36
-rw-r--r--games/xbl/distinfo6
-rw-r--r--games/xbl/files/patch-aa76
-rw-r--r--games/xbl/files/patch-bl.c20
-rw-r--r--games/xbl/files/patch-configure13
-rw-r--r--games/xbl/files/patch-initmenu.c47
6 files changed, 80 insertions, 118 deletions
diff --git a/games/xbl/Makefile b/games/xbl/Makefile
index e3ad50e56e2b..7140782ccb9a 100644
--- a/games/xbl/Makefile
+++ b/games/xbl/Makefile
@@ -6,18 +6,42 @@
#
PORTNAME= xbl
-PORTVERSION= 1.1.5
-PORTREVISION= 2
+PORTVERSION= 1.1.6
CATEGORIES= games
-MASTER_SITES= http://www710.univ-lyon1.fr/~exco/XBL/ GENTOO/distfiles
+MASTER_SITES= http://www710.univ-lyon1.fr/~exco/XBL/
MAINTAINER= ports@FreeBSD.org
COMMENT= A 3D block-dropping game
-BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake
-
-USE_XORG= x11 xext
+USE_XORG= x11
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ ac_cv_prog_IMAKE="" ac_cv_prog_XMKMF=""
+MAKE_ARGS= USE_SETGID="" \
+ GROUP_GID="" \
+ RESOURCEDIR="${PREFIX}/lib/X11/app-defaults" \
+ BINDIR="${PREFIX}/bin" \
+ SCOREDIR="${PREFIX}/lib/X11/xbl" \
+ MANPATH="${MANPREFIX}/man" \
+ LIBS="-lm -lX11" \
+ LDOPTIONS="${LDFLAGS}"
+
MAN1= xbl.1
+CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|@CFLA@ -g|@CFLA@|g' ${WRKSRC}/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bl ${PREFIX}/bin/xbl
+ ${INSTALL_MAN} ${WRKSRC}/xbl.man ${MANPREFIX}/man/man1/xbl.1
+ ${INSTALL_DATA} ${WRKSRC}/Xbl.ad ${PREFIX}/lib/X11/app-defaults/Xbl
+ @${MKDIR} ${PREFIX}/lib/X11/xbl
+ ${INSTALL_DATA} ${WRKSRC}/Xbl.ad ${PREFIX}/lib/X11/xbl/Xbl
+ ${INSTALL_DATA} ${WRKSRC}/*.gif ${PREFIX}/lib/X11/xbl
+ ${INSTALL_DATA} ${WRKSRC}/*.html ${PREFIX}/lib/X11/xbl
+
.include <bsd.port.mk>
diff --git a/games/xbl/distinfo b/games/xbl/distinfo
index 0df3fb7829d8..e4834c80fc92 100644
--- a/games/xbl/distinfo
+++ b/games/xbl/distinfo
@@ -1,3 +1,3 @@
-MD5 (xbl-1.1.5.tar.gz) = f618cb6fc20314683c20679d063e1b37
-SHA256 (xbl-1.1.5.tar.gz) = 5628e4a70709e3d996f4adf635a1760d96fad3ded0dd32d32205bdccde1e2cad
-SIZE (xbl-1.1.5.tar.gz) = 136508
+MD5 (xbl-1.1.6.tar.gz) = f2d0d1596a6e5baa36f81f7fbe11346b
+SHA256 (xbl-1.1.6.tar.gz) = 85f456b6aca15f1642bbd233872250918432f0b5252d4b0d681bc2394fda5f84
+SIZE (xbl-1.1.6.tar.gz) = 136504
diff --git a/games/xbl/files/patch-aa b/games/xbl/files/patch-aa
deleted file mode 100644
index 72697f992f35..000000000000
--- a/games/xbl/files/patch-aa
+++ /dev/null
@@ -1,76 +0,0 @@
---- Makefile.in.old Mon Nov 7 19:50:05 2005
-+++ Makefile.in Thu Dec 15 19:25:55 2005
-@@ -83,7 +83,7 @@
-
- # For linking (configure script will modify this line)
- # xmkmf et imake informations are take into account.
--LIBS = @LIBS@ -lm
-+LIBS = @LIBS@ -lm -lX11 -lcompat
-
- all:demo
-
-@@ -124,29 +124,21 @@
- @echo "Executable go in $(BINDIR)"
- @echo "Scores go in $(SCOREDIR)"
- @echo "Defaults go in $(RESOURCEDIR)/Xbl"
-- @echo "Man pages go in $(MANPATH)/mann or man1"
-+ @echo "Man pages go in $(MANPATH)/man1"
- @-if [ "" != "$(USE_SETGID)" ] ; then \
- echo "You use GID=$(GROUP_GID) protection" ; \
- fi
-- @echo "Type <Return> to continue installation"
-- @echo "Type NO to stop installation"
-- @read LINE && test "" = "$$LINE"
- #
- # Remove old score file
- #
- @-if [ -d "$(SCOREDIR)" ] ; \
- then \
-- echo "The scoring method and speeds of Xbl had change" ; \
-- echo "If your version is older than 0.2e, destroy score." ; \
-- echo "Type <Return> to destroy old score files" ; \
-- echo "Type NO to hold old score files" ; \
-- read LINE && test "" = "$$LINE" && rm $(SCOREDIR)/[1-9]* ; \
-- exit 0 ; \
-+ rm $(SCOREDIR)/[1-9]* ; \
- fi
- #
- # Install executable
- #
-- $(CP) bl $(BINDIR)/xbl
-+ $(BSD_INSTALL_PROGRAM) bl $(BINDIR)/xbl
- -if [ "" = "$(USE_SETGID)" ] ; then \
- chmod 755 $(BINDIR)/xbl ;\
- else \
-@@ -160,30 +152,20 @@
- -mkdir $(SCOREDIR) 2>/dev/null
- $(CP) Xbl.ad $(RESOURCEDIR)/Xbl ; chmod 644 $(RESOURCEDIR)/Xbl
- $(CP) Xbl.ad $(SCOREDIR)/Xbl ; chmod 644 $(SCOREDIR)/Xbl
-- $(CP) COPYING $(SCOREDIR) ; chmod 444 $(SCOREDIR)/COPYING
- -if [ "" = "$(USE_SETGID)" ] ; then \
- chmod 777 $(SCOREDIR) ;\
- chmod 666 $(SCOREDIR)/[1-9]* ;\
- else \
- chmod 775 $(SCOREDIR) ;\
-- chmod 664 $(SCOREDIR)/[1-9]* ;\
-- chown root $(SCOREDIR) $(SCOREDIR)/[1-9]* ;\
-- chgrp $(GROUP_GID) $(SCOREDIR) $(SCOREDIR)/[1-9]* ;\
- fi
- #
- # Install manual pages
- #
-- -if [ -d $(MANPATH)/mann ] ; \
-- then \
-- $(CP) xbl.man $(MANPATH)/mann/xbl.n ;\
-- chmod 444 $(MANPATH)/mann/xbl.n ; \
-- else \
- $(CP) xbl.man $(MANPATH)/man1/xbl.1 ;\
- chmod 444 $(MANPATH)/man1/xbl.1 ; \
-- fi
- cp *.gif *.html $(SCOREDIR)
- #
-- -ls -lsa $(SCOREDIR) $(BINDIR)/xbl $(MANPATH)/man[1n]/xbl.[1n]
-+ -ls -lsa $(SCOREDIR) $(BINDIR)/xbl $(MANPATH)/man1/xbl.1
- @echo "Type xbl to play"
-
- bl:$(OBJ)
diff --git a/games/xbl/files/patch-bl.c b/games/xbl/files/patch-bl.c
deleted file mode 100644
index 467ebd2cac42..000000000000
--- a/games/xbl/files/patch-bl.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- bl.c.orig Sat Feb 4 20:13:23 2006
-+++ bl.c Tue Jun 27 02:07:43 2006
-@@ -452,6 +452,8 @@
- int i ;
- XEvent event ;
-
-+ double fps;
-+
- fprintf(stderr,"THIS TEST WILL TAKE SOME TIME\n") ;
-
- blo->opt.wx = blo->opt.wy = blo->opt.wz = 6 ;
-@@ -485,7 +487,7 @@
- }
- gettimeofday(&currenttime, &tz) ;
-
-- double fps = (1000000. * i )
-+ fps = (1000000. * i )
- / ( (currenttime.tv_sec - starttime.tv_sec)*1000000
- + currenttime.tv_usec - starttime.tv_usec ) ;
- printf("%.2f frames/sec buffering=%d %s clearline=%d\n",
diff --git a/games/xbl/files/patch-configure b/games/xbl/files/patch-configure
deleted file mode 100644
index 9b2711510847..000000000000
--- a/games/xbl/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig Thu Jun 19 03:05:17 2003
-+++ configure Thu Jun 19 03:05:31 2003
-@@ -774,7 +774,6 @@
- @echo LN=\"LN=$(LN)\"
- @echo COMPRESS=\"COMPRESS=$(COMPRESS)\"
- @echo MANPATH=\"MANPATH=$(MANPATH)\"
-- @echo CC=\"$(CC)\"
- @echo LDOPTIONS=\"$(LDOPTIONS)\"
- @echo LINT=\"LINT=$(LINT)\"
- @echo LINTFLAGS=\"LINTFLAGS=$(LINTFLAGS)\"
diff --git a/games/xbl/files/patch-initmenu.c b/games/xbl/files/patch-initmenu.c
new file mode 100644
index 000000000000..4a3b08687420
--- /dev/null
+++ b/games/xbl/files/patch-initmenu.c
@@ -0,0 +1,47 @@
+--- initmenu.c.orig 2005-11-08 05:40:38.000000000 +0900
++++ initmenu.c 2009-03-17 00:01:26.000000000 +0900
+@@ -408,37 +408,34 @@
+ XCharStruct overall_return ;
+
+ m->xfont = XLoadQueryFont( x->display , opt->thefont ) ;
+- m->font = XLoadFont( x->display , opt->thefont ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font=%s\n", opt->thefont) ;
+ }
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ if ( m->xfont==0 )
+ {
+ fprintf(stderr,"Some problems when loading a font... trying others\n") ;
+ m->xfont = XLoadQueryFont( x->display ,
+- "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- m->font = XLoadFont( x->display ,
+- "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ "fixed" ) ;
++ if ( m->xfont==0 )
+ {
+- fprintf(stderr,"You haven't -*-*-*-*-*-*-*-*-*-*-*-*-*-*\n");
++ fprintf(stderr,"You haven't \"fixed\"\n");
+ fprintf(stderr,"Have you A font?\n");
+ fprintf(stderr,"Retry with -font option\n");
+ exit(1) ;
+ }
+ }
++ m->font = m->xfont->fid;
+ m->xfont2 = XLoadQueryFont( x->display , opt->thefont2 ) ;
+- m->font2 = XLoadFont( x->display , opt->thefont2 ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font2=%s\n", opt->thefont2) ;
+ }
+- if ( m->font2==BadAlloc || m->font2==BadName || m->xfont2==0 )
++ if ( m->xfont2==0 )
+ {
+- m->font2 = m->font ;
+ m->xfont2 = m->xfont ;
+ }
++ m->font2 = m->xfont2->fid;
+
+ xgc.background = x->back_pixel ;
+ xgc.foreground = opt->backcolor!=7 ? x->white_pixel : x->black_pixel;