aboutsummaryrefslogtreecommitdiff
path: root/games/xboard-devel/files
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-10-28 08:07:24 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-10-28 08:07:24 +0000
commit727d34c18fc68ac759cf2d8096c3b77a0ef38fdf (patch)
tree7b2f308d95d8b931d2c39d2d6d7ba21c74e1b282 /games/xboard-devel/files
parent6a22bfab530fe1e3063dd0f4ad3976d878d69ea9 (diff)
downloadports-727d34c18fc68ac759cf2d8096c3b77a0ef38fdf.tar.gz
ports-727d34c18fc68ac759cf2d8096c3b77a0ef38fdf.zip
Notes
Diffstat (limited to 'games/xboard-devel/files')
-rw-r--r--games/xboard-devel/files/patch-Makefile.am24
-rw-r--r--games/xboard-devel/files/patch-configure.ac17
-rw-r--r--games/xboard-devel/files/patch-xboard.conf (renamed from games/xboard-devel/files/patch-xboard.conf.in)6
3 files changed, 36 insertions, 11 deletions
diff --git a/games/xboard-devel/files/patch-Makefile.am b/games/xboard-devel/files/patch-Makefile.am
index c8c0b6d9d5ed..eef2a0d0fb2a 100644
--- a/games/xboard-devel/files/patch-Makefile.am
+++ b/games/xboard-devel/files/patch-Makefile.am
@@ -1,30 +1,38 @@
---- Makefile.am.orig 2014-07-02 14:34:53.000000000 +0200
-+++ Makefile.am 2014-08-21 22:40:05.000000000 +0200
+--- Makefile.am.orig 2015-08-06 23:49:02.000000000 +0200
++++ Makefile.am 2015-10-11 02:11:07.000000000 +0200
@@ -57,7 +57,7 @@
###
SUBDIRS = po
-xboard_LDADD = -ldl -lm @FRONTEND_LIBS@ @X_LIBS@ @LIBINTL@ @CAIRO_LIBS@
-+xboard_LDADD = -lm @FRONTEND_LIBS@ @X_LIBS@ @LIBINTL@ @CAIRO_LIBS@
++xboard_LDADD = -lm @FRONTEND_LIBS@ @X_LIBS@ @LIBINTL@ @PANGOCAIRO_LIBS@
EXTRA_DIST = pixmaps themes png sounds winboard \
xboard.texi gpl.texinfo texi2man texinfo.tex xboard.man xboard.desktop xboard-config.desktop \
+@@ -68,7 +68,7 @@
+ DISTCLEANFILES = stamp-h
+
+ GITVERSION=$(shell sh -c 'git describe --dirty --always 2>/dev/null')
+-AM_CPPFLAGS=-DINFODIR='"$(infodir)"' @X_CFLAGS@ @CAIRO_CFLAGS@ @FRONTEND_CFLAGS@ -DSYSCONFDIR='"$(sysconfdir)"' \
++AM_CPPFLAGS=-DINFODIR='"$(infodir)"' @X_CFLAGS@ @PANGOCAIRO_CFLAGS@ @FRONTEND_CFLAGS@ -DSYSCONFDIR='"$(sysconfdir)"' \
+ -DLOCALEDIR='"$(localedir)"' -DSVGDIR='"$(svgdir)"' -D__GIT_VERSION='"$(GITVERSION)"' \
+ -DCONFIGURE_OPTIONS='"@CONFIGURE_OPTIONS@"' -DDATADIR='"$(datadir)/games/xboard"' $(headers)
+
@@ -179,7 +179,8 @@
### directory and files for themes (and other) configuration files
themesdir = $(datadir)/games/xboard/themes/conf
--dist_themes_DATA = conf/shogi conf/xq conf/chu conf/ics conf/mini conf/mini.fen conf/sho conf/sho.fen
+-dist_themes_DATA = conf/shogi conf/xq conf/ics conf/mini conf/mini.fen conf/sho conf/sho.fen
+dist_themes_DATA = conf/shogi conf/xq conf/chu conf/ics conf/mini conf/mini.fen conf/sho conf/sho.fen \
-+ conf/judkins conf/judkins.fen conf/xiangqi
++ conf/judkins conf/judkins.fen conf/xiangqi
### directory and files for pixmaps
-@@ -196,8 +197,12 @@
+@@ -196,7 +197,12 @@
soundsdir = $(gamedatadir)/sounds
dist_sounds_DATA = \
sounds/cymbal.wav sounds/pop2.wav sounds/slap.wav sounds/ding1.wav sounds/laser.wav \
- sounds/woodthunk.wav sounds/gong.wav sounds/penalty.wav sounds/honkhonk.wav sounds/phone.wav sounds/roar.wav
--
+ sounds/woodthunk.wav sounds/gong.wav sounds/penalty.wav sounds/honkhonk.wav sounds/phone.wav sounds/roar.wav \
+ sounds/README sounds/alarm.wav sounds/challenge.wav sounds/channel.wav sounds/channel1.wav \
+ sounds/ching.wav sounds/click.wav sounds/draw.wav sounds/drip.wav sounds/kibitz.wav \
@@ -32,5 +40,5 @@
+ sounds/shout.wav sounds/squeak.wav sounds/sshout.wav sounds/swish.wav sounds/tell.wav \
+ sounds/thud.wav sounds/unfinished.wav sounds/whipcrak.wav sounds/win.wav
- ### set correct dir in xboard.conf
+ ### the man page depends on several files, so we add a special rule
diff --git a/games/xboard-devel/files/patch-configure.ac b/games/xboard-devel/files/patch-configure.ac
new file mode 100644
index 000000000000..5112f3106c75
--- /dev/null
+++ b/games/xboard-devel/files/patch-configure.ac
@@ -0,0 +1,17 @@
+--- configure.ac.orig 2015-08-06 23:49:02.000000000 +0200
++++ configure.ac 2015-10-11 02:07:35.000000000 +0200
+@@ -123,10 +123,10 @@
+ AS_IF( [test "x$PKGCONFIG" = xpkgconfig_not_found],
+ AC_MSG_ERROR([cannot find pkg-config! Please install it.]))
+
+-dnl | check for cairo and librsvg
+-PKG_CHECK_MODULES([CAIRO], [ cairo >= 1.2.0 librsvg-2.0 >= 2.14.0 ])
+-AC_SUBST(CAIRO_CFLAGS)
+-AC_SUBST(CAIRO_LIBS)
++dnl | check for pangocairo and librsvg
++PKG_CHECK_MODULES([PANGOCAIRO], [ pangocairo >= 1.0.0 librsvg-2.0 >= 2.14.0 ])
++AC_SUBST(PANGOCAIRO_CFLAGS)
++AC_SUBST(PANGOCAIRO_LIBS)
+
+ dnl | check which front end to use
+ dnl | first check for gtk
diff --git a/games/xboard-devel/files/patch-xboard.conf.in b/games/xboard-devel/files/patch-xboard.conf
index e1fbc0797506..43466d7a9074 100644
--- a/games/xboard-devel/files/patch-xboard.conf.in
+++ b/games/xboard-devel/files/patch-xboard.conf
@@ -1,6 +1,6 @@
---- xboard.conf.in.orig 2014-07-02 14:34:53.000000000 +0200
-+++ xboard.conf.in 2014-08-21 00:56:04.000000000 +0200
-@@ -70,11 +70,7 @@
+--- xboard.conf.orig 2014-11-04 09:45:56.000000000 +0100
++++ xboard.conf 2014-11-04 09:46:05.000000000 +0100
+@@ -74,11 +74,7 @@
; Engines & adjudicatons in engine-engine games
;
-firstChessProgram fairymax