aboutsummaryrefslogtreecommitdiff
path: root/games/xboard-devel
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-10-28 08:07:24 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-10-28 08:07:24 +0000
commit727d34c18fc68ac759cf2d8096c3b77a0ef38fdf (patch)
tree7b2f308d95d8b931d2c39d2d6d7ba21c74e1b282 /games/xboard-devel
parent6a22bfab530fe1e3063dd0f4ad3976d878d69ea9 (diff)
downloadports-727d34c18fc68ac759cf2d8096c3b77a0ef38fdf.tar.gz
ports-727d34c18fc68ac759cf2d8096c3b77a0ef38fdf.zip
Notes
Diffstat (limited to 'games/xboard-devel')
-rw-r--r--games/xboard-devel/Makefile10
-rw-r--r--games/xboard-devel/distinfo4
-rw-r--r--games/xboard-devel/files/patch-Makefile.am24
-rw-r--r--games/xboard-devel/files/patch-configure.ac17
-rw-r--r--games/xboard-devel/files/patch-xboard.conf (renamed from games/xboard-devel/files/patch-xboard.conf.in)6
-rw-r--r--games/xboard-devel/pkg-plist27
6 files changed, 47 insertions, 41 deletions
diff --git a/games/xboard-devel/Makefile b/games/xboard-devel/Makefile
index e90f0542d12d..0afb8ad2c16b 100644
--- a/games/xboard-devel/Makefile
+++ b/games/xboard-devel/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xboard-devel
-PORTVERSION= 4.7.3.20140909.8
+PORTVERSION= 4.8.0.20151020.3
PORTREVISION=
PORTEPOCH=
MASTER_SITES= http://freeheimdall.spdns.org/files/
@@ -14,6 +14,8 @@ MAINTAINER= kalten@gmx.at
LICENSE= GPLv3
+LIB_DEPENDS?= libpangocairo-1.0.so:${PORTSDIR}/x11-toolkits/pango
+
CONFLICTS= xboard-[0-9]*
MASTERDIR= ${.CURDIR}/../xboard
@@ -21,10 +23,10 @@ DISTINFO_FILE= ${.CURDIR}/distinfo
PATCHDIR= ${.CURDIR}/files
PLIST= ${.CURDIR}/pkg-plist
-COMMIT_HASH= e677df0
+COMMIT_HASH= f49e7e1
DATADIR= ${PREFIX}/share/games/xboard
DOCSDIR= ${PREFIX}/share/doc/xboard
-XBOARDCONF= ${WRKSRC}/xboard.conf.in
+XBOARDCONF= ${WRKSRC}/xboard.conf
USES= autoreconf desktop-file-utils gettext-tools gmake shared-mime-info shebangfix
SHEBANG_FILES= texi2man
@@ -34,6 +36,6 @@ INSTALL_TARGET= install-strip
pre-configure:
${RM} ${WRKSRC}/m4/*.m4
${REINPLACE_CMD} -e "s|\(GITVERSION=\).*|\1${COMMIT_HASH}|" ${WRKSRC}/Makefile.am
- ${REINPLACE_CMD} -E "s|(AC_INIT\(\[xboard\],\[master-[^]]+)(\].+\))|\1-git:${COMMIT_HASH}\2|" ${WRKSRC}/configure.ac
+ ${REINPLACE_CMD} -E "s|(AC_INIT\(\[xboard\],\[)[^]]+(\].+\))|\1${PORTVERSION}-git:${COMMIT_HASH}\2|" ${WRKSRC}/configure.ac
.include "${MASTERDIR}/Makefile"
diff --git a/games/xboard-devel/distinfo b/games/xboard-devel/distinfo
index d31c94ea5fce..e215a10cce90 100644
--- a/games/xboard-devel/distinfo
+++ b/games/xboard-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xboard-e677df0.tar.gz) = 54432a3a53076b0ac6ba6689f8e90e440108ae479846ae46d60e5b857afe59be
-SIZE (xboard-e677df0.tar.gz) = 3039491
+SHA256 (xboard-f49e7e1.tar.gz) = d24008d138f69407eb2ddd2b32059fda0e9c997b14e77f6c9f280d3c2d7a7d1a
+SIZE (xboard-f49e7e1.tar.gz) = 3705264
diff --git a/games/xboard-devel/files/patch-Makefile.am b/games/xboard-devel/files/patch-Makefile.am
index c8c0b6d9d5ed..eef2a0d0fb2a 100644
--- a/games/xboard-devel/files/patch-Makefile.am
+++ b/games/xboard-devel/files/patch-Makefile.am
@@ -1,30 +1,38 @@
---- Makefile.am.orig 2014-07-02 14:34:53.000000000 +0200
-+++ Makefile.am 2014-08-21 22:40:05.000000000 +0200
+--- Makefile.am.orig 2015-08-06 23:49:02.000000000 +0200
++++ Makefile.am 2015-10-11 02:11:07.000000000 +0200
@@ -57,7 +57,7 @@
###
SUBDIRS = po
-xboard_LDADD = -ldl -lm @FRONTEND_LIBS@ @X_LIBS@ @LIBINTL@ @CAIRO_LIBS@
-+xboard_LDADD = -lm @FRONTEND_LIBS@ @X_LIBS@ @LIBINTL@ @CAIRO_LIBS@
++xboard_LDADD = -lm @FRONTEND_LIBS@ @X_LIBS@ @LIBINTL@ @PANGOCAIRO_LIBS@
EXTRA_DIST = pixmaps themes png sounds winboard \
xboard.texi gpl.texinfo texi2man texinfo.tex xboard.man xboard.desktop xboard-config.desktop \
+@@ -68,7 +68,7 @@
+ DISTCLEANFILES = stamp-h
+
+ GITVERSION=$(shell sh -c 'git describe --dirty --always 2>/dev/null')
+-AM_CPPFLAGS=-DINFODIR='"$(infodir)"' @X_CFLAGS@ @CAIRO_CFLAGS@ @FRONTEND_CFLAGS@ -DSYSCONFDIR='"$(sysconfdir)"' \
++AM_CPPFLAGS=-DINFODIR='"$(infodir)"' @X_CFLAGS@ @PANGOCAIRO_CFLAGS@ @FRONTEND_CFLAGS@ -DSYSCONFDIR='"$(sysconfdir)"' \
+ -DLOCALEDIR='"$(localedir)"' -DSVGDIR='"$(svgdir)"' -D__GIT_VERSION='"$(GITVERSION)"' \
+ -DCONFIGURE_OPTIONS='"@CONFIGURE_OPTIONS@"' -DDATADIR='"$(datadir)/games/xboard"' $(headers)
+
@@ -179,7 +179,8 @@
### directory and files for themes (and other) configuration files
themesdir = $(datadir)/games/xboard/themes/conf
--dist_themes_DATA = conf/shogi conf/xq conf/chu conf/ics conf/mini conf/mini.fen conf/sho conf/sho.fen
+-dist_themes_DATA = conf/shogi conf/xq conf/ics conf/mini conf/mini.fen conf/sho conf/sho.fen
+dist_themes_DATA = conf/shogi conf/xq conf/chu conf/ics conf/mini conf/mini.fen conf/sho conf/sho.fen \
-+ conf/judkins conf/judkins.fen conf/xiangqi
++ conf/judkins conf/judkins.fen conf/xiangqi
### directory and files for pixmaps
-@@ -196,8 +197,12 @@
+@@ -196,7 +197,12 @@
soundsdir = $(gamedatadir)/sounds
dist_sounds_DATA = \
sounds/cymbal.wav sounds/pop2.wav sounds/slap.wav sounds/ding1.wav sounds/laser.wav \
- sounds/woodthunk.wav sounds/gong.wav sounds/penalty.wav sounds/honkhonk.wav sounds/phone.wav sounds/roar.wav
--
+ sounds/woodthunk.wav sounds/gong.wav sounds/penalty.wav sounds/honkhonk.wav sounds/phone.wav sounds/roar.wav \
+ sounds/README sounds/alarm.wav sounds/challenge.wav sounds/channel.wav sounds/channel1.wav \
+ sounds/ching.wav sounds/click.wav sounds/draw.wav sounds/drip.wav sounds/kibitz.wav \
@@ -32,5 +40,5 @@
+ sounds/shout.wav sounds/squeak.wav sounds/sshout.wav sounds/swish.wav sounds/tell.wav \
+ sounds/thud.wav sounds/unfinished.wav sounds/whipcrak.wav sounds/win.wav
- ### set correct dir in xboard.conf
+ ### the man page depends on several files, so we add a special rule
diff --git a/games/xboard-devel/files/patch-configure.ac b/games/xboard-devel/files/patch-configure.ac
new file mode 100644
index 000000000000..5112f3106c75
--- /dev/null
+++ b/games/xboard-devel/files/patch-configure.ac
@@ -0,0 +1,17 @@
+--- configure.ac.orig 2015-08-06 23:49:02.000000000 +0200
++++ configure.ac 2015-10-11 02:07:35.000000000 +0200
+@@ -123,10 +123,10 @@
+ AS_IF( [test "x$PKGCONFIG" = xpkgconfig_not_found],
+ AC_MSG_ERROR([cannot find pkg-config! Please install it.]))
+
+-dnl | check for cairo and librsvg
+-PKG_CHECK_MODULES([CAIRO], [ cairo >= 1.2.0 librsvg-2.0 >= 2.14.0 ])
+-AC_SUBST(CAIRO_CFLAGS)
+-AC_SUBST(CAIRO_LIBS)
++dnl | check for pangocairo and librsvg
++PKG_CHECK_MODULES([PANGOCAIRO], [ pangocairo >= 1.0.0 librsvg-2.0 >= 2.14.0 ])
++AC_SUBST(PANGOCAIRO_CFLAGS)
++AC_SUBST(PANGOCAIRO_LIBS)
+
+ dnl | check which front end to use
+ dnl | first check for gtk
diff --git a/games/xboard-devel/files/patch-xboard.conf.in b/games/xboard-devel/files/patch-xboard.conf
index e1fbc0797506..43466d7a9074 100644
--- a/games/xboard-devel/files/patch-xboard.conf.in
+++ b/games/xboard-devel/files/patch-xboard.conf
@@ -1,6 +1,6 @@
---- xboard.conf.in.orig 2014-07-02 14:34:53.000000000 +0200
-+++ xboard.conf.in 2014-08-21 00:56:04.000000000 +0200
-@@ -70,11 +70,7 @@
+--- xboard.conf.orig 2014-11-04 09:45:56.000000000 +0100
++++ xboard.conf 2014-11-04 09:46:05.000000000 +0100
+@@ -74,11 +74,7 @@
; Engines & adjudicatons in engine-engine games
;
-firstChessProgram fairymax
diff --git a/games/xboard-devel/pkg-plist b/games/xboard-devel/pkg-plist
index 99923c0e7d43..5123881261fb 100644
--- a/games/xboard-devel/pkg-plist
+++ b/games/xboard-devel/pkg-plist
@@ -1,4 +1,3 @@
-@postunexec /bin/rm %D/share/icons/hicolor/icon-theme.cache 2>/dev/null || /usr/bin/true
@owner root
@group wheel
bin/xboard
@@ -200,36 +199,16 @@ share/mime/packages/xboard.xml
%%NLS%%share/locale/da/LC_MESSAGES/xboard.mo
%%NLS%%share/locale/de/LC_MESSAGES/xboard.mo
%%NLS%%share/locale/es/LC_MESSAGES/xboard.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xboard.mo
%%NLS%%share/locale/it/LC_MESSAGES/xboard.mo
%%NLS%%share/locale/nl/LC_MESSAGES/xboard.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xboard.mo
%%NLS%%share/locale/ru/LC_MESSAGES/xboard.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/xboard.mo
%%NLS%%share/locale/tr/LC_MESSAGES/xboard.mo
%%NLS%%share/locale/uk/LC_MESSAGES/xboard.mo
%%NLS%%share/locale/vi/LC_MESSAGES/xboard.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/xboard.mo
%%NLS%%share/locale/zh_HK/LC_MESSAGES/xboard.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/xboard.mo
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry %%DATADIR%%/pixmaps/textures
-@dirrmtry %%DATADIR%%/pixmaps
-@dirrmtry %%DATADIR%%/sounds
-@dirrmtry %%DATADIR%%/themes/conf
-@dirrmtry %%DATADIR%%/themes/default
-@dirrmtry %%DATADIR%%/themes/shogi
-@dirrmtry %%DATADIR%%/themes/textures
-@dirrmtry %%DATADIR%%/themes/xiangqi
-@dirrmtry %%DATADIR%%/themes
-@dirrmtry %%DATADIR%%
-@dirrmtry share/games
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/scalable/apps
-@dirrmtry share/icons/hicolor/scalable
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
-@dirrmtry share/mime/packages
-@dirrmtry share/mime
@sample etc/xboard.conf.sample
-@postexec /usr/local/bin/gtk-update-icon-cache -q -f %D/share/icons/hicolor 2>/dev/null || /usr/bin/true
-@postunexec /usr/local/bin/gtk-update-icon-cache -q -f %D/share/icons/hicolor 2>/dev/null || /usr/bin/true