aboutsummaryrefslogtreecommitdiff
path: root/games/xboard/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-01-10 17:24:44 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-01-10 17:24:44 +0000
commit51fc3e34ded8b8fbd3d50e7366cf927d48c990f4 (patch)
tree356248db2b62954f5aaefc15d6f4d822ea1c10ad /games/xboard/Makefile
parent71630808aa1da2626d0a12b3557eb2e8825da3e6 (diff)
downloadports-51fc3e34ded8b8fbd3d50e7366cf927d48c990f4.tar.gz
ports-51fc3e34ded8b8fbd3d50e7366cf927d48c990f4.zip
Notes
Diffstat (limited to 'games/xboard/Makefile')
-rw-r--r--games/xboard/Makefile42
1 files changed, 10 insertions, 32 deletions
diff --git a/games/xboard/Makefile b/games/xboard/Makefile
index c32daca38f98..de345090b251 100644
--- a/games/xboard/Makefile
+++ b/games/xboard/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xboard
-PORTVERSION= 4.7.2
+PORTVERSION= 4.7.3
CATEGORIES= games
MASTER_SITES= GNU
@@ -13,17 +13,25 @@ LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo
OPTIONS_DEFINE= NLS CRAFTY FAIRYMAX GNUCHESS KNIGHTCAP PHALANX
OPTIONS_DEFAULT=
+OPTIONS_SUB= yes
CRAFTY_DESC= Install crafty engine
FAIRYMAX_DESC= Install fairymax engine
GNUCHESS_DESC= Install GnuChess engine
KNIGHTCAP_DESC= Install KnightCap engine
PHALANX_DESC= Install phalanx engine
+CRAFTY_RUN_DEPENDS+= crafty:${PORTSDIR}/games/crafty
+FAIRYMAX_RUN_DEPENDS+= fairymax:${PORTSDIR}/games/fairymax
+GNUCHESS_RUN_DEPENDS+= gnuchess:${PORTSDIR}/games/gnuchess
+KNIGHTCAP_RUN_DEPENDS+= KnightCap:${PORTSDIR}/games/KnightCap
+PHALANX_RUN_DEPENDS+= phalanx:${PORTSDIR}/games/phalanx
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
USES= desktop-file-utils perl5 pkgconfig shared-mime-info
USE_XORG= xt xpm xaw
USE_GNOME= librsvg2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=MKDIR_P="${MKDIR}"
+CONFIGURE_ARGS+=MKDIR_P="${MKDIR}" PERLPATH=${LOCALBASE}/bin
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INFO= xboard
@@ -33,36 +41,6 @@ DATADIR= ${PREFIX}/share/games/${PORTNAME}
PORTDOCS= AUTHORS ChangeLog NEWS README SHORTLOG TODO
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCRAFTY}
-RUN_DEPENDS+= crafty:${PORTSDIR}/games/crafty
-.endif
-
-.if ${PORT_OPTIONS:MFAIRYMAX}
-RUN_DEPENDS+= fairymax:${PORTSDIR}/games/fairymax
-.endif
-
-.if ${PORT_OPTIONS:MGNUCHESS}
-RUN_DEPENDS+= gnuchess:${PORTSDIR}/games/gnuchess
-.endif
-
-.if ${PORT_OPTIONS:MKNIGHTCAP}
-RUN_DEPENDS+= KnightCap:${PORTSDIR}/games/KnightCap
-.endif
-
-.if ${PORT_OPTIONS:MPHALANX}
-RUN_DEPENDS+= phalanx:${PORTSDIR}/games/phalanx
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"