aboutsummaryrefslogtreecommitdiff
path: root/games/xbubble
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/xbubble
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'games/xbubble')
-rw-r--r--games/xbubble/Makefile6
-rw-r--r--games/xbubble/files/patch-src-loadpng.c21
2 files changed, 22 insertions, 5 deletions
diff --git a/games/xbubble/Makefile b/games/xbubble/Makefile
index f1d384c19261..32942ddc4cb2 100644
--- a/games/xbubble/Makefile
+++ b/games/xbubble/Makefile
@@ -6,7 +6,7 @@
PORTNAME= xbubble
PORTVERSION= 0.5.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GENTOO}
MASTER_SITE_SUBDIR= distfiles
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= ports@FreeBSD.org
COMMENT= Puzzle Bobble clone for Unix/X11 platforms
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
MAN6= xbubble.6
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-CPPFLAGS+= -I${LOCALBASE}/include/libpng
+CPPFLAGS+= -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib -lintl
.include <bsd.port.mk>
diff --git a/games/xbubble/files/patch-src-loadpng.c b/games/xbubble/files/patch-src-loadpng.c
index d7bf605ecb2a..3a0c67cf9712 100644
--- a/games/xbubble/files/patch-src-loadpng.c
+++ b/games/xbubble/files/patch-src-loadpng.c
@@ -1,6 +1,14 @@
--- src/loadpng.c.orig 2003-09-30 14:55:20.000000000 +0200
-+++ src/loadpng.c 2010-03-30 12:09:13.000000000 +0200
-@@ -55,7 +55,7 @@
++++ src/loadpng.c 2012-04-29 13:39:04.000000000 +0200
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <png.h>
++#include <pngpriv.h>
+
+ #include "gettext.h"
+
+@@ -55,7 +56,7 @@
}
/* ensure that we opened a PNG file */
fread( header, 1, 8, fd );
@@ -9,3 +17,12 @@
fclose(fd);
fprintf(stderr,_("File %s does not have a valid PNG signature.\n"), file);
return NULL;
+@@ -73,7 +74,7 @@
+ return NULL;
+ }
+ /* libpng does a longjmp here when it encounters an error */
+- if ( setjmp( png_ptr->jmpbuf ) ) {
++ if ( setjmp( png_jmpbuf(png_ptr) ) ) {
+ png_destroy_read_struct( &png_ptr, &info_ptr, NULL);
+ fclose(fd);
+ return NULL;