aboutsummaryrefslogtreecommitdiff
path: root/games/xevil/Makefile
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2000-12-21 19:00:48 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2000-12-21 19:00:48 +0000
commit7a9b9cd9b928b10528d61b82643527cedc403f34 (patch)
treee432203dc25217f851f169b302edea5fc3b9c03d /games/xevil/Makefile
parentebe1b1170cc08cb7d1dab50e8ec7b393d55cb419 (diff)
Notes
Diffstat (limited to 'games/xevil/Makefile')
-rw-r--r--games/xevil/Makefile46
1 files changed, 34 insertions, 12 deletions
diff --git a/games/xevil/Makefile b/games/xevil/Makefile
index b801f19c1d0e..4b92791f6274 100644
--- a/games/xevil/Makefile
+++ b/games/xevil/Makefile
@@ -1,22 +1,44 @@
-# New ports collection makefile for: xevil
-# Date created: 6 May 1995
-# Whom: jmz
+# New ports collection makefile for: xevil
+# Date created: 7 November 2000
+# Whom: Göran Runfeldt <goranrunfeldt@home.se>
#
# $FreeBSD$
#
PORTNAME= xevil
-PORTVERSION= 1.5
+PORTVERSION= 2.02
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR= games/${PORTNAME}${PORTVERSION}
-DISTFILES= ${PORTNAME}${PORTVERSION}.tar.Z
+MASTER_SITES= ftp://ftp.xevil.com/stable/
+DISTNAME= xevilsrc${PORTVERSION}
-MAINTAINER= jmz@FreeBSD.org
+MAINTAINER= goranrunfeldt@home.se
-USE_XLIB= yes
-MAN6= xevil.6
-MANCOMPRESSED= yes
-NO_WRKSUBDIR= yes
+USE_X_PREFIX= yes
+USE_ZIP= yes
+USE_XPM= yes
+ALL_TARGET= freebsd
+
+# I'm not sure if this should be here
+.if (${MACHINE} == "alpha")
+CFLAGS+="-DXEVIL_KEYSET=UIalpha"
+.endif
+
+pre-extract:
+ @${MKDIR} ${WRKDIR}/${DISTNAME}
+
+do-extract:
+ @unzip -aqo ${DISTDIR}/${DISTFILES} -d ${WRKSRC}
+
+post-extract:
+ @${MV} -f ${WRKDIR}/${DISTNAME}/makefile ${WRKDIR}/${DISTNAME}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/x11/FREEBSD/xevil ${PREFIX}/bin/xevil
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/xevil/instructions
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/xevil
+ ${INSTALL_DATA} ${WRKSRC}/instructions/* \
+ ${PREFIX}/share/doc/xevil/instructions
+.endif
.include <bsd.port.mk>