aboutsummaryrefslogtreecommitdiff
path: root/games/xgalaga
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-31 05:36:33 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-31 05:36:33 +0000
commit6d613e28796be2165fc7e00df699f49b8e2e0df0 (patch)
tree92ab7f6d64b59861dab2d2f7237d5d200f2690ae /games/xgalaga
parente0822b98f2cbc9d0ef38a72ba0e706c7234ae93b (diff)
downloadports-6d613e28796be2165fc7e00df699f49b8e2e0df0.tar.gz
ports-6d613e28796be2165fc7e00df699f49b8e2e0df0.zip
Notes
Diffstat (limited to 'games/xgalaga')
-rw-r--r--games/xgalaga/Makefile25
-rw-r--r--games/xgalaga/files/patch-aa41
-rw-r--r--games/xgalaga/pkg-descr7
3 files changed, 55 insertions, 18 deletions
diff --git a/games/xgalaga/Makefile b/games/xgalaga/Makefile
index 87988a5b07de..3b3de7fdbfb8 100644
--- a/games/xgalaga/Makefile
+++ b/games/xgalaga/Makefile
@@ -1,36 +1,33 @@
-# Created by: asami
+# Created by: Satoshi Asami <asami@FreeBSD.org>
# $FreeBSD$
PORTNAME= xgalaga
PORTVERSION= 2.1.1.0
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
+MASTER_SITES= SF/${PORTNAME}
MAINTAINER= turutani@scphys.kyoto-u.ac.jp
-COMMENT= Galaga resurrected on X
+COMMENT= Clone of the classic game Galaga for X11
+
+LICENSE= GPLv2
USES= gmake
-MAKE_JOBS_UNSAFE= yes
USE_XORG= xpm xmu
HAS_CONFIGURE= yes
-MAN6= xgalaga.6x
-MANCOMPRESSED= yes
+
# xgalaga has a very strange usage of these variables...
CONFIGURE_ARGS= --prefix=${LOCALBASE}/lib/X11/xgalaga \
--mandir=${LOCALBASE}/man \
--exec_prefix=${LOCALBASE}/bin
+MAN6= xgalaga.6x
+MANCOMPRESSED= yes
+
OPTIONS_DEFINE= SOUND
OPTIONS_DEFAULT= SOUND
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MSOUND)
-CONFIGURE_ARGS+= --without-sound
-PLIST_SUB= SOUND="@comment "
-.else
-PLIST_SUB= SOUND=""
-.endif
+SOUND_CONFIGURE_OFF= --without-sound
post-install:
@${STRIP_CMD} ${PREFIX}/bin/xgalaga
diff --git a/games/xgalaga/files/patch-aa b/games/xgalaga/files/patch-aa
index 2cad8492ec29..a66e9ae2487b 100644
--- a/games/xgalaga/files/patch-aa
+++ b/games/xgalaga/files/patch-aa
@@ -13,3 +13,44 @@
distversion = 2.1.1.0
@SET_MAKE@
+@@ -74,14 +74,14 @@
+ # chmod ${GAMEMODE} $(bindir)/$(TARGET)
+ # chmod ${GAMEDATAMODE} $(prefix)/scores
+
+-subdirs:
+- for i in $(SUBDIRS); do cd $$i ; make ; done
++$(SUBDIRS)::
++ $(MAKE) -C $@
+
+-$(TARGET): subdirs $(OBJS)
++$(TARGET): $(SUBDIRS) $(OBJS)
+ $(RM) $(TARGET)
+ $(CC) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+
+-$(TARGET2): subdirs $(OBJS_HYPER)
++$(TARGET2): $(SUBDIRS) $(OBJS_HYPER)
+ $(RM) $(TARGET2)
+ $(CC) $(LDFLAGS) -o $(TARGET2) $(OBJS_HYPER) $(LIBS)
+
+@@ -98,17 +98,17 @@
+ $(RM) core *.o $(OBJS) $(OBJS_HYPER) $(TARGET) $(TARGET2) $(MANPAGE)
+
+ dist: clean
+- cd libsprite;make clean
++ $(MAKE) -C libsprite clean
+ if test -d xgalaga-$(distverson) ; then echo -n; else mkdir xgalaga-$(distversion); fi
+ cp -rf $(SRCS) configure *.in *.sub *.guess images sounds xgal.sndsrv.*.c libsprite README* INSTALL CHANGES CREDITS xgalaga.6x *.h install-sh levels mkimgsrc* mkinstalldirs xgalaga-$(distversion)
+- cd xgalaga-$(distversion); rm -f config.h
+- cd xgalaga-$(distversion)/libsprite; make distclean ; rm -rf CVS
++ rm -f xgalaga-$(distversion)/config.h
++ $(MAKE) -C xgalaga-$(distversion)/libsprite distclean
+ find xgalaga-$(distversion) -name "CVS" -exec rm -rf {} \; -prune
+ tar czvf xgalaga-$(distversion).tar.gz xgalaga-$(distversion)
+
+ distclean: clean
+ $(RM) Makefile config.h config.status config.cache config.log
+- cd libsprite;$(MAKE) distclean
++ $(MAKE) -C libsprite distclean
+
+ depend:
+ makedepend $(CFLAGS) $(SRCS)
diff --git a/games/xgalaga/pkg-descr b/games/xgalaga/pkg-descr
index 5536267209f2..ea6a6a7fc6e0 100644
--- a/games/xgalaga/pkg-descr
+++ b/games/xgalaga/pkg-descr
@@ -1,5 +1,4 @@
-xgalaga is a rework of the Galaga shooting game.
+XGalaga is a clone of the classic game Galaga for X11, a space-invader like
+game with additional features to produce a more interesting game.
-The package is built to use the sound device in /dev/dsp. If you don't
-have a sound card and are getting core dumps, try recompiling it with
-"make -DNOSOUND".
+WWW: http://rumsey.org/xgal.html