aboutsummaryrefslogtreecommitdiff
path: root/games/xgammon/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2001-09-13 12:07:09 +0000
committerThomas Gellekum <tg@FreeBSD.org>2001-09-13 12:07:09 +0000
commitb1bd5552145b6554ba3b4ba95c24b7334ae99980 (patch)
tree51a8fb605fbaac4769c6ff27813beca34ee0f58a /games/xgammon/Makefile
parent94b469cd52162732510ecd94fde4f2f4911959ac (diff)
downloadports-b1bd5552145b6554ba3b4ba95c24b7334ae99980.tar.gz
ports-b1bd5552145b6554ba3b4ba95c24b7334ae99980.zip
Notes
Diffstat (limited to 'games/xgammon/Makefile')
-rw-r--r--games/xgammon/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/games/xgammon/Makefile b/games/xgammon/Makefile
index 0440bdae104e..cb1782c1a828 100644
--- a/games/xgammon/Makefile
+++ b/games/xgammon/Makefile
@@ -8,9 +8,8 @@
PORTNAME= xgammon
PORTVERSION= 0.98
CATEGORIES= games
-MASTER_SITES= ftp://ftp.redhat.com/pub/redhat/current/SRPMS/SRPMS/ \
- ftp://ftp.mpi-sb.mpg.de/pub/linux/mirror/ftp.redhat.com/redhat/current/SRPMS/SRPMS/ \
- ftp://sunsite.Informatik.RWTH-Aachen.DE/pub/comp/Linux/redhat/current/SRPMS/SRPMS/
+MASTER_SITES= ${MASTER_SITE_REDHAT}
+MASTER_SITE_SUBDIR= linux/6.2/en/os/${MACHINE_ARCH}/SRPMS
EXTRACT_SUFX= -15.src.rpm
PATCH_DIST_STRIP= -p1
@@ -23,7 +22,7 @@ NO_WRKSUBDIR= yes
USE_IMAKE= yes
MAN6= xgammon.6
-PATCH_FILES= ${DISTNAME}-dirent.patch
+PATCH_FILES= ${PORTNAME}-${PORTVERSION}-dirent.patch
do-extract:
@${RM} -rf ${WRKDIR}
@@ -33,8 +32,8 @@ do-extract:
pre-patch:
@${ECHO_MSG} "===> Applying distribution patches for ${PKGNAME}"
- @for file in ${PATCH_FILES}; do \
- ${PATCH} ${PATCH_DIST_ARGS} < ${WRKDIR}/$$file; \
- done
+.for file in ${PATCH_FILES}
+ @${PATCH} ${PATCH_DIST_ARGS} < ${WRKDIR}/${file}
+.endfor
.include <bsd.port.mk>