aboutsummaryrefslogtreecommitdiff
path: root/games/xglk/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-02-06 19:45:58 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-02-06 19:45:58 +0000
commit2b65b90e340df002d3a3806ee8fe9d6692f58c53 (patch)
treece010f230b7fcf1cbf6f65a512c168906c779071 /games/xglk/Makefile
parent0d9d3794e70e986deebb6b5aae76c1680c2a1806 (diff)
downloadports-2b65b90e340df002d3a3806ee8fe9d6692f58c53.tar.gz
ports-2b65b90e340df002d3a3806ee8fe9d6692f58c53.zip
Notes
Diffstat (limited to 'games/xglk/Makefile')
-rw-r--r--games/xglk/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/games/xglk/Makefile b/games/xglk/Makefile
new file mode 100644
index 000000000000..24e5895b7945
--- /dev/null
+++ b/games/xglk/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xglk
+# Date created: 4 February 2005
+# Whom: Peter Pentchev <roam@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xglk
+PORTVERSION= 411
+CATEGORIES= games
+MASTER_SITES= http://www.ifarchive.org/if-archive/programming/glk/implementations/
+DISTNAME= ${PORTNAME}-0${PORTVERSION}
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= roam@FreeBSD.org
+COMMENT= X Windows Implementation of the Glk API
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg png.5:${PORTSDIR}/graphics/png
+
+USE_XLIB= yes
+USE_X_PREFIX= yes
+
+MAKE_ENV+= AR=${AR} RANLIB=${RANLIB} ECHO=${ECHO} RM=${RM}
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/xglk
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/xglk/
+ ${INSTALL_DATA} ${WRKSRC}/libxglk.a ${PREFIX}/lib/
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Make.xglk ${DATADIR}
+
+.include <bsd.port.mk>