aboutsummaryrefslogtreecommitdiff
path: root/games/xgospel/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-08-21 15:58:14 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-08-21 15:58:14 +0000
commit60886ad035e562a53961485ea3235a85c27289d2 (patch)
tree0162a6c099a7d0a75d87803544d98379e7a977e1 /games/xgospel/Makefile
parent57f084cd833162a3d6d36131d61843f58db17581 (diff)
downloadports-60886ad035e562a53961485ea3235a85c27289d2.tar.gz
ports-60886ad035e562a53961485ea3235a85c27289d2.zip
Notes
Diffstat (limited to 'games/xgospel/Makefile')
-rw-r--r--games/xgospel/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/games/xgospel/Makefile b/games/xgospel/Makefile
index aa4b6659c924..2539bbd6bef6 100644
--- a/games/xgospel/Makefile
+++ b/games/xgospel/Makefile
@@ -17,14 +17,16 @@ LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
USE_XLIB= yes
USE_XPM= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS= --with-x --with-xpm --with-xaw3d
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s,#ifndef _POSIX_SOURCE,#if 0," \
+ ${WRKSRC}/connect.c ${WRKSRC}/relay.c ${WRKSRC}/relog.c \
+ ${WRKSRC}/rport.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/relay ${PREFIX}/bin