aboutsummaryrefslogtreecommitdiff
path: root/games/xhime
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>2004-02-05 19:35:49 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>2004-02-05 19:35:49 +0000
commitd1e4a35abe75fef6a88c4a118035344f3506f28c (patch)
treebaf25ddd480f32fdbbbcdf41c2e2629c691c8dfc /games/xhime
parentb89408e5c9805ad895273a2aba3714ff6002f1c6 (diff)
downloadports-d1e4a35abe75fef6a88c4a118035344f3506f28c.tar.gz
ports-d1e4a35abe75fef6a88c4a118035344f3506f28c.zip
Notes
Diffstat (limited to 'games/xhime')
-rw-r--r--games/xhime/Makefile4
-rw-r--r--games/xhime/files/patch-ab111
2 files changed, 111 insertions, 4 deletions
diff --git a/games/xhime/Makefile b/games/xhime/Makefile
index dc928b4ecc5c..026aee22742c 100644
--- a/games/xhime/Makefile
+++ b/games/xhime/Makefile
@@ -24,10 +24,6 @@ NO_CDROM= 'contains commercial character data'
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
post-install:
${STRIP_CMD} ${PREFIX}/bin/xhime
${INSTALL_MAN} ${WRKSRC}/xhime-man.euc \
diff --git a/games/xhime/files/patch-ab b/games/xhime/files/patch-ab
new file mode 100644
index 000000000000..19a66b37a11d
--- /dev/null
+++ b/games/xhime/files/patch-ab
@@ -0,0 +1,111 @@
+*** xhime.c.orig Sun Nov 9 05:45:35 2003
+--- xhime.c Tue Feb 3 22:22:23 2004
+***************
+*** 24,32 ****
+ #include <signal.h>
+ #include <ctype.h> /* defined in X11/Xos.h ? */
+ #include <string.h>/* defined in X11/Xos.h ? */
+ #include <limits.h>
+! #include <varargs.h>
+ #include <sys/time.h>/* defined in X11/Xos.h */
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #ifndef O_RDONLY
+--- 24,32 ----
+ #include <signal.h>
+ #include <ctype.h> /* defined in X11/Xos.h ? */
+ #include <string.h>/* defined in X11/Xos.h ? */
+ #include <limits.h>
+! #include <stdarg.h>
+ #include <sys/time.h>/* defined in X11/Xos.h */
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #ifndef O_RDONLY
+***************
+*** 115,148 ****
+ int ActionFlag = ACT_NONE;
+
+ /* -- */
+ void
+! Error(va_alist)
+! va_dcl
+ {
+ va_list args;
+- char *fmt;
+
+ fprintf(stderr, "%s: ", ProgramName);
+
+! va_start(args);
+ fmt = (char *)va_arg(args, char *);
+ vfprintf(stderr, fmt, args);
+ va_end(args);
+
+ fprintf(stderr, "\n");
+ }
+
+ void
+! ErrorExit(va_alist)
+! va_dcl
+ {
+ va_list args;
+- char *fmt;
+
+ fprintf(stderr, "%s: ", ProgramName);
+
+! va_start(args);
+ fmt = (char *)va_arg(args, char *);
+ vfprintf(stderr, fmt, args);
+ va_end(args);
+
+--- 115,144 ----
+ int ActionFlag = ACT_NONE;
+
+ /* -- */
+ void
+! Error(char *fmt, ...)
+ {
+ va_list args;
+
+ fprintf(stderr, "%s: ", ProgramName);
+
+! va_start(args, fmt);
+ fmt = (char *)va_arg(args, char *);
+ vfprintf(stderr, fmt, args);
+ va_end(args);
+
+ fprintf(stderr, "\n");
+ }
+
+ void
+! ErrorExit(char *fmt, ...)
+ {
+ va_list args;
+
+ fprintf(stderr, "%s: ", ProgramName);
+
+! va_start(args, fmt);
+ fmt = (char *)va_arg(args, char *);
+ vfprintf(stderr, fmt, args);
+ va_end(args);
+
+***************
+*** 1363,1371 ****
+ }
+ exit(0);
+ }
+
+! void
+ main(argc, argv)
+ int argc;
+ char *argv[];
+ {
+--- 1359,1367 ----
+ }
+ exit(0);
+ }
+
+! int
+ main(argc, argv)
+ int argc;
+ char *argv[];
+ {