aboutsummaryrefslogtreecommitdiff
path: root/games/xkobo
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2007-03-20 20:11:49 +0000
committerWill Andrews <will@FreeBSD.org>2007-03-20 20:11:49 +0000
commita2ae5368c1293cd56ce3c32056f36c603a068a5e (patch)
tree5c9e33ee6dbbc8487a85c88876ee181a4a211cdf /games/xkobo
parentd42b57098b7011065fd7a0e59c19660d3d3e1670 (diff)
downloadports-a2ae5368c1293cd56ce3c32056f36c603a068a5e.tar.gz
ports-a2ae5368c1293cd56ce3c32056f36c603a068a5e.zip
Notes
Diffstat (limited to 'games/xkobo')
-rw-r--r--games/xkobo/Makefile4
-rw-r--r--games/xkobo/files/patch-af4
2 files changed, 6 insertions, 2 deletions
diff --git a/games/xkobo/Makefile b/games/xkobo/Makefile
index 6eae33de7b49..44018bd64d0e 100644
--- a/games/xkobo/Makefile
+++ b/games/xkobo/Makefile
@@ -19,6 +19,10 @@ USE_IMAKE= yes
ALL_TARGET= xkobo
MAN1= xkobo.1
+post-configure:
+ ${REINPLACE_CMD} -E -e 's,^.* CC = .*$$, CC=${CC},' \
+ -e 's,^.* CXX = .*$$, CXX=${CXX},' ${WRKSRC}/Makefile
+
post-install:
${CHMOD} u-s,g+s ${PREFIX}/bin/xkobo
${CHOWN} root:games ${PREFIX}/bin/xkobo ${PREFIX}/lib/X11/xkobo-scores
diff --git a/games/xkobo/files/patch-af b/games/xkobo/files/patch-af
index 1db897a8ebf4..2bd42624e7b3 100644
--- a/games/xkobo/files/patch-af
+++ b/games/xkobo/files/patch-af
@@ -5,7 +5,7 @@
break;
}
- t += i;
-+ t = (void *) ((int) t + i);
++ t = (void *) ((long) t + i);
len -= i;
} while (len > 0);
for (;;){
@@ -14,7 +14,7 @@
break;
}
- t += i;
-+ t = (void *) ((int) t + i);
++ t = (void *) ((long) t + i);
len -= i;
} while (len > 0);
for (;;){