aboutsummaryrefslogtreecommitdiff
path: root/games/xlines/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-02-13 18:08:30 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-02-13 18:08:30 +0000
commit378aad359f5a02ec06219b27c2915072f0da5a74 (patch)
tree4c3b96f07bd5c0d65ae3e668875f561c145413c7 /games/xlines/Makefile
parentbb1b92a25241ac39995b5d22febe491009149af5 (diff)
downloadports-378aad359f5a02ec06219b27c2915072f0da5a74.tar.gz
ports-378aad359f5a02ec06219b27c2915072f0da5a74.zip
Notes
Diffstat (limited to 'games/xlines/Makefile')
-rw-r--r--games/xlines/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/games/xlines/Makefile b/games/xlines/Makefile
new file mode 100644
index 000000000000..a0cd6517170a
--- /dev/null
+++ b/games/xlines/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xlines
+# Version required: 1.0
+# Date created: 11 February 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id:$
+#
+
+DISTNAME= xlines
+PKGNAME= xlines-1.0
+CATEGORIES= games x11
+MASTER_SITES= ftp://risq.belcaf.minsk.by/pub/genie/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= qt\\.1\\.:${PORTSDIR}/x11/qt
+BUILD_DEPENDS= moc:${PORTSDIR}/x11/qt
+
+USE_X11= yes
+WRKSRC= ${WRKDIR}
+
+pre-patch:
+ @ ${TR} -d "\015" < ${WRKSRC}/Makefile > ${WRKSRC}/Makefile.new
+ @ ${MV} ${WRKSRC}/Makefile.new ${WRKSRC}/Makefile
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/xlines ${PREFIX}/bin
+ @ ${MKDIR} ${PREFIX}/share/xlines
+ @ ${INSTALL_DATA} ${WRKSRC}/trolltech.gif ${PREFIX}/share/xlines
+ @ ${MKDIR} ${PREFIX}/share/doc/xlines
+ @ ${INSTALL_DATA} ${WRKSRC}/readme.lines ${PREFIX}/share/doc/xlines
+ @ ${INSTALL_DATA} ${WRKSRC}/readme.qt ${PREFIX}/share/doc/xlines
+
+.include <bsd.port.mk>