aboutsummaryrefslogtreecommitdiff
path: root/games/xmahjongg
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2018-07-09 08:29:44 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2018-07-09 08:29:44 +0000
commitd8568dba0c8193089643aad0426ada016c91278d (patch)
tree4a563fe08ba5a2977e6395e51442250f7119392d /games/xmahjongg
parent1637d2415fa038e1a2538b0ae896ee418b0311c7 (diff)
downloadports-d8568dba0c8193089643aad0426ada016c91278d.tar.gz
ports-d8568dba0c8193089643aad0426ada016c91278d.zip
Fix build errors seen by recent C++ compilers.
While being here, add LICENSE.
Notes
Notes: svn path=/head/; revision=474239
Diffstat (limited to 'games/xmahjongg')
-rw-r--r--games/xmahjongg/Makefile6
-rw-r--r--games/xmahjongg/files/patch-lcdf24
2 files changed, 28 insertions, 2 deletions
diff --git a/games/xmahjongg/Makefile b/games/xmahjongg/Makefile
index ac4cc9d9c70c..b17409c161a6 100644
--- a/games/xmahjongg/Makefile
+++ b/games/xmahjongg/Makefile
@@ -3,12 +3,14 @@
PORTNAME= xmahjongg
PORTVERSION= 3.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= http://www.lcdf.org/xmahjongg/
MAINTAINER= joerg@FreeBSD.org
-COMMENT= The Chinese game of Mahjongg for X11
+COMMENT= Chinese game of Mahjongg for X11
+
+LICENSE= GPLv2
USE_XORG= x11
GNU_CONFIGURE= yes
diff --git a/games/xmahjongg/files/patch-lcdf b/games/xmahjongg/files/patch-lcdf
new file mode 100644
index 000000000000..c5af5b7cdb82
--- /dev/null
+++ b/games/xmahjongg/files/patch-lcdf
@@ -0,0 +1,24 @@
+--- include/lcdf/vector.hh.orig 2003-11-17 03:21:23 UTC
++++ include/lcdf/vector.hh
+@@ -7,7 +7,7 @@
+ #elif defined(HAVE_NEW_H)
+ # include <new.h>
+ #else
+-static inline void *operator new(size_t, void *v) { return v; }
++inline void *operator new(size_t, void *v) { return v; }
+ #endif
+
+ template <class T>
+--- liblcdf/permstr.cc.orig 2004-11-21 19:01:59 UTC
++++ liblcdf/permstr.cc
+@@ -111,8 +111,8 @@ static int scatter[] = { /* map c
+ void
+ PermString::initialize(const char* s, int length)
+ {
+- register unsigned char* m = (unsigned char*) s;
+- register unsigned char* mm;
++ unsigned char* m = (unsigned char*) s;
++ unsigned char* mm;
+
+ if (length < 0)
+ length = (s ? strlen(s) : 0);