aboutsummaryrefslogtreecommitdiff
path: root/games/xmille
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-05-27 17:49:44 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-05-27 17:49:44 +0000
commit1d7185ca93f6aaa2331bc39d8b25c4d204a1187f (patch)
tree8b7a275bd360f8eef3edd433ac63629f1e555baf /games/xmille
parent7c22b24e8b7f029b4d9c5865f847555a1b02f292 (diff)
downloadports-1d7185ca93f6aaa2331bc39d8b25c4d204a1187f.tar.gz
ports-1d7185ca93f6aaa2331bc39d8b25c4d204a1187f.zip
Notes
Diffstat (limited to 'games/xmille')
-rw-r--r--games/xmille/Makefile16
-rw-r--r--games/xmille/files/patch-mille.c31
2 files changed, 38 insertions, 9 deletions
diff --git a/games/xmille/Makefile b/games/xmille/Makefile
index 46cdd01625dd..0a94633dd040 100644
--- a/games/xmille/Makefile
+++ b/games/xmille/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: xmille
-# Date created: 30 Dec 1994
-# Whom: swallace
-#
+# Created by: swallace
# $FreeBSD$
-#
PORTNAME= xmille
PORTVERSION= 2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITES= XCONTRIB
MASTER_SITE_SUBDIR= games
DISTNAME= ${PORTNAME}
@@ -21,10 +17,16 @@ WRKSRC= ${WRKDIR}/Mille
USE_IMAKE= yes
USE_XORG= x11 xext
MAN1= xmille.1
+MANCOMPRESSED= no
PLIST_FILES= bin/xmille
MAKE_JOBS_UNSAFE= yes
+CFLAGS+= -Wno-error=return-type
post-extract:
@${FIND} ${WRKSRC} -name '*.[ao]' -delete
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmille ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xmille.man ${MANPREFIX}/man/man1/xmille.1
+
.include <bsd.port.mk>
diff --git a/games/xmille/files/patch-mille.c b/games/xmille/files/patch-mille.c
index e9c179f5a941..3238738b5d85 100644
--- a/games/xmille/files/patch-mille.c
+++ b/games/xmille/files/patch-mille.c
@@ -1,5 +1,5 @@
---- mille.c.orig Thu Mar 28 14:29:31 1996
-+++ mille.c Fri Jun 15 02:27:49 2007
+--- ./mille.c.orig 1996-03-28 06:29:31.000000000 +0100
++++ ./mille.c 2013-05-26 18:05:50.000000000 +0200
@@ -1,16 +1,17 @@
# include "mille.h"
# include <signal.h>
@@ -21,6 +21,33 @@
main(ac, av)
reg int ac;
+@@ -49,8 +50,6 @@
+ /* NOTREACHED */
+ }
+ setbuf(stdout, _sobuf);
+- Play = PLAYER;
+- init_ui ();
+ # ifndef PROF
+ #ifdef sun
+ srandom(getpid());
+@@ -60,6 +59,8 @@
+ # else
+ srand(0);
+ # endif
++ Play = random()&01 ? COMP : PLAYER;
++ init_ui();
+ signal(SIGINT, rub);
+ for (;;) {
+ if (!restore || (Player[PLAYER].total >= 5000
+@@ -73,7 +74,7 @@
+ }
+ do {
+ if (!restore)
+- Handstart = Play = other(Handstart);
++ Handstart = other(Handstart);
+ if (!restore || On_exit) {
+ shuffle();
+ init();
@@ -123,9 +124,9 @@
* Routine to trap rubouts, and make sure they really want to
* quit.