aboutsummaryrefslogtreecommitdiff
path: root/games/xmille
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-05 14:18:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-05 14:18:31 +0000
commitc228905d38a3a39f5e88581b2ec996f1a43cdfa8 (patch)
tree6919dfcb8b22ab48108e5b489036d9fec569ed50 /games/xmille
parentfab0d8e4e60ee5bc3e72b98d5fab9638e6e7deb4 (diff)
downloadports-c228905d38a3a39f5e88581b2ec996f1a43cdfa8.tar.gz
ports-c228905d38a3a39f5e88581b2ec996f1a43cdfa8.zip
Notes
Diffstat (limited to 'games/xmille')
-rw-r--r--games/xmille/Makefile8
-rw-r--r--games/xmille/files/patch-ab61
2 files changed, 58 insertions, 11 deletions
diff --git a/games/xmille/Makefile b/games/xmille/Makefile
index 2206c0a21e94..3ecb7cb1eab9 100644
--- a/games/xmille/Makefile
+++ b/games/xmille/Makefile
@@ -21,13 +21,7 @@ WRKSRC= ${WRKDIR}/Mille
USE_IMAKE= yes
MAN1= xmille.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile due to imake"
-.endif
-
post-extract:
@${FIND} ${WRKSRC} -name '*.[ao]' -delete
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/xmille/files/patch-ab b/games/xmille/files/patch-ab
index f21668f9fd04..cb5a8ddb2635 100644
--- a/games/xmille/files/patch-ab
+++ b/games/xmille/files/patch-ab
@@ -1,11 +1,64 @@
--- Imakefile.orig Thu Apr 2 23:03:24 1992
-+++ Imakefile Wed Jan 31 23:04:28 2001
-@@ -5,7 +5,7 @@
- /**/# Dana Chee
- /**/#
++++ Imakefile Thu Dec 4 21:52:59 2003
+@@ -1,11 +1,11 @@
+-/**/#
+-/**/#
+-/**/# Imakefile for xmille (Mille Bourne game)
+-/**/#
+-/**/# Dana Chee
+-/**/#
++XCOMM #
++XCOMM #
++XCOMM # Imakefile for xmille (Mille Bourne game)
++XCOMM #
++XCOMM # Dana Chee
++XCOMM #
#define IHaveSubdirs
-#define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS) DEFINES=$(DEFINES)'
+#define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS) $(DEFINES)'
HEADERS = ui.h
SRCS= comp.c end.c extern.c init.c mille.c misc.c move.c print.c \
+@@ -18,26 +18,26 @@
+ SYS_LIBRARIES = -lm
+ SUBDIRS = control cards
+
+-/**/#
+-/**/# This looks better with the timrom12 and timrom12b fonts supplied,
+-/**/# but if you don't wish to install it, just use fixed.
+-/**/#
+-/**/# if you do want to use the timrom fonts, then uncomment this line
+-/**/# and see the info below about font targets
+-/**/#
+-/**/#DEFINES = -DDEFAULT_FONT=\"timrom12\" -DDEFAULT_FONTB=\"timrom12b\"
++XCOMM #
++XCOMM # This looks better with the timrom12 and timrom12b fonts supplied,
++XCOMM # but if you don't wish to install it, just use fixed.
++XCOMM #
++XCOMM # if you do want to use the timrom fonts, then uncomment this line
++XCOMM # and see the info below about font targets
++XCOMM #
++XCOMM #DEFINES = -DDEFAULT_FONT=\"timrom12\" -DDEFAULT_FONTB=\"timrom12b\"
+ DEFINES = -DDEFAULT_FONT=\"fixed\" -DDEFAULT_FONTB=\"fixed\"
+
+ MakeSubdirs($(SUBDIRS))
+
+ ComplexProgramTarget(xmille)
+
+-/**/#
+-/**/# Otherwise, make these font targets (uncomment the following lines)
+-/**/#
+-/**/#FONTS = FontBaseObj(timrom12) FontBaseObj(timrom12b)
+-/**/#FONTINSTDIR = $(FONTDIR)/misc
+-/**/#FontTarget(timrom12)
+-/**/#FontTarget(tomrom12b)
+-/**/#all:: $(FONTS)
++XCOMM #
++XCOMM # Otherwise, make these font targets (uncomment the following lines)
++XCOMM #
++XCOMM #FONTS = FontBaseObj(timrom12) FontBaseObj(timrom12b)
++XCOMM #FONTINSTDIR = $(FONTDIR)/misc
++XCOMM #FontTarget(timrom12)
++XCOMM #FontTarget(tomrom12b)
++XCOMM #all:: $(FONTS)
+