aboutsummaryrefslogtreecommitdiff
path: root/games/xminehunter
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-13 20:18:22 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-13 20:18:22 +0000
commit46bc9f608b718e261beb50f8577beb1a8cb5325c (patch)
treee360986924d51c2cf40852e0051dde0b20363f23 /games/xminehunter
parent18b372b0abf620cb461148234c9652c296ec18c8 (diff)
downloadports-46bc9f608b718e261beb50f8577beb1a8cb5325c.tar.gz
ports-46bc9f608b718e261beb50f8577beb1a8cb5325c.zip
Notes
Diffstat (limited to 'games/xminehunter')
-rw-r--r--games/xminehunter/Makefile1
-rw-r--r--games/xminehunter/files/patch-aa17
2 files changed, 13 insertions, 5 deletions
diff --git a/games/xminehunter/Makefile b/games/xminehunter/Makefile
index 45fe16282b4d..25eb38fd0f8b 100644
--- a/games/xminehunter/Makefile
+++ b/games/xminehunter/Makefile
@@ -16,5 +16,4 @@ USE_XORG= xpm
WRKSRC= ${WRKDIR}/xminehunter
ALL_TARGET= xminehunter
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/xminehunter/files/patch-aa b/games/xminehunter/files/patch-aa
index 13e1d26baaac..9779b277e8fc 100644
--- a/games/xminehunter/files/patch-aa
+++ b/games/xminehunter/files/patch-aa
@@ -1,13 +1,13 @@
---- Makefile.orig Mon Jul 22 02:11:34 1996
-+++ Makefile Thu Jan 25 22:22:22 2007
+--- ./Makefile.orig 1996-07-22 03:11:34.000000000 -0300
++++ ./Makefile 2013-11-13 18:22:58.000000000 -0200
@@ -1,9 +1,9 @@
-INSTALL_BIN_PATH = /usr/local/bin
-INSTALL_SCORE_PATH = /usr/local/lib/xminehunter
-
-INCLUDES = -I/usr/local/X11R5/include
-LIBS = -L/usr/local/X11R5/lib -lXm -lXt -lXpm -lXext -lX11
-+INSTALL_BIN_PATH = ${LOCALBASE}/bin
-+INSTALL_SCORE_PATH = ${LOCALBASE}/lib/X11/xminehunter
++INSTALL_BIN_PATH = ${DESTDIR}${PREFIX}/bin
++INSTALL_SCORE_PATH = ${DESTDIR}${PREFIX}/lib/X11/xminehunter
+INCLUDES = -I${LOCALBASE}/include
+LIBS = -L${LOCALBASE}/lib ${MOTIFLIB} -lXt -lXpm -lXext -lX11
@@ -15,3 +15,12 @@
CC = g++
+@@ -50,7 +50,7 @@
+
+ install:
+ mkdir -p ${INSTALL_SCORE_PATH}
+- chmod 333 ${INSTALL_SCORE_PATH}
++ chmod 633 ${INSTALL_SCORE_PATH}
+ cp xminehunter ${INSTALL_BIN_PATH}
+
+ clean: