aboutsummaryrefslogtreecommitdiff
path: root/games/xmoto/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/xmoto/Makefile
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/xmoto/Makefile')
-rw-r--r--games/xmoto/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 25fc5b47ed7a..bf04c7d58c98 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -18,7 +18,7 @@ COMMENT= Challenging 2D motocross platform game
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
curl.4:${PORTSDIR}/ftp/curl
-BUILD_DEPENDS= ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
+BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -30,8 +30,8 @@ USE_DOS2UNIX= src/*.cpp src/*.h
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include -I${LUA_INCDIR}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -L${LUA_LIBDIR}
+CPPFLAGS= -I${LOCALBASE}/include -I${LUA_INCDIR}
+LDFLAGS= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}