aboutsummaryrefslogtreecommitdiff
path: root/games/xmoto
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-08-12 11:14:43 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-08-12 11:14:43 +0000
commit45cbe4911750b78d5b0c106b65e52faebc982ed4 (patch)
tree70a14c422388e0c95d4b71a6962a0754c9bd337d /games/xmoto
parente59a0713d9e26a85c441e9296a6ee8176e6a3f88 (diff)
downloadports-45cbe4911750b78d5b0c106b65e52faebc982ed4.tar.gz
ports-45cbe4911750b78d5b0c106b65e52faebc982ed4.zip
Notes
Diffstat (limited to 'games/xmoto')
-rw-r--r--games/xmoto/Makefile35
-rw-r--r--games/xmoto/distinfo6
-rw-r--r--games/xmoto/pkg-descr2
-rw-r--r--games/xmoto/pkg-plist51
4 files changed, 64 insertions, 30 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 17a3a0002727..b1aefd5bc857 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmoto
-PORTVERSION= 0.2.7
-PORTREVISION= 2
+PORTVERSION= 0.3.2
CATEGORIES= games
MASTER_SITES= http://download.tuxfamily.org/xmoto/xmoto/${PORTVERSION}/ \
http://www.amdmi3.ru/distfiles/
@@ -18,15 +17,16 @@ COMMENT= Challenging 2D motocross platform game
LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
png.5:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ curl.4:${PORTSDIR}/ftp/curl \
+ sqlite3:${PORTSDIR}/databases/sqlite3
BUILD_DEPENDS= ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LUA= 5.1
-USE_SDL= sdl mixer
+USE_SDL= sdl mixer ttf
USE_DOS2UNIX= src/*.cpp src/*.h
-USE_GCC= 3.4+
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -38,21 +38,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= README ChangeLog
-OPTIONS= WWW "Online high-scores and new levels download support" on \
- ZOOM "Enable zooming" off \
+OPTIONS= ZOOM "Enable zooming" on \
SDL_GFX "Use sdl_gfx rendering instead of OpenGL" off
MAN6= xmoto.6
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_WWW)
-LIB_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+= --with-enable-www=1
-.else
-CONFIGURE_ARGS+= --with-enable-www=0
-.endif
-
.if defined(WITH_ZOOM)
CONFIGURE_ARGS+= --with-enable-zoom=1
.else
@@ -67,14 +59,15 @@ USE_GL= yes
CONFIGURE_ARGS+=--with-renderer-sdlGfx=0 --with-renderer-openGl=1
.endif
-.if !defined(WITHOUT_NLS)
+# won't compile WITHOUT_NLS ATM
+#.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CONFIGURE_ENV+= LIBS="-lintl"
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+#.else
+#CONFIGURE_ARGS+= --disable-nls
+#PLIST_SUB+= NLS="@comment "
+#.endif
post-patch:
@${REINPLACE_CMD} -e 's|SDL/||; s|endian.h|sys/endian.h|' \
@@ -82,9 +75,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
${WRKSRC}/src/image/tim_memory_crt.cpp
@${REINPLACE_CMD} -e \
- '/LIBS/ s|\(-lSDL_mixer\)|`${SDL_CONFIG} --libs` \1| ; \
+ '/LIBS/ s|-lSDL_mixer|`${SDL_CONFIG} --libs` &|; \
s|function displayRequirement|displayRequirement()|; \
- /Locales/ s|libc|libintl|' \
+ /Locales/ s|libc|libintl|; s|lua50|luaxx|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/mang|/man6|' ${WRKSRC}/Makefile.in
diff --git a/games/xmoto/distinfo b/games/xmoto/distinfo
index b3ec79eb53be..b31818bef7cb 100644
--- a/games/xmoto/distinfo
+++ b/games/xmoto/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmoto-0.2.7-src.tar.gz) = 4b079ea010561584a61b3d6384b942fc
-SHA256 (xmoto-0.2.7-src.tar.gz) = 6764a7e9148af801eef4870ddab2c2109665d5760acb3d805f073449a83e4e54
-SIZE (xmoto-0.2.7-src.tar.gz) = 12399222
+MD5 (xmoto-0.3.2-src.tar.gz) = 09f40a4cc189033ce0753eadb0a2213e
+SHA256 (xmoto-0.3.2-src.tar.gz) = dbe5143f2a6cf43d7b53f908b2c84891029be1d12df13fdfdc6ece7d11861432
+SIZE (xmoto-0.3.2-src.tar.gz) = 16954891
diff --git a/games/xmoto/pkg-descr b/games/xmoto/pkg-descr
index 4750bd2f395b..84e207b67066 100644
--- a/games/xmoto/pkg-descr
+++ b/games/xmoto/pkg-descr
@@ -2,4 +2,4 @@ X-Moto is a challenging 2D motocross platform game, where physics play an all
important role in the gameplay. You need to control your bike to its limit, if
you want to have a chance finishing the more difficult of the challenges.
-WWW: http://xmoto.sourceforge.net/
+WWW: http://xmoto.tuxfamily.org/
diff --git a/games/xmoto/pkg-plist b/games/xmoto/pkg-plist
index f7841af26b19..51ff9eceb4d1 100644
--- a/games/xmoto/pkg-plist
+++ b/games/xmoto/pkg-plist
@@ -1,13 +1,54 @@
bin/xmoto
-%%NLS%%share/locale/ca/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/de/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/es/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/sk/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/ca_ES/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/cs_CZ/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/de_DE/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/fi_FI/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/fr_FR/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/lv_LV/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/nb_NO/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/nn_NO/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/no_NO/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/pl_PL/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/ru_RU/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/sk_SK/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/sv_SE/LC_MESSAGES/xmoto.mo
+%%DATADIR%%/Textures/Fonts/DejaVuSans.ttf
%%DATADIR%%/Textures/Musics/batcave.ogg
+%%DATADIR%%/Textures/Musics/legolodio.ogg
%%DATADIR%%/Textures/Musics/menu.ogg
%%DATADIR%%/Textures/Musics/ridealong.ogg
%%DATADIR%%/xmoto.bin
+%%DATADIR%%/xmoto_icone_x.ico
+%%NLS%%@dirrmtry share/locale/ca_ES/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ca_ES
+%%NLS%%@dirrmtry share/locale/cs_CZ/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/cs_CZ
+%%NLS%%@dirrmtry share/locale/de_DE/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/de_DE
+%%NLS%%@dirrmtry share/locale/fi_FI/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fi_FI
+%%NLS%%@dirrmtry share/locale/it_IT/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/it_IT
+%%NLS%%@dirrmtry share/locale/lv_LV/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/lv_LV
+%%NLS%%@dirrmtry share/locale/nb_NO/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/nb_NO
+%%NLS%%@dirrmtry share/locale/nn_NO/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/nn_NO
+%%NLS%%@dirrmtry share/locale/no_NO/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/no_NO
+%%NLS%%@dirrmtry share/locale/pl_PL/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pl_PL
+%%NLS%%@dirrmtry share/locale/ru_RU/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ru_RU
+%%NLS%%@dirrmtry share/locale/sk_SK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sk_SK
+%%NLS%%@dirrmtry share/locale/sv_SE/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sv_SE
@dirrm %%DATADIR%%/Textures/Musics
+@dirrm %%DATADIR%%/Textures/Fonts
@dirrm %%DATADIR%%/Textures
@dirrm %%DATADIR%%