aboutsummaryrefslogtreecommitdiff
path: root/games/xmoto
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2008-04-07 03:26:09 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2008-04-07 03:26:09 +0000
commit7063b51163ff812d7786eb5ca0198220beb0fb34 (patch)
tree1bb71f3686390d2b15622122158281b764c82034 /games/xmoto
parentf4c7b3cc50e9bff1312a07dd5fedcf38754029e1 (diff)
downloadports-7063b51163ff812d7786eb5ca0198220beb0fb34.tar.gz
ports-7063b51163ff812d7786eb5ca0198220beb0fb34.zip
Notes
Diffstat (limited to 'games/xmoto')
-rw-r--r--games/xmoto/Makefile1
-rw-r--r--games/xmoto/files/patch-configure29
2 files changed, 30 insertions, 0 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index f8b7151fa557..25fc5b47ed7a 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -22,6 +22,7 @@ BUILD_DEPENDS= ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_GNOME= pkgconfig
USE_LUA= 5.1
USE_SQLITE= yes
USE_SDL= sdl mixer ttf
diff --git a/games/xmoto/files/patch-configure b/games/xmoto/files/patch-configure
new file mode 100644
index 000000000000..847ae82508a1
--- /dev/null
+++ b/games/xmoto/files/patch-configure
@@ -0,0 +1,29 @@
+--- configure.orig 2008-04-06 23:15:13.000000000 -0300
++++ configure 2008-04-06 23:16:55.000000000 -0300
+@@ -5101,7 +5101,7 @@
+ cat >>confdefs.h <<_ACEOF
+ #define `echo "HAVE_$ac_header" | $as_tr_cpp` 1
+ _ACEOF
+- SQLITE_LIBS=-lsqlite3
++ SQLITE_LIBS=`pkg-config --static --libs sqlite3`
+ else
+ { { echo "$as_me:$LINENO: error: \"sqlite3 required\"" >&5
+ echo "$as_me: error: \"sqlite3 required\"" >&2;}
+@@ -5117,7 +5117,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lsqlite3 $LIBS"
++LIBS="`pkg-config --static --libs sqlite3` $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -5171,7 +5171,7 @@
+ #define HAVE_LIBSQLITE3 1
+ _ACEOF
+
+- LIBS="-lsqlite3 $LIBS"
++ LIBS="`pkg-config --static --libs sqlite3` $LIBS"
+
+ else
+ { { echo "$as_me:$LINENO: error: \"Linking against sqlite3 failed.\"" >&5