aboutsummaryrefslogtreecommitdiff
path: root/games/xmoto
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-14 15:13:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-14 15:13:30 +0000
commit9b65c3f97341842ccbd926c0b22aaec3b9378c0e (patch)
treedc3b72fd3f24573b20e384758064807403ea0eb1 /games/xmoto
parentb64641cd1ef5abbf19b3dc11adeef82a67ae00ff (diff)
downloadports-9b65c3f97341842ccbd926c0b22aaec3b9378c0e.tar.gz
ports-9b65c3f97341842ccbd926c0b22aaec3b9378c0e.zip
- Pet portlint
- Switch to USES=localbase - Switch to options helpers - Regenerate patches
Notes
Notes: svn path=/head/; revision=426113
Diffstat (limited to 'games/xmoto')
-rw-r--r--games/xmoto/Makefile30
-rw-r--r--games/xmoto/files/patch-src-GameInit.cpp4
-rw-r--r--games/xmoto/files/patch-src-VTexture.h6
-rw-r--r--games/xmoto/files/patch-src-WWW.cpp4
-rw-r--r--games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp10
-rw-r--r--games/xmoto/files/patch-src-helpers-System.cpp10
-rw-r--r--games/xmoto/files/patch-src-include-xm__hashmap.h4
7 files changed, 34 insertions, 34 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 6488ee84dae8..10bd467e04dc 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -12,29 +12,36 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Challenging 2D motocross platform game
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libpng.so:graphics/png \
libcurl.so:ftp/curl \
libxdg-basedir.so:x11/libxdg-basedir
BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:devel/ode
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
-
GNU_CONFIGURE= yes
-USES= compiler:features dos2unix gmake jpeg lua:51 sqlite
+USES= compiler:features dos2unix gmake jpeg localbase lua:51 sqlite
USE_GNOME= libxml2
USE_SDL= sdl mixer ttf net
USE_GL= gl glu
DOS2UNIX_GLOB= *.cpp *.h
-CPPFLAGS+= -I${LOCALBASE}/include -I${LUA_INCDIR}
-LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
+CPPFLAGS+= -isystem${LUA_INCDIR}
+LDFLAGS+= -L${LUA_LIBDIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= README ChangeLog
PORTDATA= *
+DESKTOP_ENTRIES="XMoto" \
+ "Motorcross game" \
+ "${DATADIR}/xmoto_icone_x.ico" \
+ "xmoto" \
+ "Game;SportsGame;ArcadeGame;" \
+ false
+
OPTIONS_DEFINE= ASIAN_TTF DOCS NLS
OPTIONS_SUB= yes
@@ -47,13 +54,6 @@ ASIAN_TTF_CONFIGURE_OFF=--without-asian-ttf-file
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-DESKTOP_ENTRIES="XMoto" \
- "Motorcross game" \
- "${DATADIR}/xmoto_icone_x.ico" \
- "xmoto" \
- "Game;SportsGame;ArcadeGame;" \
- false
-
.include <bsd.port.pre.mk>
.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
@@ -66,8 +66,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e "s/lua5.1/lua-${LUA_VER}/g" ${WRKSRC}/configure
-post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
diff --git a/games/xmoto/files/patch-src-GameInit.cpp b/games/xmoto/files/patch-src-GameInit.cpp
index 9796ebdf65fb..f1af17b61b4c 100644
--- a/games/xmoto/files/patch-src-GameInit.cpp
+++ b/games/xmoto/files/patch-src-GameInit.cpp
@@ -1,5 +1,5 @@
---- src/GameInit.cpp.orig 2015-01-10 18:22:36.000000000 +0100
-+++ src/GameInit.cpp 2015-01-10 18:27:28.000000000 +0100
+--- src/GameInit.cpp.orig 2011-10-11 20:18:35 UTC
++++ src/GameInit.cpp
@@ -248,7 +248,7 @@ void GameApp::run_load(int nNumArgs, cha
Logger::setActiv(XMSession::instance()->noLog() == false); /* apply log activ mode */
diff --git a/games/xmoto/files/patch-src-VTexture.h b/games/xmoto/files/patch-src-VTexture.h
index 9932bfe4962d..ab8dcd92d31a 100644
--- a/games/xmoto/files/patch-src-VTexture.h
+++ b/games/xmoto/files/patch-src-VTexture.h
@@ -1,6 +1,6 @@
---- src/VTexture.h.orig 2011-10-12 00:18:35.000000000 +0400
-+++ src/VTexture.h 2014-11-24 22:08:42.749026473 +0300
-@@ -135,7 +135,7 @@
+--- src/VTexture.h.orig 2011-10-11 20:18:35 UTC
++++ src/VTexture.h
+@@ -135,7 +135,7 @@ private:
void cleanUnregistredTextures();
diff --git a/games/xmoto/files/patch-src-WWW.cpp b/games/xmoto/files/patch-src-WWW.cpp
index faaaf07d79ad..b9dd3df2540f 100644
--- a/games/xmoto/files/patch-src-WWW.cpp
+++ b/games/xmoto/files/patch-src-WWW.cpp
@@ -1,5 +1,5 @@
---- src/WWW.cpp.orig 2015-01-10 18:11:22.000000000 +0100
-+++ src/WWW.cpp 2015-01-10 18:21:32.000000000 +0100
+--- src/WWW.cpp.orig 2011-10-11 20:18:35 UTC
++++ src/WWW.cpp
@@ -206,7 +206,7 @@ void FSWeb::downloadFile(const std::stri
std::string v_www_agent = WWW_AGENT;
diff --git a/games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp b/games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp
index 6230ef38dbdc..142ccfe0fb23 100644
--- a/games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp
+++ b/games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp
@@ -1,6 +1,6 @@
---- src/drawlib/DrawLibOpenGL.cpp.orig 2011-10-12 00:18:26.000000000 +0400
-+++ src/drawlib/DrawLibOpenGL.cpp 2014-11-24 22:08:12.925973647 +0300
-@@ -80,7 +80,7 @@
+--- src/drawlib/DrawLibOpenGL.cpp.orig 2011-10-11 20:18:26 UTC
++++ src/drawlib/DrawLibOpenGL.cpp
+@@ -80,7 +80,7 @@ public:
/* a glyph from other glyphs */
/*kejo:why not just grrr create a copy contructor*/
GLFontGlyph(const std::string& i_value,
@@ -9,7 +9,7 @@
virtual ~GLFontGlyph();
std::string Value() const;
-@@ -132,11 +132,11 @@
+@@ -132,11 +132,11 @@ public:
private:
std::vector<std::string> m_glyphsKeys;
std::vector<GLFontGlyph*> m_glyphsValues;
@@ -23,7 +23,7 @@
unsigned int getLonguestLineSize(const std::string& i_value, unsigned int i_start = 0, unsigned int i_nbLinesToRead = -1);
};
-@@ -825,7 +825,7 @@
+@@ -825,7 +825,7 @@ GLFontGlyph::GLFontGlyph(const std::stri
}
GLFontGlyph::GLFontGlyph(const std::string& i_value,
diff --git a/games/xmoto/files/patch-src-helpers-System.cpp b/games/xmoto/files/patch-src-helpers-System.cpp
index e95613e9d1eb..8de4695f8677 100644
--- a/games/xmoto/files/patch-src-helpers-System.cpp
+++ b/games/xmoto/files/patch-src-helpers-System.cpp
@@ -1,8 +1,8 @@
---- src/helpers/System.cpp.orig 2011-10-12 00:18:14.000000000 +0400
-+++ src/helpers/System.cpp 2013-09-13 22:36:38.029229232 +0400
-@@ -25,6 +25,8 @@
- #include "VExcept.h"
- #include <sstream>
+--- src/helpers/System.cpp.orig 2014-03-29 06:14:14 UTC
++++ src/helpers/System.cpp
+@@ -31,6 +31,8 @@ Foundation, Inc., 59 Temple Place, Suite
+ #include <unistd.h>
+ #endif
+#include <unistd.h> // for getpid()
+
diff --git a/games/xmoto/files/patch-src-include-xm__hashmap.h b/games/xmoto/files/patch-src-include-xm__hashmap.h
index 96d68172a9ae..c6c6977656d8 100644
--- a/games/xmoto/files/patch-src-include-xm__hashmap.h
+++ b/games/xmoto/files/patch-src-include-xm__hashmap.h
@@ -1,5 +1,5 @@
---- src/include/xm_hashmap.h.orig 2015-01-12 23:04:54.000000000 +0100
-+++ src/include/xm_hashmap.h 2015-01-12 23:07:53.000000000 +0100
+--- src/include/xm_hashmap.h.orig 2011-10-11 20:18:17 UTC
++++ src/include/xm_hashmap.h
@@ -13,13 +13,18 @@
#include <hash_map>
namespace HashNamespace=std;