aboutsummaryrefslogtreecommitdiff
path: root/games/xmoto
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-12-11 03:14:14 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-12-11 03:14:14 +0000
commit20c20f92f60b937c5e68fa0c156b0b1777d46d9e (patch)
treedcd83775411a9f09e720f953231e19bec2d887cc /games/xmoto
parent0def3860fe2793e274e0411c8edb8d6d4a311cfb (diff)
downloadports-20c20f92f60b937c5e68fa0c156b0b1777d46d9e.tar.gz
ports-20c20f92f60b937c5e68fa0c156b0b1777d46d9e.zip
Notes
Diffstat (limited to 'games/xmoto')
-rw-r--r--games/xmoto/Makefile22
-rw-r--r--games/xmoto/distinfo4
-rw-r--r--games/xmoto/files/patch-configure11
-rw-r--r--games/xmoto/files/patch-tim_png.cpp10
4 files changed, 20 insertions, 27 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index c61d8f836bf9..1240dc9bde17 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: xmoto
-# Date created: 07 Oct 2005
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= xmoto
-PORTVERSION= 0.5.8
-PORTREVISION= 3
+PORTVERSION= 0.5.10
CATEGORIES= games
MASTER_SITES= http://download.tuxfamily.org/xmoto/xmoto/${PORTVERSION}/ \
http://mirror.amdmi3.ru/distfiles/
@@ -39,7 +34,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= README ChangeLog
-OPTIONS= ASIAN_TTF "Use asian TTF font" off
+OPTIONS_DEFINE= ASIAN_TTF
+ASIAN_TTF_DESC= "Use asian TTF font"
MAN6= xmoto.6
@@ -56,14 +52,14 @@ DESKTOP_ENTRIES="XMoto" \
BROKEN= does not compile due to missing getline()
.endif
-.if defined(WITH_ASIAN_TTF)
+.if ${PORT_OPTIONS:MASIAN_TTF}
RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/TrueType/bkai00mp.ttf:${PORTSDIR}/chinese/arphicttf
CONFIGURE_ARGS+=--with-asian-ttf-file=${LOCALBASE}/lib/X11/fonts/TrueType/bsmi00lp.ttf
.else
CONFIGURE_ARGS+=--without-asian-ttf-file
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CONFIGURE_ENV+= LIBS="-lintl"
@@ -72,11 +68,7 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-post-patch:
- ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/src/image/tim_png.cpp
-
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
diff --git a/games/xmoto/distinfo b/games/xmoto/distinfo
index 2bf81913ac17..e4fda9fbcc33 100644
--- a/games/xmoto/distinfo
+++ b/games/xmoto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xmoto-0.5.8-src.tar.gz) = c9592d54ba571b868e95ccb66544032608ad6b67b29a33b5c12baaa5e6a705b4
-SIZE (xmoto-0.5.8-src.tar.gz) = 40378449
+SHA256 (xmoto-0.5.10-src.tar.gz) = 2d2438e4685aa5fc1aa9f73bfbe26893d7fc97fadd6e1cc9fdb09c8d16df9e1e
+SIZE (xmoto-0.5.10-src.tar.gz) = 40766628
diff --git a/games/xmoto/files/patch-configure b/games/xmoto/files/patch-configure
new file mode 100644
index 000000000000..2efb2a2b33d5
--- /dev/null
+++ b/games/xmoto/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2012-05-03 23:37:06.000000000 +0400
++++ configure 2012-12-11 03:40:16.510933187 +0400
+@@ -5803,7 +5803,7 @@
+
+ CPPFLAGS="$CPPFLAGS"" ""$XML_CPPFLAGS"
+ CFLAGS="$CFLAGS"" ""$XML_CPPFLAGS"
+-LIBS="$LIBS""$XML_LIBS"
++LIBS="$LIBS"" ""$XML_LIBS"
+ fi
+
+ if test "$target_os" = "mingw32" # on windows, don't include libbz2
diff --git a/games/xmoto/files/patch-tim_png.cpp b/games/xmoto/files/patch-tim_png.cpp
deleted file mode 100644
index b91bbbb515cb..000000000000
--- a/games/xmoto/files/patch-tim_png.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/image/tim_png.cpp.orig 2012-04-25 06:16:33.000000000 +0200
-+++ src/image/tim_png.cpp 2012-04-25 06:16:57.000000000 +0200
-@@ -26,6 +26,7 @@
- #include <string.h>
- #include "tim.h"
- #include "png.h"
-+#include "zlib.h"
-
- /*==============================================================================
- Types