aboutsummaryrefslogtreecommitdiff
path: root/games/xmoto
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-22 00:40:04 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-22 00:40:04 +0000
commitb2003d2b473f40728c67c9a05d3a2770e57e6aba (patch)
tree4db134bfbe28b4a52452be5e735691bc3e9713a7 /games/xmoto
parent94b64b934c1aac6406a39d9d89c9081e62bc2b79 (diff)
downloadports-b2003d2b473f40728c67c9a05d3a2770e57e6aba.tar.gz
ports-b2003d2b473f40728c67c9a05d3a2770e57e6aba.zip
Notes
Diffstat (limited to 'games/xmoto')
-rw-r--r--games/xmoto/Makefile33
-rw-r--r--games/xmoto/distinfo6
-rw-r--r--games/xmoto/files/patch-src-Locales.h11
-rw-r--r--games/xmoto/files/patch-src-VCommon.h8
-rw-r--r--games/xmoto/pkg-plist3
5 files changed, 49 insertions, 12 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index c8d9980c4641..beab714937e6 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmoto
-PORTVERSION= 0.2.0
-PORTREVISION= 1
+PORTVERSION= 0.2.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -32,17 +31,39 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include -I${LUA_INCDIR}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -L${LUA_LIBDIR}
+MANCOMPRESSED= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= README ChangeLog
-OPTIONS= CURL "Online high-scores and new levels download support" on
+OPTIONS= WWW "Online high-scores and new levels download support" on \
+ ZOOM "Enable zooming" off
+
+MAN6= xmoto.6 xmoto-edit.6
.include <bsd.port.pre.mk>
-.if defined(WITH_CURL)
+.if !defined(WITHOUT_WWW)
LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --with-enable-www=1
+.else
+CONFIGURE_ARGS+= --with-enable-www=0
+.endif
+
+.if defined(WITH_ZOOM)
+CONFIGURE_ARGS+= --with-enable-zoom=1
+.else
+CONFIGURE_ARGS+= --with-enable-zoom=0
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CONFIGURE_ENV+= LIBS="-lintl"
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@@ -52,8 +73,10 @@ post-patch:
${WRKSRC}/src/image/tim_memory_crt.cpp
@${REINPLACE_CMD} -e \
'/LIBS/ s|\(-lSDL_mixer\)|`${SDL_CONFIG} --libs` \1| ; \
- s|test $$ac_cv_lib_curl_curl_easy_init = yes|false|' \
+ s|function displayRequirement|displayRequirement()|; \
+ /Locales/ s|libc|libintl|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/mang|/man6|' ${WRKSRC}/Makefile.in
.if !defined(NOPORTDOCS)
post-install:
diff --git a/games/xmoto/distinfo b/games/xmoto/distinfo
index cb4b0a81e566..7bb0cab0ea4b 100644
--- a/games/xmoto/distinfo
+++ b/games/xmoto/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmoto-0.2.0-src.tar.gz) = 0404467792034dd221b92303f2750ac7
-SHA256 (xmoto-0.2.0-src.tar.gz) = ee742446d0e37ca59d8157f857874b97b59fe23115001223fa56e7ee529754f9
-SIZE (xmoto-0.2.0-src.tar.gz) = 5607598
+MD5 (xmoto-0.2.1-src.tar.gz) = e5acce4c304db1cade31e6cc2d5abfde
+SHA256 (xmoto-0.2.1-src.tar.gz) = 9d7faa1a9196a6626f5edba7b590c0306eb16b35d5b3724fda7311ccb35de17c
+SIZE (xmoto-0.2.1-src.tar.gz) = 5755501
diff --git a/games/xmoto/files/patch-src-Locales.h b/games/xmoto/files/patch-src-Locales.h
new file mode 100644
index 000000000000..9603acd3cd94
--- /dev/null
+++ b/games/xmoto/files/patch-src-Locales.h
@@ -0,0 +1,11 @@
+--- src/Locales.h.orig Tue Sep 19 05:51:55 2006
++++ src/Locales.h Tue Sep 19 05:55:02 2006
+@@ -22,6 +22,8 @@
+ #ifndef __LOCALES_H__
+ #define __LOCALES_H__
+
++#include "BuildConfig.h"
++
+ #ifndef USE_GETTEXT
+ #define _(a) a
+ #else
diff --git a/games/xmoto/files/patch-src-VCommon.h b/games/xmoto/files/patch-src-VCommon.h
index 047bcfd38d27..7efb2cdfd038 100644
--- a/games/xmoto/files/patch-src-VCommon.h
+++ b/games/xmoto/files/patch-src-VCommon.h
@@ -1,12 +1,12 @@
---- src/VCommon.h.orig Thu Jul 20 21:51:42 2006
-+++ src/VCommon.h Fri Jul 28 15:59:16 2006
-@@ -62,8 +62,7 @@
+--- src/VCommon.h.orig Tue Sep 12 22:29:01 2006
++++ src/VCommon.h Sat Sep 16 17:45:59 2006
+@@ -70,8 +70,7 @@
#include <string>
#include <vector>
#include <queue>
-#include <ostream>
-#include <istream>
+#include <iostream>
+ #include <sstream>
#include <stdio.h>
- #include <math.h>
diff --git a/games/xmoto/pkg-plist b/games/xmoto/pkg-plist
index 2c4e2139d691..760d0730bc20 100644
--- a/games/xmoto/pkg-plist
+++ b/games/xmoto/pkg-plist
@@ -1,7 +1,10 @@
bin/xmoto
bin/xmoto-edit
+%%NLS%%share/locale/fr/LC_MESSAGES/xmoto.mo
%%DATADIR%%/editor.dat
%%DATADIR%%/fonts.dat
%%DATADIR%%/xmoto.bin
%%DATADIR%%/xmoto.ogg
+%%NLS%%@dirrmtry share/locale/fr/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fr
@dirrm %%DATADIR%%